summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/imx-mkimage/imx-boot_1.0.bb')
-rw-r--r--recipes-bsp/imx-mkimage/imx-boot_1.0.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
index 4b6ef699..a54b439d 100644
--- a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
+++ b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
@@ -126,20 +126,20 @@ compile_mx8x() {
126 fi 126 fi
127} 127}
128do_compile() { 128do_compile() {
129 compile_${SOC_FAMILY}
130 # mkimage for i.MX8 129 # mkimage for i.MX8
131 # Copy TEE binary to SoC target folder to mkimage 130 # Copy TEE binary to SoC target folder to mkimage
132 if ${DEPLOY_OPTEE}; then 131 if ${DEPLOY_OPTEE}; then
133 cp ${DEPLOY_DIR_IMAGE}/tee.bin ${BOOT_STAGING} 132 cp ${DEPLOY_DIR_IMAGE}/tee.bin ${BOOT_STAGING}
134 fi 133 fi
135 for target in ${IMXBOOT_TARGETS}; do 134 for target in ${IMXBOOT_TARGETS}; do
135 compile_${SOC_FAMILY}
136 if [ "$target" = "flash_linux_m4_no_v2x" ]; then 136 if [ "$target" = "flash_linux_m4_no_v2x" ]; then
137 # Special target build for i.MX 8DXL with V2X off 137 # Special target build for i.MX 8DXL with V2X off
138 bbnote "building ${SOC_TARGET} - ${REV_OPTION} V2X=NO ${target}" 138 bbnote "building ${SOC_TARGET} - ${REV_OPTION} V2X=NO ${target}"
139 make SOC=${SOC_TARGET} ${REV_OPTION} V2X=NO flash_linux_m4 139 make SOC=${SOC_TARGET} ${REV_OPTION} V2X=NO dtbs=${UBOOT_DTB_NAME} flash_linux_m4
140 else 140 else
141 bbnote "building ${SOC_TARGET} - ${REV_OPTION} ${target}" 141 bbnote "building ${SOC_TARGET} - ${REV_OPTION} ${target}"
142 make SOC=${SOC_TARGET} ${REV_OPTION} ${target} 142 make SOC=${SOC_TARGET} ${REV_OPTION} dtbs=${UBOOT_DTB_NAME} ${target}
143 fi 143 fi
144 if [ -e "${BOOT_STAGING}/flash.bin" ]; then 144 if [ -e "${BOOT_STAGING}/flash.bin" ]; then
145 cp ${BOOT_STAGING}/flash.bin ${S}/${BOOT_CONFIG_MACHINE}-${target} 145 cp ${BOOT_STAGING}/flash.bin ${S}/${BOOT_CONFIG_MACHINE}-${target}