summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-atf/imx-atf_2.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/imx-atf/imx-atf_2.6.bb')
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.6.bb16
1 files changed, 12 insertions, 4 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.6.bb b/recipes-bsp/imx-atf/imx-atf_2.6.bb
index b0cd4d3d..194ef935 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.6.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.6.bb
@@ -18,9 +18,11 @@ S = "${WORKDIR}/git"
18 18
19inherit deploy 19inherit deploy
20 20
21BOOT_TOOLS = "imx-boot-tools" 21ATF_PLATFORM ??= "INVALID"
22 22
23ATF_PLATFORM ??= "INVALID" 23# FIXME: We should return INVALID here but currently only i.MX8M has support to override the UART
24# base address in source code.
25ATF_BOOT_UART_BASE ?= ""
24 26
25EXTRA_OEMAKE += " \ 27EXTRA_OEMAKE += " \
26 CROSS_COMPILE="${TARGET_PREFIX}" \ 28 CROSS_COMPILE="${TARGET_PREFIX}" \
@@ -34,7 +36,8 @@ AS[unexport] = "1"
34LD[unexport] = "1" 36LD[unexport] = "1"
35 37
36# Baremetal, just need a compiler 38# Baremetal, just need a compiler
37DEPENDS:remove = "virtual/${TARGET_PREFIX}compilerlibs virtual/libc" 39INHIBIT_DEFAULT_DEPS = "1"
40DEPENDS = "virtual/${HOST_PREFIX}gcc"
38 41
39BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}" 42BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}"
40 43
@@ -49,6 +52,11 @@ EXTRA_OEMAKE += 'LD="${@remove_options_tail(d.getVar('LD'))}"'
49 52
50EXTRA_OEMAKE += 'CC="${@remove_options_tail(d.getVar('CC'))}"' 53EXTRA_OEMAKE += 'CC="${@remove_options_tail(d.getVar('CC'))}"'
51 54
55# Set the UART to use during the boot.
56EXTRA_OEMAKE += 'IMX_BOOT_UART_BASE=${ATF_BOOT_UART_BASE}'
57
58do_configure[noexec] = "1"
59
52do_compile() { 60do_compile() {
53 # Clear LDFLAGS to avoid the option -Wl recognize issue 61 # Clear LDFLAGS to avoid the option -Wl recognize issue
54 oe_runmake bl31 62 oe_runmake bl31
@@ -68,5 +76,5 @@ do_deploy() {
68} 76}
69addtask deploy after do_compile 77addtask deploy after do_compile
70 78
71PACKAGE_ARCH = "${MACHINE_SOCARCH}" 79PACKAGE_ARCH = "${MACHINE_ARCH}"
72COMPATIBLE_MACHINE = "(mx8-generic-bsp)" 80COMPATIBLE_MACHINE = "(mx8-generic-bsp)"