summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-atf/imx-atf_2.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/imx-atf/imx-atf_2.4.bb')
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.4.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.4.bb b/recipes-bsp/imx-atf/imx-atf_2.4.bb
index 8792c0cd..ce30822e 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.4.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.4.bb
@@ -36,6 +36,17 @@ DEPENDS:remove = "virtual/${TARGET_PREFIX}compilerlibs virtual/libc"
36 36
37BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}" 37BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}"
38 38
39# CC and LD introduce arguments which conflict with those otherwise provided by
40# this recipe. The heads of these variables excluding those arguments
41# are therefore used instead.
42def remove_options_tail (in_string):
43 from itertools import takewhile
44 return ' '.join(takewhile(lambda x: not x.startswith('-'), in_string.split(' ')))
45
46EXTRA_OEMAKE += "LD=${@remove_options_tail(d.getVar('LD'))}"
47
48EXTRA_OEMAKE += "CC=${@remove_options_tail(d.getVar('CC'))}"
49
39do_compile() { 50do_compile() {
40 # Clear LDFLAGS to avoid the option -Wl recognize issue 51 # Clear LDFLAGS to avoid the option -Wl recognize issue
41 oe_runmake bl31 52 oe_runmake bl31