summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-atf/imx-atf_2.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/imx-atf/imx-atf_2.4.bb')
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.4.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.4.bb b/recipes-bsp/imx-atf/imx-atf_2.4.bb
new file mode 100644
index 00000000..07807eff
--- /dev/null
+++ b/recipes-bsp/imx-atf/imx-atf_2.4.bb
@@ -0,0 +1,51 @@
1# Copyright (C) 2017-2021 NXP
2
3DESCRIPTION = "i.MX ARM Trusted Firmware"
4SECTION = "BSP"
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
7
8PV .= "+git${SRCPV}"
9
10SRCBRANCH = "imx_5.4.70_2.3.0"
11SRC_URI = "git://source.codeaurora.org/external/imx/imx-atf.git;protocol=https;branch=${SRCBRANCH} \
12"
13SRCREV = "2a26786460edd4f0ec3111e7027c93c57fc572c1"
14
15S = "${WORKDIR}/git"
16
17inherit deploy
18
19BOOT_TOOLS = "imx-boot-tools"
20
21ATF_PLATFORM ??= "INVALID"
22
23EXTRA_OEMAKE += " \
24 CROSS_COMPILE="${TARGET_PREFIX}" \
25 PLAT=${ATF_PLATFORM} \
26"
27
28BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}"
29
30do_compile() {
31 # Clear LDFLAGS to avoid the option -Wl recognize issue
32 unset LDFLAGS
33 oe_runmake bl31
34 if ${BUILD_OPTEE}; then
35 oe_runmake clean BUILD_BASE=build-optee
36 oe_runmake BUILD_BASE=build-optee SPD=opteed bl31
37 fi
38}
39
40do_install[noexec] = "1"
41
42do_deploy() {
43 install -Dm 0644 ${S}/build/${ATF_PLATFORM}/release/bl31.bin ${DEPLOYDIR}/${BOOT_TOOLS}/bl31-${ATF_PLATFORM}.bin
44 if ${BUILD_OPTEE}; then
45 install -m 0644 ${S}/build-optee/${ATF_PLATFORM}/release/bl31.bin ${DEPLOYDIR}/${BOOT_TOOLS}/bl31-${ATF_PLATFORM}.bin-optee
46 fi
47}
48addtask deploy after do_compile
49
50PACKAGE_ARCH = "${MACHINE_SOCARCH}"
51COMPATIBLE_MACHINE = "(mx8|imx-boot-container)"