summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/ddr-phy/ddr-phy_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/ddr-phy/ddr-phy_git.bb')
-rw-r--r--recipes-bsp/ddr-phy/ddr-phy_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-bsp/ddr-phy/ddr-phy_git.bb b/recipes-bsp/ddr-phy/ddr-phy_git.bb
new file mode 100644
index 00000000..ebd68c26
--- /dev/null
+++ b/recipes-bsp/ddr-phy/ddr-phy_git.bb
@@ -0,0 +1,29 @@
1SUMMARY = "DDR firmware repository"
2LICENSE = "NXP-Binary-EULA"
3LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=89cc852481956e861228286ac7430d74"
4
5inherit deploy fsl-eula-unpack
6
7SRC_URI = "git://github.com/nxp/ddr-phy-binary.git;fsl-eula=true;nobranch=1"
8SRCREV = "14d03e6e748ed5ebb9440f264bb374f1280b061c"
9
10S = "${WORKDIR}/git"
11
12REGLEX_lx2160a = "lx2160a"
13
14do_install () {
15 install -d ${D}/boot
16 install -m 755 ${S}/${REGLEX}/* ${D}/boot
17}
18
19do_deploy () {
20 install -d ${DEPLOYDIR}/ddr-phy
21 install -m 755 ${S}/${REGLEX}/* ${DEPLOYDIR}/ddr-phy
22}
23addtask deploy before do_populate_sysroot after do_install
24
25PACKAGES += "${PN}-image"
26FILES_${PN}-image += "/boot"
27
28COMPATIBLE_MACHINE = "(lx2160a)"
29PACKAGE_ARCH = "${MACHINE_ARCH}"