summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/atf
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/atf')
-rw-r--r--recipes-bsp/atf/atf/0001-Makefile-add-CC-gcc.patch28
-rw-r--r--recipes-bsp/atf/atf/0001-fix-fiptool-build-error.patch28
-rw-r--r--recipes-bsp/atf/atf_git.bb4
3 files changed, 0 insertions, 60 deletions
diff --git a/recipes-bsp/atf/atf/0001-Makefile-add-CC-gcc.patch b/recipes-bsp/atf/atf/0001-Makefile-add-CC-gcc.patch
deleted file mode 100644
index efa2749e..00000000
--- a/recipes-bsp/atf/atf/0001-Makefile-add-CC-gcc.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From 3161524085339ae214f7dee17a98ccd6c442d66b Mon Sep 17 00:00:00 2001
2From: Chunrong Guo <chunrong.guo@nxp.com>
3Date: Thu, 16 Aug 2018 17:38:04 +0800
4Subject: [PATCH] Makefile: add CC=gcc
5
6
7Upstream-Status: Inappropriate [embedded specific]
8
9Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
10---
11 plat/nxp/tools/Makefile | 1 +
12 1 file changed, 1 insertion(+)
13
14diff --git a/plat/nxp/tools/Makefile b/plat/nxp/tools/Makefile
15index e648fd1..43d3b56 100644
16--- a/plat/nxp/tools/Makefile
17+++ b/plat/nxp/tools/Makefile
18@@ -32,6 +32,7 @@ endif
19 INCLUDE_PATHS :=
20
21 HOSTCC ?= gcc
22+CC = gcc
23
24 .PHONY: all clean distclean
25
26--
272.7.4
28
diff --git a/recipes-bsp/atf/atf/0001-fix-fiptool-build-error.patch b/recipes-bsp/atf/atf/0001-fix-fiptool-build-error.patch
deleted file mode 100644
index ffd9965a..00000000
--- a/recipes-bsp/atf/atf/0001-fix-fiptool-build-error.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From a76ae26fdb673613f5f97872b7275c630b7b24b8 Mon Sep 17 00:00:00 2001
2From: BJ DevOps Team <bjdevops@NXP1.onmicrosoft.com>
3Date: Wed, 16 May 2018 13:26:45 +0800
4Subject: [PATCH] fix fiptool build error
5
6Upstream-Status: Inappropriate [embedded specific]
7
8---
9 tools/fiptool/Makefile | 3 ++-
10 1 file changed, 2 insertions(+), 1 deletion(-)
11
12diff --git a/tools/fiptool/Makefile b/tools/fiptool/Makefile
13index e0e3923..f213f44 100644
14--- a/tools/fiptool/Makefile
15+++ b/tools/fiptool/Makefile
16@@ -19,7 +19,8 @@ ifeq (${DEBUG},1)
17 else
18 CFLAGS += -O2
19 endif
20-LDLIBS := -lcrypto
21+
22+LDLIBS := -Wl,-rpath=${LIBPATH}/usr/lib -L${LIBPATH}/usr/lib -lcrypto
23
24 ifeq (${V},0)
25 Q := @
26--
271.8.3.1
28
diff --git a/recipes-bsp/atf/atf_git.bb b/recipes-bsp/atf/atf_git.bb
index dcc3689a..a93cb804 100644
--- a/recipes-bsp/atf/atf_git.bb
+++ b/recipes-bsp/atf/atf_git.bb
@@ -14,10 +14,6 @@ S = "${WORKDIR}/git"
14SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/atf;nobranch=1" 14SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/atf;nobranch=1"
15SRCREV = "7d748e6f0ec652ba7c43733dc67a3d0b0217390a" 15SRCREV = "7d748e6f0ec652ba7c43733dc67a3d0b0217390a"
16 16
17SRC_URI += "file://0001-fix-fiptool-build-error.patch \
18 file://0001-Makefile-add-CC-gcc.patch \
19"
20
21COMPATIBLE_MACHINE = "(qoriq)" 17COMPATIBLE_MACHINE = "(qoriq)"
22 18
23PACKAGE_ARCH = "${MACHINE_ARCH}" 19PACKAGE_ARCH = "${MACHINE_ARCH}"