summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/atf
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/atf')
-rw-r--r--recipes-bsp/atf/atf-tools_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-bsp/atf/atf-tools_git.bb b/recipes-bsp/atf/atf-tools_git.bb
new file mode 100644
index 00000000..a5998fe2
--- /dev/null
+++ b/recipes-bsp/atf/atf-tools_git.bb
@@ -0,0 +1,19 @@
1SUMMARY = "Tools for ARM Trusted Firmware, e.g. FIP image creation tool"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://license.rst;md5=e927e02bca647e14efd87e9e914b2443"
4
5SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/atf;nobranch=1"
6SRCREV = "17f94e4315e81e3d1b22d863d9614d724e8273dc"
7
8S = "${WORKDIR}/git"
9
10DEPENDS += "openssl"
11
12EXTRA_OEMAKE = "fiptool V=1 HOSTCC='${CC} ${CPPFLAGS} ${CFLAGS} ${LDFLAGS}'"
13
14do_install () {
15 install -m 0755 -d ${D}/${bindir}
16 install -m 0755 ${S}/tools/fiptool/fiptool ${D}/${bindir}/
17}
18
19BBCLASSEXTEND = "native"