summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/atf/qoriq-atf/tf-a-tests-no-warn-rwx-segments.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/atf/qoriq-atf/tf-a-tests-no-warn-rwx-segments.patch')
-rw-r--r--recipes-bsp/atf/qoriq-atf/tf-a-tests-no-warn-rwx-segments.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-bsp/atf/qoriq-atf/tf-a-tests-no-warn-rwx-segments.patch b/recipes-bsp/atf/qoriq-atf/tf-a-tests-no-warn-rwx-segments.patch
new file mode 100644
index 00000000..8412499e
--- /dev/null
+++ b/recipes-bsp/atf/qoriq-atf/tf-a-tests-no-warn-rwx-segments.patch
@@ -0,0 +1,34 @@
1From 9ceeb0cadffee1b1476718795d0568f6b244bf44 Mon Sep 17 00:00:00 2001
2From: Jun Zhu <junzhu@nxp.com>
3Date: Mon, 31 Oct 2022 21:24:15 +0800
4Subject: [PATCH] tf-a-tests-no-warn-rwx-segments
5
6Binutils 2.39 now warns when a segment has RXW permissions[1]:
7
8aarch64-poky-linux-musl-ld: tftf.elf has a LOAD segment with RWX permissions
9
10There is a ticket filed upstream[2], so until that is resolved just disable the warning
11[1] https://sourceware.org/git/?p=binutils-gdb.git;a=commit;h=ba951afb99912da01a6e8434126b8fac7aa75107
12[2] https://developer.trustedfirmware.org/T996
13
14Signed-off-by: Jun Zhu <junzhu@nxp.com>
15---
16 Makefile | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19diff --git a/Makefile b/Makefile
20index dccf0121d..0d082344b 100644
21--- a/Makefile
22+++ b/Makefile
23@@ -445,7 +445,7 @@ TF_LDFLAGS += --gc-sections
24 # ld.lld doesn't recognize the errata flags,
25 # therefore don't add those in that case
26 ifeq ($(findstring ld.lld,$(notdir $(LD))),)
27-TF_LDFLAGS += $(TF_LDFLAGS_$(ARCH))
28+TF_LDFLAGS += $(TF_LDFLAGS_$(ARCH)) --no-warn-rwx-segments
29 endif
30 endif
31
32--
332.25.1
34