summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/imx-boot-container.bbclass2
-rw-r--r--conf/machine/imx8mq-evk.conf34
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-common_2022.01.inc (renamed from recipes-bsp/u-boot/u-boot-fslc-common_2021.07.inc)6
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mfgtool_2022.01.bb (renamed from recipes-bsp/u-boot/u-boot-fslc-mfgtool_2021.07.bb)0
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mxsboot_2022.01.bb (renamed from recipes-bsp/u-boot/u-boot-fslc-mxsboot_2021.07.bb)0
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2022.01.bb (renamed from recipes-bsp/u-boot/u-boot-fslc_2021.07.bb)0
-rw-r--r--wic/imx-boot-container-bootpart.wks.in13
7 files changed, 39 insertions, 16 deletions
diff --git a/classes/imx-boot-container.bbclass b/classes/imx-boot-container.bbclass
index 3ffa7cbd..19b43312 100644
--- a/classes/imx-boot-container.bbclass
+++ b/classes/imx-boot-container.bbclass
@@ -85,7 +85,6 @@ do_deploy:append() {
85 j=$(expr $j + 1); 85 j=$(expr $j + 1);
86 if [ $j -eq $i ] 86 if [ $j -eq $i ]
87 then 87 then
88 install -m 0644 ${B}/${config}/u-boot.itb ${DEPLOYDIR}/u-boot.itb-${MACHINE}-${type}
89 install -m 0644 ${B}/${config}/flash.bin ${DEPLOYDIR}/flash.bin-${MACHINE}-${type} 88 install -m 0644 ${B}/${config}/flash.bin ${DEPLOYDIR}/flash.bin-${MACHINE}-${type}
90 # When there's more than one word in UBOOT_CONFIG, 89 # When there's more than one word in UBOOT_CONFIG,
91 # this will overwrite the links created in 90 # this will overwrite the links created in
@@ -94,7 +93,6 @@ do_deploy:append() {
94 # word in UBOOT_CONFIG. This is also how all other 93 # word in UBOOT_CONFIG. This is also how all other
95 # artifacts handled by oe-core's u-boot.inc are 94 # artifacts handled by oe-core's u-boot.inc are
96 # treated. 95 # treated.
97 ln -sf u-boot.itb-${MACHINE}-${type} u-boot.itb
98 ln -sf flash.bin-${MACHINE}-${type} flash.bin 96 ln -sf flash.bin-${MACHINE}-${type} flash.bin
99 fi 97 fi
100 done 98 done
diff --git a/conf/machine/imx8mq-evk.conf b/conf/machine/imx8mq-evk.conf
index cea44ed1..cb63dceb 100644
--- a/conf/machine/imx8mq-evk.conf
+++ b/conf/machine/imx8mq-evk.conf
@@ -4,15 +4,18 @@
4#@DESCRIPTION: Machine configuration for NXP i.MX 8M Quad Evaluation Kit 4#@DESCRIPTION: Machine configuration for NXP i.MX 8M Quad Evaluation Kit
5#@MAINTAINER: Jun Zhu <junzhu@nxp.com> 5#@MAINTAINER: Jun Zhu <junzhu@nxp.com>
6 6
7MACHINEOVERRIDES =. "mx8:mx8m:mx8mq:" 7MACHINEOVERRIDES =. "imx-boot-container:mx8:mx8m:mx8mq:"
8 8
9require conf/machine/include/imx-base.inc 9require conf/machine/include/imx-base.inc
10require conf/machine/include/arm/armv8a/tune-cortexa53.inc 10require conf/machine/include/arm/armv8a/tune-cortexa53.inc
11 11
12IMX_DEFAULT_BSP = "nxp" 12# Mainline BSP defaults to "generic" cortexa53 configuration,
13# adjust it here to include crypto extension which enables
14# inline NEON and FPU code generation
15DEFAULTTUNE:use-mainline-bsp = "cortexa53-crypto"
13 16
14MACHINE_FEATURES += "pci wifi bluetooth optee bcm43455 bcm4356" 17MACHINE_FEATURES += "pci wifi bluetooth bcm43455 bcm4356"
15MACHINE_FEATURES:append:use-nxp-bsp = " bcm4359" 18MACHINE_FEATURES:append:use-nxp-bsp = " optee bcm4359"
16 19
17MACHINE_SOCARCH_FILTER:append:mx8mq = " virtual/libopenvg virtual/libgles1 virtual/libgles2 virtual/egl virtual/mesa virtual/libgl virtual/libg2d" 20MACHINE_SOCARCH_FILTER:append:mx8mq = " virtual/libopenvg virtual/libgles1 virtual/libgles2 virtual/egl virtual/mesa virtual/libgl virtual/libg2d"
18 21
@@ -64,11 +67,34 @@ UBOOT_DTB_NAME = "imx8mq-evk.dtb"
64 67
65# Set ATF platform name 68# Set ATF platform name
66ATF_PLATFORM = "imx8mq" 69ATF_PLATFORM = "imx8mq"
70ATF_LOAD_ADDR = "0x910000"
71
72# Extra firmware package name, that is required to build boot container for fslc bsp
73IMX_EXTRA_FIRMWARE = "firmware-imx-8m"
67 74
68# Set imx-mkimage boot target 75# Set imx-mkimage boot target
69IMXBOOT_TARGETS = "flash_evk flash_evk_no_hdmi flash_dp_evk" 76IMXBOOT_TARGETS = "flash_evk flash_evk_no_hdmi flash_dp_evk"
70IMX_BOOT_SOC_TARGET = "iMX8M" 77IMX_BOOT_SOC_TARGET = "iMX8M"
71 78
79# Add support for Syslinux to mainline BSP.
80# U-Boot has the Distro Boot mode enabled by default, which
81# require that either Syslinux to be enabled, or a boot script
82# to be used to define the boot process.
83# We opt-in for Syslinux, since it is designated as a preferred
84# distro boot mode according to the U-Boot documentation.
85UBOOT_EXTLINUX:use-mainline-bsp = "1"
86UBOOT_EXTLINUX_LABELS:use-mainline-bsp = "default"
87UBOOT_EXTLINUX_DEFAULT_LABEL:use-mainline-bsp = "i.MX8M Quad EVK"
88
89UBOOT_EXTLINUX_MENU_DESCRIPTION:default:use-mainline-bsp = "i.MX8M Quad EVK"
90UBOOT_EXTLINUX_FDT:default:use-mainline-bsp = "../imx8mq-evk.dtb"
91UBOOT_EXTLINUX_CONSOLE:default:use-mainline-bsp = "console=${console}"
92UBOOT_EXTLINUX_ROOT:default:use-mainline-bsp ??= "root=/dev/mmcblk1p2"
93
94# Add extlinux.conf to the lis of files, which are deployed onto the
95# boot partition
96IMAGE_BOOT_FILES:append:use-mainline-bsp = " extlinux.conf;extlinux/extlinux.conf"
97
72LOADADDR = "" 98LOADADDR = ""
73UBOOT_SUFFIX = "bin" 99UBOOT_SUFFIX = "bin"
74UBOOT_MAKE_TARGET = "" 100UBOOT_MAKE_TARGET = ""
diff --git a/recipes-bsp/u-boot/u-boot-fslc-common_2021.07.inc b/recipes-bsp/u-boot/u-boot-fslc-common_2022.01.inc
index 7d401692..341e2802 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-common_2021.07.inc
+++ b/recipes-bsp/u-boot/u-boot-fslc-common_2022.01.inc
@@ -10,10 +10,10 @@ DEPENDS += "flex-native bison-native"
10 10
11SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH};protocol=https" 11SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH};protocol=https"
12 12
13SRCREV = "691e634bfd317ede487d2b864a126847ffeb4aa7" 13SRCREV = "ed9503daa309c765a8654dc89c486326b4850f6d"
14SRCBRANCH = "2021.07+fslc" 14SRCBRANCH = "2022.01+fslc"
15 15
16PV = "v2021.07+git${SRCPV}" 16PV = "v2022.01+git${SRCPV}"
17 17
18S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
19B = "${WORKDIR}/build" 19B = "${WORKDIR}/build"
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mfgtool_2021.07.bb b/recipes-bsp/u-boot/u-boot-fslc-mfgtool_2022.01.bb
index 2e79166b..2e79166b 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-mfgtool_2021.07.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc-mfgtool_2022.01.bb
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2021.07.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2022.01.bb
index a3a732ef..a3a732ef 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2021.07.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2022.01.bb
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2021.07.bb b/recipes-bsp/u-boot/u-boot-fslc_2022.01.bb
index 21989ae5..21989ae5 100644
--- a/recipes-bsp/u-boot/u-boot-fslc_2021.07.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc_2022.01.bb
diff --git a/wic/imx-boot-container-bootpart.wks.in b/wic/imx-boot-container-bootpart.wks.in
index 88679a68..321ee46b 100644
--- a/wic/imx-boot-container-bootpart.wks.in
+++ b/wic/imx-boot-container-bootpart.wks.in
@@ -11,16 +11,15 @@
11# U-Boot DTB file, ATF, and optional OP-TEE components. 11# U-Boot DTB file, ATF, and optional OP-TEE components.
12# 12#
13# The disk layout used is: 13# The disk layout used is:
14# - ----------- -------------- ---------------------------- 14# - ----------- -------------- -------------
15# | | flash.bin | u-boot.itb | boot | rootfs | 15# | | flash.bin | boot | rootfs |
16# - ----------- -------------- ---------------------------- 16# - ----------- -------------- -------------
17# ^ ^ ^ ^ ^ ^ 17# ^ ^ ^ ^ ^
18# | | | | | | 18# | | | | |
19# 0 | 384KiB 8MiB 72MiB 72MiB + rootfs + IMAGE_EXTRA_SPACE (default 10MiB) 19# 0 | 8MiB 72MiB 72MiB + rootfs + IMAGE_EXTRA_SPACE (default 10MiB)
20# ${IMX_BOOT_SEEK} 32 or 33kiB, see reference manual 20# ${IMX_BOOT_SEEK} 32 or 33kiB, see reference manual
21# 21#
22part u-boot --source rawcopy --sourceparams="file=flash.bin" --ondisk mmcblk --no-table --align ${IMX_BOOT_SEEK} 22part u-boot --source rawcopy --sourceparams="file=flash.bin" --ondisk mmcblk --no-table --align ${IMX_BOOT_SEEK}
23part u-boot-itb --source rawcopy --sourceparams="file=u-boot.itb" --ondisk mmcblk --no-table --align 384
24part /boot --source bootimg-partition --ondisk mmcblk --fstype=vfat --label boot --active --align 8192 --size 64 23part /boot --source bootimg-partition --ondisk mmcblk --fstype=vfat --label boot --active --align 8192 --size 64
25part / --source rootfs --ondisk mmcblk --fstype=ext4 --label root --align 8192 24part / --source rootfs --ondisk mmcblk --fstype=ext4 --label root --align 8192
26 25