diff options
-rw-r--r-- | conf/machine/include/qoriq-base.inc | 2 | ||||
-rw-r--r-- | recipes-bsp/atf/qoriq-atf_2.4.bb | 2 | ||||
-rw-r--r-- | recipes-bsp/imx-atf/imx-atf/0001-Makefile-Suppress-array-bounds-error.patch | 15 | ||||
-rw-r--r-- | recipes-devtools/qoriq-cst/qoriq-cst/0001-tools-Mark-struct-input_field-file_field-extern.patch (renamed from recipes-devtools/cst/cst/0001-tools-Mark-struct-input_field-file_field-extern.patch) | 0 | ||||
-rw-r--r-- | recipes-devtools/qoriq-cst/qoriq-cst_git.bb (renamed from recipes-devtools/cst/cst_git.bb) | 2 | ||||
-rw-r--r-- | recipes-security/optee-qoriq/optee-client-qoriq_3.13.0.bb (renamed from recipes-security/optee/optee-client-qoriq_3.13.0.bb) | 0 | ||||
-rw-r--r-- | recipes-security/optee-qoriq/optee-client.nxp.inc (renamed from recipes-security/optee/optee-client.nxp.inc) | 0 | ||||
-rw-r--r-- | recipes-security/optee-qoriq/optee-client/tee-supplicant.service (renamed from recipes-security/optee/optee-client/tee-supplicant.service) | 0 | ||||
-rw-r--r-- | recipes-security/optee-qoriq/optee-os-qoriq_3.13.0.bb (renamed from recipes-security/optee/optee-os-qoriq_3.13.0.bb) | 0 | ||||
-rw-r--r-- | recipes-security/optee-qoriq/optee-os.nxp.inc (renamed from recipes-security/optee/optee-os.nxp.inc) | 0 | ||||
-rw-r--r-- | recipes-security/optee-qoriq/optee-test-qoriq_3.13.0.bb (renamed from recipes-security/optee/optee-test-qoriq_3.13.0.bb) | 0 | ||||
-rw-r--r-- | recipes-security/optee-qoriq/optee-test.nxp.inc (renamed from recipes-security/optee/optee-test.nxp.inc) | 0 |
12 files changed, 13 insertions, 8 deletions
diff --git a/conf/machine/include/qoriq-base.inc b/conf/machine/include/qoriq-base.inc index 35b7d82e..4340c942 100644 --- a/conf/machine/include/qoriq-base.inc +++ b/conf/machine/include/qoriq-base.inc | |||
@@ -39,7 +39,7 @@ WKS_FILE ?= "${SOC_DEFAULT_WKS_FILE}" | |||
39 | MACHINE_FEATURES ?= "pci ext2 ext3 serial" | 39 | MACHINE_FEATURES ?= "pci ext2 ext3 serial" |
40 | MACHINE_EXTRA_RRECOMMENDS += "udev-extraconf udev-rules-qoriq kernel-modules" | 40 | MACHINE_EXTRA_RRECOMMENDS += "udev-extraconf udev-rules-qoriq kernel-modules" |
41 | 41 | ||
42 | EXTRA_IMAGEDEPENDS += "u-boot cst-native" | 42 | EXTRA_IMAGEDEPENDS += "u-boot qoriq-cst-native" |
43 | 43 | ||
44 | MACHINEOVERRIDES =. "qoriq:" | 44 | MACHINEOVERRIDES =. "qoriq:" |
45 | 45 | ||
diff --git a/recipes-bsp/atf/qoriq-atf_2.4.bb b/recipes-bsp/atf/qoriq-atf_2.4.bb index b6716272..ec953297 100644 --- a/recipes-bsp/atf/qoriq-atf_2.4.bb +++ b/recipes-bsp/atf/qoriq-atf_2.4.bb | |||
@@ -2,7 +2,7 @@ require recipes-bsp/atf/qoriq-atf-2.4.inc | |||
2 | 2 | ||
3 | inherit deploy | 3 | inherit deploy |
4 | 4 | ||
5 | DEPENDS += "u-boot-mkimage-native u-boot openssl openssl-native rcw cst-native bc-native" | 5 | DEPENDS += "u-boot-mkimage-native u-boot openssl openssl-native rcw qoriq-cst-native bc-native" |
6 | DEPENDS:append:lx2160a = " ddr-phy" | 6 | DEPENDS:append:lx2160a = " ddr-phy" |
7 | DEPENDS:append:lx2162a = " ddr-phy" | 7 | DEPENDS:append:lx2162a = " ddr-phy" |
8 | do_compile[depends] += "u-boot:do_deploy rcw:do_deploy uefi:do_deploy" | 8 | do_compile[depends] += "u-boot:do_deploy rcw:do_deploy uefi:do_deploy" |
diff --git a/recipes-bsp/imx-atf/imx-atf/0001-Makefile-Suppress-array-bounds-error.patch b/recipes-bsp/imx-atf/imx-atf/0001-Makefile-Suppress-array-bounds-error.patch index 37b5ce6f..c7ace225 100644 --- a/recipes-bsp/imx-atf/imx-atf/0001-Makefile-Suppress-array-bounds-error.patch +++ b/recipes-bsp/imx-atf/imx-atf/0001-Makefile-Suppress-array-bounds-error.patch | |||
@@ -3,8 +3,8 @@ From: Tom Hochstein <tom.hochstein@nxp.com> | |||
3 | Date: Mon, 16 May 2022 13:45:16 -0500 | 3 | Date: Mon, 16 May 2022 13:45:16 -0500 |
4 | Subject: [PATCH] Makefile: Suppress array-bounds error | 4 | Subject: [PATCH] Makefile: Suppress array-bounds error |
5 | 5 | ||
6 | The array-bounds error is triggered now in cases where it was silent before, | 6 | The array-bounds error is triggered now in cases where it was silent |
7 | causing errors like: | 7 | before, causing errors like: |
8 | 8 | ||
9 | ``` | 9 | ``` |
10 | plat/imx/imx8m/hab.c: In function 'imx_hab_handler': | 10 | plat/imx/imx8m/hab.c: In function 'imx_hab_handler': |
@@ -13,10 +13,15 @@ plat/imx/imx8m/hab.c:64:57: error: array subscript 0 is outside array bounds of | |||
13 | | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ | 13 | | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ |
14 | ``` | 14 | ``` |
15 | 15 | ||
16 | It appears that these new cases will be silenced soon in gcc [1], so for | 16 | The error is a false-positive and is entered as a bug [1]. The problem |
17 | now just silence the warning locally as a workaround. | 17 | is fixed partially in GCC 12 and fully in GCC 13 [2]. |
18 | 18 | ||
19 | [1] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=99578#c39 | 19 | The partial fix does not work here because the constant addresses used |
20 | are less than the 4kB boundary chosen for the partial fix, so suppress | ||
21 | the error until GCC is upgraded to 13. | ||
22 | |||
23 | [1] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=99578 | ||
24 | [2] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=99578#c39 | ||
20 | 25 | ||
21 | Upstream-Status: Inappropriate [other] | 26 | Upstream-Status: Inappropriate [other] |
22 | Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> | 27 | Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> |
diff --git a/recipes-devtools/cst/cst/0001-tools-Mark-struct-input_field-file_field-extern.patch b/recipes-devtools/qoriq-cst/qoriq-cst/0001-tools-Mark-struct-input_field-file_field-extern.patch index d25675aa..d25675aa 100644 --- a/recipes-devtools/cst/cst/0001-tools-Mark-struct-input_field-file_field-extern.patch +++ b/recipes-devtools/qoriq-cst/qoriq-cst/0001-tools-Mark-struct-input_field-file_field-extern.patch | |||
diff --git a/recipes-devtools/cst/cst_git.bb b/recipes-devtools/qoriq-cst/qoriq-cst_git.bb index b9ac3e9e..ca0f35fb 100644 --- a/recipes-devtools/cst/cst_git.bb +++ b/recipes-devtools/qoriq-cst/qoriq-cst_git.bb | |||
@@ -4,7 +4,7 @@ LICENSE = "BSD-3-Clause" | |||
4 | 4 | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=e959d5d617e33779d0e90ce1d9043eff" | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=e959d5d617e33779d0e90ce1d9043eff" |
6 | 6 | ||
7 | DEPENDS += "openssl cst-native" | 7 | DEPENDS += "openssl qoriq-cst-native" |
8 | RDEPENDS:${PN} = "bash" | 8 | RDEPENDS:${PN} = "bash" |
9 | 9 | ||
10 | GENKEYS ?= "${STAGING_BINDIR_NATIVE}/cst/gen_keys" | 10 | GENKEYS ?= "${STAGING_BINDIR_NATIVE}/cst/gen_keys" |
diff --git a/recipes-security/optee/optee-client-qoriq_3.13.0.bb b/recipes-security/optee-qoriq/optee-client-qoriq_3.13.0.bb index 94123e43..94123e43 100644 --- a/recipes-security/optee/optee-client-qoriq_3.13.0.bb +++ b/recipes-security/optee-qoriq/optee-client-qoriq_3.13.0.bb | |||
diff --git a/recipes-security/optee/optee-client.nxp.inc b/recipes-security/optee-qoriq/optee-client.nxp.inc index fa187e84..fa187e84 100644 --- a/recipes-security/optee/optee-client.nxp.inc +++ b/recipes-security/optee-qoriq/optee-client.nxp.inc | |||
diff --git a/recipes-security/optee/optee-client/tee-supplicant.service b/recipes-security/optee-qoriq/optee-client/tee-supplicant.service index 0e2b4f6b..0e2b4f6b 100644 --- a/recipes-security/optee/optee-client/tee-supplicant.service +++ b/recipes-security/optee-qoriq/optee-client/tee-supplicant.service | |||
diff --git a/recipes-security/optee/optee-os-qoriq_3.13.0.bb b/recipes-security/optee-qoriq/optee-os-qoriq_3.13.0.bb index 3c3652d3..3c3652d3 100644 --- a/recipes-security/optee/optee-os-qoriq_3.13.0.bb +++ b/recipes-security/optee-qoriq/optee-os-qoriq_3.13.0.bb | |||
diff --git a/recipes-security/optee/optee-os.nxp.inc b/recipes-security/optee-qoriq/optee-os.nxp.inc index 72af6ca4..72af6ca4 100644 --- a/recipes-security/optee/optee-os.nxp.inc +++ b/recipes-security/optee-qoriq/optee-os.nxp.inc | |||
diff --git a/recipes-security/optee/optee-test-qoriq_3.13.0.bb b/recipes-security/optee-qoriq/optee-test-qoriq_3.13.0.bb index 69ef73d3..69ef73d3 100644 --- a/recipes-security/optee/optee-test-qoriq_3.13.0.bb +++ b/recipes-security/optee-qoriq/optee-test-qoriq_3.13.0.bb | |||
diff --git a/recipes-security/optee/optee-test.nxp.inc b/recipes-security/optee-qoriq/optee-test.nxp.inc index e3ba0c8e..e3ba0c8e 100644 --- a/recipes-security/optee/optee-test.nxp.inc +++ b/recipes-security/optee-qoriq/optee-test.nxp.inc | |||