summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/dtc-145.bbclass7
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2017.03.bb3
-rw-r--r--recipes-kernel/dtc/dtc-145_git.bb6
3 files changed, 14 insertions, 2 deletions
diff --git a/classes/dtc-145.bbclass b/classes/dtc-145.bbclass
new file mode 100644
index 00000000..d4a30711
--- /dev/null
+++ b/classes/dtc-145.bbclass
@@ -0,0 +1,7 @@
1# Use this class for U-Boot 2017.03 or older.
2
3DEPENDS_append = " dtc-145-native"
4
5do_configure_prepend () {
6 sed -i -e 's/^DTC[[:space:]]*=[[:space:]]*dtc[[:space:]]*$/DTC = dtc-145/' ${S}/Makefile
7}
diff --git a/recipes-bsp/u-boot/u-boot-imx_2017.03.bb b/recipes-bsp/u-boot/u-boot-imx_2017.03.bb
index 52ebee99..0e4ba7b3 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2017.03.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2017.03.bb
@@ -6,7 +6,6 @@ DESCRIPTION = "i.MX U-Boot suppporting i.MX reference boards."
6require recipes-bsp/u-boot/u-boot.inc 6require recipes-bsp/u-boot/u-boot.inc
7 7
8PROVIDES += "u-boot" 8PROVIDES += "u-boot"
9DEPENDS_append = "dtc-145-native"
10 9
11LICENSE = "GPLv2+" 10LICENSE = "GPLv2+"
12LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263" 11LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
@@ -17,7 +16,7 @@ SRCREV = "b76bb1bf9fd21e21006d79552e28855ac43ad43c"
17 16
18S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
19 18
20inherit fsl-u-boot-localversion 19inherit dtc-145 fsl-u-boot-localversion
21 20
22LOCALVERSION ?= "-${SRCBRANCH}" 21LOCALVERSION ?= "-${SRCBRANCH}"
23 22
diff --git a/recipes-kernel/dtc/dtc-145_git.bb b/recipes-kernel/dtc/dtc-145_git.bb
index afed62fd..2776cc5e 100644
--- a/recipes-kernel/dtc/dtc-145_git.bb
+++ b/recipes-kernel/dtc/dtc-145_git.bb
@@ -10,3 +10,9 @@ SRCREV = "22a65c5331c22979d416738eb756b9541672e00d"
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11 11
12BBCLASSEXTEND = "native nativesdk" 12BBCLASSEXTEND = "native nativesdk"
13
14# only install the dtc binary renamed to dtc-145
15do_install () {
16 install -d ${D}/${bindir}
17 install -m 755 dtc ${D}/${bindir}/dtc-145
18}