diff options
-rw-r--r-- | recipes-extended/odp/odp-counters_git.bb | 4 | ||||
-rw-r--r-- | recipes-extended/odp/odp-module_git.bb | 4 | ||||
-rw-r--r-- | recipes-kernel/kernel-modules/kernel-module-ar_git.bb | 4 |
3 files changed, 6 insertions, 6 deletions
diff --git a/recipes-extended/odp/odp-counters_git.bb b/recipes-extended/odp/odp-counters_git.bb index 9d88ea43..c8f13208 100644 --- a/recipes-extended/odp/odp-counters_git.bb +++ b/recipes-extended/odp/odp-counters_git.bb | |||
@@ -9,6 +9,6 @@ do_compile:prepend () { | |||
9 | } | 9 | } |
10 | 10 | ||
11 | do_install () { | 11 | do_install () { |
12 | install -d ${D}/lib/modules/${KERNEL_VERSION}/odp | 12 | install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/odp |
13 | install -m 755 ${S}/test/debug/perf_counters/odpfsl_perfcounters.ko ${D}/lib/modules/${KERNEL_VERSION}/odp | 13 | install -m 755 ${S}/test/debug/perf_counters/odpfsl_perfcounters.ko ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/odp |
14 | } | 14 | } |
diff --git a/recipes-extended/odp/odp-module_git.bb b/recipes-extended/odp/odp-module_git.bb index 0748e5bf..ba74a5c0 100644 --- a/recipes-extended/odp/odp-module_git.bb +++ b/recipes-extended/odp/odp-module_git.bb | |||
@@ -9,8 +9,8 @@ do_compile:prepend () { | |||
9 | } | 9 | } |
10 | 10 | ||
11 | do_install () { | 11 | do_install () { |
12 | install -d ${D}/lib/modules/${KERNEL_VERSION}/odp | 12 | install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/odp |
13 | install -m 755 ${S}/kern/odpfsl_kni.ko ${D}/lib/modules/${KERNEL_VERSION}/odp | 13 | install -m 755 ${S}/kern/odpfsl_kni.ko ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/odp |
14 | } | 14 | } |
15 | 15 | ||
16 | PKG:${PN} = "kernel-module-${PN}" | 16 | PKG:${PN} = "kernel-module-${PN}" |
diff --git a/recipes-kernel/kernel-modules/kernel-module-ar_git.bb b/recipes-kernel/kernel-modules/kernel-module-ar_git.bb index f2cd1a57..898afeb2 100644 --- a/recipes-kernel/kernel-modules/kernel-module-ar_git.bb +++ b/recipes-kernel/kernel-modules/kernel-module-ar_git.bb | |||
@@ -19,9 +19,9 @@ do_compile:prepend() { | |||
19 | } | 19 | } |
20 | 20 | ||
21 | do_install(){ | 21 | do_install(){ |
22 | install -d ${D}/lib/modules/${KERNEL_VERSION} | 22 | install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION} |
23 | install -d ${D}${bindir} | 23 | install -d ${D}${bindir} |
24 | install -m 644 ${B}/bin/ar.ko ${D}/lib/modules/${KERNEL_VERSION}/ | 24 | install -m 644 ${B}/bin/ar.ko ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/ |
25 | cp -f ${S}/bin/ar_* ${D}${bindir}/ | 25 | cp -f ${S}/bin/ar_* ${D}${bindir}/ |
26 | } | 26 | } |
27 | 27 | ||