diff options
-rw-r--r-- | recipes-devtools/utp-com/utp-com/0001-Fix-Makefile-for-crosscompilation.patch | 19 | ||||
-rw-r--r-- | recipes-devtools/utp-com/utp-com_git.bb | 28 | ||||
-rw-r--r-- | recipes-support/sg3-utils/sg3-utils_%.bbappend | 1 |
3 files changed, 48 insertions, 0 deletions
diff --git a/recipes-devtools/utp-com/utp-com/0001-Fix-Makefile-for-crosscompilation.patch b/recipes-devtools/utp-com/utp-com/0001-Fix-Makefile-for-crosscompilation.patch new file mode 100644 index 00000000..5db050c1 --- /dev/null +++ b/recipes-devtools/utp-com/utp-com/0001-Fix-Makefile-for-crosscompilation.patch | |||
@@ -0,0 +1,19 @@ | |||
1 | --- a/makefile | ||
2 | +++ b/makefile | ||
3 | @@ -1,10 +1,12 @@ | ||
4 | -CC=gcc | ||
5 | -CFLAGS=-I. -Wall -O2 | ||
6 | -DEPS= | ||
7 | +CC ?= gcc | ||
8 | +CFLAGS ?= -I. -Wall -O2 | ||
9 | +LDFLAGS ?= | ||
10 | +DEPS ?= | ||
11 | + | ||
12 | OBJ=utp_com.o | ||
13 | |||
14 | %.o: %.c $(DEPS) | ||
15 | $(CC) -c -o $@ $< $(CFLAGS) | ||
16 | |||
17 | utp_com: $(OBJ) | ||
18 | - gcc -o $@ $^ $(CFLAGS) | ||
19 | + $(CC) -o $@ $^ $(LDFLAGS) | ||
diff --git a/recipes-devtools/utp-com/utp-com_git.bb b/recipes-devtools/utp-com/utp-com_git.bb new file mode 100644 index 00000000..163f5852 --- /dev/null +++ b/recipes-devtools/utp-com/utp-com_git.bb | |||
@@ -0,0 +1,28 @@ | |||
1 | DESCRIPTION = "Tool used to send commands to hardware via NXP's UTP protocol" | ||
2 | LICENSE = "GPLv2" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8264535c0c4e9c6c335635c4026a8022" | ||
4 | |||
5 | DEPENDS = "sg3-utils" | ||
6 | |||
7 | SRCREV = "7fe590fef812561cceb08aaa10b64e9bac8f542f" | ||
8 | SRC_URI = " \ | ||
9 | git://github.com/ixonos/utp_com;protocol=https \ | ||
10 | file://0001-Fix-Makefile-for-crosscompilation.patch \ | ||
11 | " | ||
12 | |||
13 | PV = "1.0+git${SRCPV}" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | do_configure[noexec] = "1" | ||
18 | |||
19 | do_compile () { | ||
20 | oe_runmake | ||
21 | } | ||
22 | |||
23 | do_install () { | ||
24 | install -d -m 0755 ${D}${bindir} | ||
25 | install -m 0755 ${S}/utp_com ${D}${bindir}/utp_com | ||
26 | } | ||
27 | |||
28 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/recipes-support/sg3-utils/sg3-utils_%.bbappend b/recipes-support/sg3-utils/sg3-utils_%.bbappend new file mode 100644 index 00000000..608377e3 --- /dev/null +++ b/recipes-support/sg3-utils/sg3-utils_%.bbappend | |||
@@ -0,0 +1 @@ | |||
BBCLASSEXTEND = "native nativesdk" | |||