diff options
-rw-r--r-- | classes/use-imx-headers.bbclass | 4 | ||||
-rw-r--r-- | conf/machine/include/imx-base.inc | 16 | ||||
-rw-r--r-- | recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb | 2 | ||||
-rw-r--r-- | recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc | 2 | ||||
-rw-r--r-- | recipes-graphics/wayland/weston-init.bbappend | 2 | ||||
-rw-r--r-- | recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend | 2 | ||||
-rw-r--r-- | recipes-multimedia/alsa/alsa-lib_%.bbappend | 4 | ||||
-rw-r--r-- | recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.0.0.bb | 4 |
8 files changed, 18 insertions, 18 deletions
diff --git a/classes/use-imx-headers.bbclass b/classes/use-imx-headers.bbclass index ea70e6a5..c6c7f043 100644 --- a/classes/use-imx-headers.bbclass +++ b/classes/use-imx-headers.bbclass | |||
@@ -13,14 +13,14 @@ | |||
13 | # | 13 | # |
14 | # Copyright 2018 (C) O.S. Systems Software LTDA. | 14 | # Copyright 2018 (C) O.S. Systems Software LTDA. |
15 | 15 | ||
16 | DEPENDS:append_imx = " linux-imx-headers" | 16 | DEPENDS:append:imx = " linux-imx-headers" |
17 | 17 | ||
18 | # Set runtime dependency of -dev for package inheriting this class to | 18 | # Set runtime dependency of -dev for package inheriting this class to |
19 | # linux-imx-headers-dev package. This is required in order to propagate | 19 | # linux-imx-headers-dev package. This is required in order to propagate |
20 | # headers into the SDK | 20 | # headers into the SDK |
21 | RDEPENDS:${PN}-dev += "linux-imx-headers-dev" | 21 | RDEPENDS:${PN}-dev += "linux-imx-headers-dev" |
22 | 22 | ||
23 | PACKAGE_ARCH_imx ?= "${MACHINE_SOCARCH}" | 23 | PACKAGE_ARCH:imx ?= "${MACHINE_SOCARCH}" |
24 | 24 | ||
25 | STAGING_INCDIR_IMX = "${STAGING_INCDIR}/imx" | 25 | STAGING_INCDIR_IMX = "${STAGING_INCDIR}/imx" |
26 | 26 | ||
diff --git a/conf/machine/include/imx-base.inc b/conf/machine/include/imx-base.inc index b8bcecab..18bf4700 100644 --- a/conf/machine/include/imx-base.inc +++ b/conf/machine/include/imx-base.inc | |||
@@ -204,7 +204,7 @@ MACHINE_SOCARCH_SUFFIX:mx8dxl = "-mx8dxl" | |||
204 | MACHINE_SOCARCH_SUFFIX:use-mainline-bsp = "-imx" | 204 | MACHINE_SOCARCH_SUFFIX:use-mainline-bsp = "-imx" |
205 | 205 | ||
206 | MACHINE_ARCH_FILTER = "virtual/kernel" | 206 | MACHINE_ARCH_FILTER = "virtual/kernel" |
207 | MACHINE_SOCARCH_FILTER:append_imx = " \ | 207 | MACHINE_SOCARCH_FILTER:append:imx = " \ |
208 | alsa-lib \ | 208 | alsa-lib \ |
209 | gstreamer1.0 \ | 209 | gstreamer1.0 \ |
210 | weston \ | 210 | weston \ |
@@ -355,17 +355,17 @@ PREFERRED_PROVIDER_virtual/libgl ?= "mesa" | |||
355 | PREFERRED_PROVIDER_virtual/libgles1 ?= "mesa" | 355 | PREFERRED_PROVIDER_virtual/libgles1 ?= "mesa" |
356 | PREFERRED_PROVIDER_virtual/libgles2 ?= "mesa" | 356 | PREFERRED_PROVIDER_virtual/libgles2 ?= "mesa" |
357 | 357 | ||
358 | PREFERRED_PROVIDER_virtual/egl_imxgpu ?= "imx-gpu-viv" | 358 | PREFERRED_PROVIDER_virtual/egl:imxgpu ?= "imx-gpu-viv" |
359 | PREFERRED_PROVIDER_virtual/libgl_imxgpu3d ?= "imx-gpu-viv" | 359 | PREFERRED_PROVIDER_virtual/libgl:imxgpu3d ?= "imx-gpu-viv" |
360 | PREFERRED_PROVIDER_virtual/libgles1_imxgpu3d ?= "imx-gpu-viv" | 360 | PREFERRED_PROVIDER_virtual/libgles1:imxgpu3d ?= "imx-gpu-viv" |
361 | PREFERRED_PROVIDER_virtual/libgles2_imxgpu3d ?= "imx-gpu-viv" | 361 | PREFERRED_PROVIDER_virtual/libgles2:imxgpu3d ?= "imx-gpu-viv" |
362 | PREFERRED_PROVIDER_virtual/libg2d ?= "imx-gpu-g2d" | 362 | PREFERRED_PROVIDER_virtual/libg2d ?= "imx-gpu-g2d" |
363 | PREFERRED_PROVIDER_virtual/libg2d_imxdpu ?= "imx-dpu-g2d" | 363 | PREFERRED_PROVIDER_virtual/libg2d:imxdpu ?= "imx-dpu-g2d" |
364 | PREFERRED_PROVIDER_opencl-clhpp:imxgpu ?= "imx-gpu-viv" | 364 | PREFERRED_PROVIDER_opencl-clhpp:imxgpu ?= "imx-gpu-viv" |
365 | PREFERRED_PROVIDER_opencl-headers:imxgpu ?= "imx-gpu-viv" | 365 | PREFERRED_PROVIDER_opencl-headers:imxgpu ?= "imx-gpu-viv" |
366 | PREFERRED_PROVIDER_opencl-icd-loader:imxgpu ?= "imx-gpu-viv" | 366 | PREFERRED_PROVIDER_opencl-icd-loader:imxgpu ?= "imx-gpu-viv" |
367 | 367 | ||
368 | PREFERRED_VERSION_weston_imx ?= "9.0.0.imx" | 368 | PREFERRED_VERSION_weston:imx ?= "9.0.0.imx" |
369 | PREFERRED_VERSION_weston:use-mainline-bsp = "" | 369 | PREFERRED_VERSION_weston:use-mainline-bsp = "" |
370 | 370 | ||
371 | PREFERRED_VERSION_wayland-protocols:mx6 ?= "1.20.imx" | 371 | PREFERRED_VERSION_wayland-protocols:mx6 ?= "1.20.imx" |
@@ -474,7 +474,7 @@ KERNEL_IMAGETYPE:aarch64 = "Image" | |||
474 | 474 | ||
475 | MACHINE_FEATURES = "usbgadget usbhost vfat alsa touchscreen" | 475 | MACHINE_FEATURES = "usbgadget usbhost vfat alsa touchscreen" |
476 | 476 | ||
477 | # Add the ability to specify _imx machines | 477 | # Add the ability to specify imx machines |
478 | MACHINEOVERRIDES =. "imx:" | 478 | MACHINEOVERRIDES =. "imx:" |
479 | 479 | ||
480 | HOSTTOOLS_NONFATAL:append:mx8 = " sha384sum" | 480 | HOSTTOOLS_NONFATAL:append:mx8 = " sha384sum" |
diff --git a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb index 4b6aee0b..e57a4273 100644 --- a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb +++ b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb | |||
@@ -26,7 +26,7 @@ EXTRA_OECONF = "--imx-linux-headers-path=${STAGING_INCDIR_IMX} \ | |||
26 | # libg2d. However, that implementation's g2d_alloc() function | 26 | # libg2d. However, that implementation's g2d_alloc() function |
27 | # is broken, so we cannot use it. | 27 | # is broken, so we cannot use it. |
28 | LIBG2D_PACKAGECONFIG = "g2d" | 28 | LIBG2D_PACKAGECONFIG = "g2d" |
29 | LIBG2D_PACKAGECONFIG_imxdpu = "" | 29 | LIBG2D_PACKAGECONFIG:imxdpu = "" |
30 | 30 | ||
31 | PACKAGECONFIG ?= " " | 31 | PACKAGECONFIG ?= " " |
32 | PACKAGECONFIG:append:imxgpu2d = " ${LIBG2D_PACKAGECONFIG}" | 32 | PACKAGECONFIG:append:imxgpu2d = " ${LIBG2D_PACKAGECONFIG}" |
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc index e486d689..472c03c4 100644 --- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc +++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc | |||
@@ -17,7 +17,7 @@ DEPENDS += " \ | |||
17 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxcb libxshmfence libxxf86vm', \ | 17 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxcb libxshmfence libxxf86vm', \ |
18 | '', d)} \ | 18 | '', d)} \ |
19 | " | 19 | " |
20 | DEPENDS:append_imxdrm = " libdrm wayland" | 20 | DEPENDS:append:imxdrm = " libdrm wayland" |
21 | DEPENDS:append:mx8 = " patchelf-native" | 21 | DEPENDS:append:mx8 = " patchelf-native" |
22 | 22 | ||
23 | # imx-gpu-viv does not provide everything it needs to for virtual/libgl | 23 | # imx-gpu-viv does not provide everything it needs to for virtual/libgl |
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend index e6baac0b..5710e9b5 100644 --- a/recipes-graphics/wayland/weston-init.bbappend +++ b/recipes-graphics/wayland/weston-init.bbappend | |||
@@ -12,7 +12,7 @@ SRC_URI:append:mx6sl = " file://weston.config" | |||
12 | # commented out. For example: | 12 | # commented out. For example: |
13 | # #xwayland=true | 13 | # #xwayland=true |
14 | # Then add the assignment to INI_UNCOMMENT_ASSIGNMENTS. | 14 | # Then add the assignment to INI_UNCOMMENT_ASSIGNMENTS. |
15 | INI_UNCOMMENT_ASSIGNMENTS:append_imx = " \ | 15 | INI_UNCOMMENT_ASSIGNMENTS:append:imx = " \ |
16 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland=true', '', d)} \ | 16 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland=true', '', d)} \ |
17 | " | 17 | " |
18 | INI_UNCOMMENT_ASSIGNMENTS:append:mx8 = " \ | 18 | INI_UNCOMMENT_ASSIGNMENTS:append:mx8 = " \ |
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend b/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend index c7b7e879..34e2ed82 100644 --- a/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend +++ b/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend | |||
@@ -13,4 +13,4 @@ IMX_OPENGL_PKGCONFIGS_REMOVE = "" | |||
13 | IMX_OPENGL_PKGCONFIGS_REMOVE:imxgpu = "glamor" | 13 | IMX_OPENGL_PKGCONFIGS_REMOVE:imxgpu = "glamor" |
14 | OPENGL_PKGCONFIGS:remove:mx6 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" | 14 | OPENGL_PKGCONFIGS:remove:mx6 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" |
15 | OPENGL_PKGCONFIGS:remove:mx7 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" | 15 | OPENGL_PKGCONFIGS:remove:mx7 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" |
16 | OPENGL_PKGCONFIGS:remove_imxdrm = "dri glx" | 16 | OPENGL_PKGCONFIGS:remove:imxdrm = "dri glx" |
diff --git a/recipes-multimedia/alsa/alsa-lib_%.bbappend b/recipes-multimedia/alsa/alsa-lib_%.bbappend index 74fcba8a..d76c45d1 100644 --- a/recipes-multimedia/alsa/alsa-lib_%.bbappend +++ b/recipes-multimedia/alsa/alsa-lib_%.bbappend | |||
@@ -6,6 +6,6 @@ IMX_PATCH = " \ | |||
6 | file://0005-add-ak4458-conf-for-multichannel-support.patch \ | 6 | file://0005-add-ak4458-conf-for-multichannel-support.patch \ |
7 | file://0006-add-conf-for-iMX-XCVR-sound-card.patch \ | 7 | file://0006-add-conf-for-iMX-XCVR-sound-card.patch \ |
8 | " | 8 | " |
9 | SRC_URI:append_imx = "${IMX_PATCH}" | 9 | SRC_URI:append:imx = "${IMX_PATCH}" |
10 | 10 | ||
11 | PACKAGE_ARCH_imx = "${MACHINE_SOCARCH}" | 11 | PACKAGE_ARCH:imx = "${MACHINE_SOCARCH}" |
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.0.0.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.0.0.bb index eefa870a..26f25d72 100644 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.0.0.bb +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.0.0.bb | |||
@@ -28,8 +28,8 @@ inherit pkgconfig meson use-imx-headers | |||
28 | # is needed to improve performance. | 28 | # is needed to improve performance. |
29 | LIBG2D_DPU_OPTION = "-Dg2d-based-on-dpu=false" | 29 | LIBG2D_DPU_OPTION = "-Dg2d-based-on-dpu=false" |
30 | LIBG2D_DEPENDENCIES = "virtual/libg2d" | 30 | LIBG2D_DEPENDENCIES = "virtual/libg2d" |
31 | LIBG2D_DPU_OPTION_imxdpu = "-Dg2d-based-on-dpu=true" | 31 | LIBG2D_DPU_OPTION:imxdpu = "-Dg2d-based-on-dpu=true" |
32 | LIBG2D_DEPENDENCIES_imxdpu = "virtual/libg2d libdrm" | 32 | LIBG2D_DEPENDENCIES:imxdpu = "virtual/libg2d libdrm" |
33 | 33 | ||
34 | EXTRA_OEMESON += "-Dimx-headers-path=${STAGING_INCDIR_IMX}" | 34 | EXTRA_OEMESON += "-Dimx-headers-path=${STAGING_INCDIR_IMX}" |
35 | 35 | ||