diff options
-rw-r--r-- | recipes-bsp/rcw/ls2-rcw_git.bb | 29 |
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-bsp/rcw/ls2-rcw_git.bb b/recipes-bsp/rcw/ls2-rcw_git.bb new file mode 100644 index 00000000..b6d9ccd3 --- /dev/null +++ b/recipes-bsp/rcw/ls2-rcw_git.bb | |||
@@ -0,0 +1,29 @@ | |||
1 | SUMMARY = "Reset Configuration Word" | ||
2 | DESCRIPTION = "Reset Configuration Word - hardware boot-time parameters for the QorIQ targets" | ||
3 | LICENSE = "Freescale-EULA" | ||
4 | LIC_FILES_CHKSUM = "file://EULA;md5=c9ae442cf1f9dd6c13dfad64b0ffe73f" | ||
5 | |||
6 | inherit deploy | ||
7 | |||
8 | INHIBIT_DEFAULT_DEPS = "1" | ||
9 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
10 | |||
11 | SRC_URI = "git://git.freescale.com/ppc/sdk/ls2-rcw.git;branch=sdk-v2.0.x" | ||
12 | SRCREV = "74ec3bcdf33fbbedf417b800e0d486d1e8031115" | ||
13 | |||
14 | S = "${WORKDIR}/git" | ||
15 | |||
16 | do_install () { | ||
17 | install -d ${D}/boot/rcw | ||
18 | cp -r ${S}/ls2080a/RDB/* ${D}/boot/rcw | ||
19 | } | ||
20 | |||
21 | do_deploy () { | ||
22 | install -d ${DEPLOYDIR}/rcw | ||
23 | cp -r ${S}/ls2080a/RDB/* ${DEPLOYDIR}/rcw | ||
24 | } | ||
25 | addtask deploy before do_build after do_install | ||
26 | |||
27 | PACKAGES += "${PN}-image" | ||
28 | FILES_${PN}-image += "/boot" | ||
29 | COMPATIBLE_MACHINE = "(ls2080ardb)" | ||