summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/firmware-imx/firmware-imx-8_8.18.bb22
1 files changed, 19 insertions, 3 deletions
diff --git a/recipes-bsp/firmware-imx/firmware-imx-8_8.18.bb b/recipes-bsp/firmware-imx/firmware-imx-8_8.18.bb
index 18ce14d3..72a3fb99 100644
--- a/recipes-bsp/firmware-imx/firmware-imx-8_8.18.bb
+++ b/recipes-bsp/firmware-imx/firmware-imx-8_8.18.bb
@@ -4,20 +4,36 @@ DESCRIPTION = "Freescale i.MX firmware for 8 family"
4 4
5require firmware-imx-${PV}.inc 5require firmware-imx-${PV}.inc
6 6
7inherit deploy 7inherit deploy nopackages
8 8
9do_install[noexec] = "1" 9do_install[noexec] = "1"
10 10
11do_deploy() { 11SOC_FAMILY = "INVALID"
12SOC_FAMILY:mx8-generic-bsp = "mx8"
13SOC_FAMILY:mx9-generic-bsp = "mx9"
14
15deploy_mx8() {
12 # Cadence HDMI 16 # Cadence HDMI
13 install -m 0644 ${S}/firmware/hdmi/cadence/hdmitxfw.bin ${DEPLOYDIR} 17 install -m 0644 ${S}/firmware/hdmi/cadence/hdmitxfw.bin ${DEPLOYDIR}
14 install -m 0644 ${S}/firmware/hdmi/cadence/hdmirxfw.bin ${DEPLOYDIR} 18 install -m 0644 ${S}/firmware/hdmi/cadence/hdmirxfw.bin ${DEPLOYDIR}
15 install -m 0644 ${S}/firmware/hdmi/cadence/dpfw.bin ${DEPLOYDIR} 19 install -m 0644 ${S}/firmware/hdmi/cadence/dpfw.bin ${DEPLOYDIR}
16} 20}
21
22deploy_mx9() {
23 # Synopsys DDR
24 for ddr_firmware in ${DDR_FIRMWARE_NAME}; do
25 install -m 0644 ${S}/firmware/ddr/synopsys/${ddr_firmware} ${DEPLOYDIR}
26 done
27}
28
29do_deploy() {
30 deploy_${SOC_FAMILY}
31}
32
17addtask deploy after do_install before do_build 33addtask deploy after do_install before do_build
18 34
19PACKAGE_ARCH = "${MACHINE_SOCARCH}" 35PACKAGE_ARCH = "${MACHINE_SOCARCH}"
20 36
21COMPATIBLE_MACHINE = "(mx8-nxp-bsp)" 37COMPATIBLE_MACHINE = "(mx8-nxp-bsp|mx9-nxp-bsp)"
22COMPATIBLE_MACHINE:mx8m-nxp-bsp = "(^$)" 38COMPATIBLE_MACHINE:mx8m-nxp-bsp = "(^$)"
23COMPATIBLE_MACHINE:mx8x-nxp-bsp = "(^$)" 39COMPATIBLE_MACHINE:mx8x-nxp-bsp = "(^$)"