summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend8
1 files changed, 6 insertions, 2 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index fa088b6f..3a91fbe6 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -37,6 +37,10 @@ PACKAGECONFIG_USE_G2D:mx8qm-nxp-bsp ?= ""
37PACKAGECONFIG_USE_G2D:mx8qxp-nxp-bsp ?= "" 37PACKAGECONFIG_USE_G2D:mx8qxp-nxp-bsp ?= ""
38PACKAGECONFIG_USE_G2D:mx8dx-nxp-bsp ?= "" 38PACKAGECONFIG_USE_G2D:mx8dx-nxp-bsp ?= ""
39 39
40USE_G2D_VALUE = "true"
41USE_G2D_VALUE:mx6-nxp-bsp = "1"
42USE_G2D_VALUE:mx7-nxp-bsp = "1"
43
40PACKAGECONFIG[gbm-format] = ",," 44PACKAGECONFIG[gbm-format] = ",,"
41PACKAGECONFIG[rdp] = ",," 45PACKAGECONFIG[rdp] = ",,"
42PACKAGECONFIG[repaint-window] = ",," 46PACKAGECONFIG[repaint-window] = ",,"
@@ -66,9 +70,9 @@ do_install:append() {
66 fi 70 fi
67 71
68 if [ "${@bb.utils.contains('PACKAGECONFIG', 'use-g2d', 'yes', 'no', d)}" = "yes" ]; then 72 if [ "${@bb.utils.contains('PACKAGECONFIG', 'use-g2d', 'yes', 'no', d)}" = "yes" ]; then
69 sed -i -e "/^\[core\]/a use-g2d=1" ${D}${sysconfdir}/xdg/weston/weston.ini 73 sed -i -e "/^\[core\]/a use-g2d=${USE_G2D_VALUE}" ${D}${sysconfdir}/xdg/weston/weston.ini
70 else 74 else
71 sed -i -e "/^\[core\]/a #use-g2d=1" ${D}${sysconfdir}/xdg/weston/weston.ini 75 sed -i -e "/^\[core\]/a #use-g2d=${USE_G2D_VALUE}" ${D}${sysconfdir}/xdg/weston/weston.ini
72 fi 76 fi
73 77
74 sed -i -e 's,@bindir@,${bindir},g' ${D}${sysconfdir}/xdg/weston/weston.ini 78 sed -i -e 's,@bindir@,${bindir},g' ${D}${sysconfdir}/xdg/weston/weston.ini