diff options
-rw-r--r-- | recipes-graphics/drm/libdrm/0001-configure.ac-Allow-explicit-enabling-of-cunit-tests.patch | 24 | ||||
-rw-r--r-- | recipes-graphics/drm/libdrm_2.4.91.imx.bb (renamed from recipes-graphics/drm/libdrm_2.4.84.imx.bb) | 7 |
2 files changed, 14 insertions, 17 deletions
diff --git a/recipes-graphics/drm/libdrm/0001-configure.ac-Allow-explicit-enabling-of-cunit-tests.patch b/recipes-graphics/drm/libdrm/0001-configure.ac-Allow-explicit-enabling-of-cunit-tests.patch index bf526370..fa7b218e 100644 --- a/recipes-graphics/drm/libdrm/0001-configure.ac-Allow-explicit-enabling-of-cunit-tests.patch +++ b/recipes-graphics/drm/libdrm/0001-configure.ac-Allow-explicit-enabling-of-cunit-tests.patch | |||
@@ -1,22 +1,23 @@ | |||
1 | From e6bd4205b0b546afe991ae6f72256645f4404ad4 Mon Sep 17 00:00:00 2001 | 1 | From 9be904a70e6b7e6b3cc4e1b270bca02d14a4179b Mon Sep 17 00:00:00 2001 |
2 | From: Jussi Kukkonen <jussi.kukkonen@intel.com> | 2 | From: Jussi Kukkonen <jussi.kukkonen@intel.com> |
3 | Date: Mon, 5 Sep 2016 14:41:37 +0300 | 3 | Date: Mon, 5 Sep 2016 14:41:37 +0300 |
4 | Subject: [PATCH libdrm] configure.ac: Allow explicit enabling of cunit tests | 4 | Subject: [PATCH] configure.ac: Allow explicit enabling of cunit tests |
5 | 5 | ||
6 | Add --with-cunit to make it easier to do reproducible builds. Default | 6 | Add --with-cunit to make it easier to do reproducible builds. Default |
7 | is still to probe cunit and build opportunistically. | 7 | is still to probe cunit and build opportunistically. |
8 | 8 | ||
9 | Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> | 9 | Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> |
10 | Upstream-Status: Submitted [mailing list] | 10 | Upstream-Status: Submitted [mailing list] |
11 | |||
11 | --- | 12 | --- |
12 | configure.ac | 14 ++++++++++++-- | 13 | configure.ac | 14 ++++++++++++-- |
13 | 1 file changed, 12 insertions(+), 2 deletions(-) | 14 | 1 file changed, 12 insertions(+), 2 deletions(-) |
14 | 15 | ||
15 | diff --git a/configure.ac b/configure.ac | 16 | diff --git a/configure.ac b/configure.ac |
16 | index e3048c7..918d21d 100644 | 17 | index 1341f51..bef46e0 100644 |
17 | --- a/configure.ac | 18 | --- a/configure.ac |
18 | +++ b/configure.ac | 19 | +++ b/configure.ac |
19 | @@ -137,6 +137,12 @@ AC_ARG_ENABLE(install-test-programs, | 20 | @@ -168,6 +168,12 @@ AC_ARG_ENABLE(install-test-programs, |
20 | [Install test programs (default: no)]), | 21 | [Install test programs (default: no)]), |
21 | [INSTALL_TESTS=$enableval], [INSTALL_TESTS=no]) | 22 | [INSTALL_TESTS=$enableval], [INSTALL_TESTS=no]) |
22 | 23 | ||
@@ -29,8 +30,8 @@ index e3048c7..918d21d 100644 | |||
29 | dnl =========================================================================== | 30 | dnl =========================================================================== |
30 | dnl check compiler flags | 31 | dnl check compiler flags |
31 | AC_DEFUN([LIBDRM_CC_TRY_FLAG], [ | 32 | AC_DEFUN([LIBDRM_CC_TRY_FLAG], [ |
32 | @@ -372,7 +378,7 @@ if test "x$RADEON" = xyes; then | 33 | @@ -416,7 +422,7 @@ else |
33 | AC_DEFINE(HAVE_RADEON, 1, [Have radeon support]) | 34 | AC_DEFINE(HAVE_RADEON, 0) |
34 | fi | 35 | fi |
35 | 36 | ||
36 | -if test "x$AMDGPU" != xno; then | 37 | -if test "x$AMDGPU" != xno; then |
@@ -38,8 +39,8 @@ index e3048c7..918d21d 100644 | |||
38 | # Detect cunit library | 39 | # Detect cunit library |
39 | PKG_CHECK_MODULES([CUNIT], [cunit >= 2.1], [have_cunit=yes], [have_cunit=no]) | 40 | PKG_CHECK_MODULES([CUNIT], [cunit >= 2.1], [have_cunit=yes], [have_cunit=no]) |
40 | # If pkg-config does not find cunit, check it using AC_CHECK_LIB. We | 41 | # If pkg-config does not find cunit, check it using AC_CHECK_LIB. We |
41 | @@ -399,7 +406,11 @@ if test "x$AMDGPU" = xyes; then | 42 | @@ -441,7 +447,11 @@ if test "x$AMDGPU" = xyes; then |
42 | AC_DEFINE(HAVE_CUNIT, [test "x$have_cunit" != "xno"], [Enable CUNIT Have amdgpu support]) | 43 | AC_DEFINE(HAVE_AMDGPU, 1, [Have amdgpu support]) |
43 | 44 | ||
44 | if test "x$have_cunit" = "xno"; then | 45 | if test "x$have_cunit" = "xno"; then |
45 | - AC_MSG_WARN([Could not find cunit library. Disabling amdgpu tests]) | 46 | - AC_MSG_WARN([Could not find cunit library. Disabling amdgpu tests]) |
@@ -49,8 +50,5 @@ index e3048c7..918d21d 100644 | |||
49 | + AC_MSG_WARN([Could not find cunit library. Disabling amdgpu tests]) | 50 | + AC_MSG_WARN([Could not find cunit library. Disabling amdgpu tests]) |
50 | + fi | 51 | + fi |
51 | fi | 52 | fi |
52 | fi | 53 | else |
53 | 54 | AC_DEFINE(HAVE_AMDGPU, 0) | |
54 | -- | ||
55 | 2.1.4 | ||
56 | |||
diff --git a/recipes-graphics/drm/libdrm_2.4.84.imx.bb b/recipes-graphics/drm/libdrm_2.4.91.imx.bb index 317b8f62..b3e8f1e1 100644 --- a/recipes-graphics/drm/libdrm_2.4.84.imx.bb +++ b/recipes-graphics/drm/libdrm_2.4.91.imx.bb | |||
@@ -11,14 +11,15 @@ PROVIDES = "drm" | |||
11 | DEPENDS = "libpthread-stubs libpciaccess" | 11 | DEPENDS = "libpthread-stubs libpciaccess" |
12 | 12 | ||
13 | IMX_LIBDRM_SRC ?= "git://source.codeaurora.org/external/imx/libdrm-imx.git;protocol=https" | 13 | IMX_LIBDRM_SRC ?= "git://source.codeaurora.org/external/imx/libdrm-imx.git;protocol=https" |
14 | IMX_LIBDRM_BRANCH = "libdrm-imx-2.4.84" | 14 | IMX_LIBDRM_BRANCH = "libdrm-imx-2.4.91" |
15 | SRC_URI = "${IMX_LIBDRM_SRC};branch=${IMX_LIBDRM_BRANCH} \ | 15 | SRC_URI = "${IMX_LIBDRM_SRC};branch=${IMX_LIBDRM_BRANCH} \ |
16 | file://installtests.patch \ | 16 | file://installtests.patch \ |
17 | file://fix_O_CLOEXEC_undeclared.patch \ | 17 | file://fix_O_CLOEXEC_undeclared.patch \ |
18 | file://0001-configure.ac-Allow-explicit-enabling-of-cunit-tests.patch \ | 18 | file://0001-configure.ac-Allow-explicit-enabling-of-cunit-tests.patch \ |
19 | " | 19 | " |
20 | SRC_URI_remove_mx8 = "file://drm-update-arm.patch" | 20 | SRC_URI_remove_mx8 = "file://drm-update-arm.patch" |
21 | SRCREV = "8c8c46d41839035de605291bc1c26902011a74ac" | 21 | SRCREV = "e8e9cf8a66be11508c39f1cc31b8a5e7eb758875" |
22 | S = "${WORKDIR}/git" | ||
22 | 23 | ||
23 | DEFAULT_PREFERENCE = "-1" | 24 | DEFAULT_PREFERENCE = "-1" |
24 | 25 | ||
@@ -61,6 +62,4 @@ RRECOMMENDS_${PN}-drivers_append_imxgpu = " ${PN}-vivante" | |||
61 | 62 | ||
62 | FILES_${PN}-vivante = "${libdir}/libdrm_vivante.so.*" | 63 | FILES_${PN}-vivante = "${libdir}/libdrm_vivante.so.*" |
63 | 64 | ||
64 | S = "${WORKDIR}/git" | ||
65 | |||
66 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" | 65 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" |