summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/atf/atf/0001-Makefile-add-CC-gcc.patch28
-rw-r--r--recipes-bsp/atf/atf/0001-fix-fiptool-build-error.patch28
-rw-r--r--recipes-bsp/atf/atf_git.bb156
3 files changed, 212 insertions, 0 deletions
diff --git a/recipes-bsp/atf/atf/0001-Makefile-add-CC-gcc.patch b/recipes-bsp/atf/atf/0001-Makefile-add-CC-gcc.patch
new file mode 100644
index 00000000..efa2749e
--- /dev/null
+++ b/recipes-bsp/atf/atf/0001-Makefile-add-CC-gcc.patch
@@ -0,0 +1,28 @@
1From 3161524085339ae214f7dee17a98ccd6c442d66b Mon Sep 17 00:00:00 2001
2From: Chunrong Guo <chunrong.guo@nxp.com>
3Date: Thu, 16 Aug 2018 17:38:04 +0800
4Subject: [PATCH] Makefile: add CC=gcc
5
6
7Upstream-Status: Inappropriate [embedded specific]
8
9Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
10---
11 plat/nxp/tools/Makefile | 1 +
12 1 file changed, 1 insertion(+)
13
14diff --git a/plat/nxp/tools/Makefile b/plat/nxp/tools/Makefile
15index e648fd1..43d3b56 100644
16--- a/plat/nxp/tools/Makefile
17+++ b/plat/nxp/tools/Makefile
18@@ -32,6 +32,7 @@ endif
19 INCLUDE_PATHS :=
20
21 HOSTCC ?= gcc
22+CC = gcc
23
24 .PHONY: all clean distclean
25
26--
272.7.4
28
diff --git a/recipes-bsp/atf/atf/0001-fix-fiptool-build-error.patch b/recipes-bsp/atf/atf/0001-fix-fiptool-build-error.patch
new file mode 100644
index 00000000..ffd9965a
--- /dev/null
+++ b/recipes-bsp/atf/atf/0001-fix-fiptool-build-error.patch
@@ -0,0 +1,28 @@
1From a76ae26fdb673613f5f97872b7275c630b7b24b8 Mon Sep 17 00:00:00 2001
2From: BJ DevOps Team <bjdevops@NXP1.onmicrosoft.com>
3Date: Wed, 16 May 2018 13:26:45 +0800
4Subject: [PATCH] fix fiptool build error
5
6Upstream-Status: Inappropriate [embedded specific]
7
8---
9 tools/fiptool/Makefile | 3 ++-
10 1 file changed, 2 insertions(+), 1 deletion(-)
11
12diff --git a/tools/fiptool/Makefile b/tools/fiptool/Makefile
13index e0e3923..f213f44 100644
14--- a/tools/fiptool/Makefile
15+++ b/tools/fiptool/Makefile
16@@ -19,7 +19,8 @@ ifeq (${DEBUG},1)
17 else
18 CFLAGS += -O2
19 endif
20-LDLIBS := -lcrypto
21+
22+LDLIBS := -Wl,-rpath=${LIBPATH}/usr/lib -L${LIBPATH}/usr/lib -lcrypto
23
24 ifeq (${V},0)
25 Q := @
26--
271.8.3.1
28
diff --git a/recipes-bsp/atf/atf_git.bb b/recipes-bsp/atf/atf_git.bb
new file mode 100644
index 00000000..45bd376c
--- /dev/null
+++ b/recipes-bsp/atf/atf_git.bb
@@ -0,0 +1,156 @@
1DESCRIPTION = "ARM Trusted Firmware"
2
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://license.rst;md5=e927e02bca647e14efd87e9e914b2443"
5
6inherit deploy
7
8DEPENDS += "u-boot-mkimage-native u-boot openssl openssl-native mbedtls rcw cst-native uefi"
9DEPENDS_append_qoriq-arm64 += "optee-os-qoriq"
10do_compile[depends] += "u-boot:do_deploy rcw:do_deploy uefi:do_deploy"
11
12S = "${WORKDIR}/git"
13
14SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/atf;nobranch=1"
15SRCREV = "4971f394cf32e33e3a9ca23a4faa49d606af31c5"
16
17SRC_URI += "file://0001-fix-fiptool-build-error.patch \
18 file://0001-Makefile-add-CC-gcc.patch \
19"
20COMPATIBLE_MACHINE = "(qoriq)"
21PLATFORM = "${MACHINE}"
22PLATFORM_ls1088ardb-pb = "ls1088ardb"
23# requires CROSS_COMPILE set by hand as there is no configure script
24export CROSS_COMPILE="${TARGET_PREFIX}"
25export ARCH="arm64"
26# Let the Makefile handle setting up the CFLAGS and LDFLAGS as it is a standalone application
27CFLAGS[unexport] = "1"
28LDFLAGS[unexport] = "1"
29AS[unexport] = "1"
30LD[unexport] = "1"
31
32# set secure option
33# fuseopt ?= "FUSE_PROV=1 FUSE_FILE=$(CONFIG_SEC_FUSE_FILE)"
34
35BOOTTYPE ?= "nor nand qspi flexspi_nor sd emmc"
36BUILD_SECURE = "${@bb.utils.contains('COMBINED_FEATURES', 'secure', 'true', 'false', d)}"
37BUILD_OPTEE = "${@bb.utils.contains('COMBINED_FEATURES', 'optee', 'true', 'false', d)}"
38
39uboot_boot_sec ?= "${DEPLOY_DIR_IMAGE}/u-boot.bin-tfa-secure-boot"
40uboot_boot ?= "${DEPLOY_DIR_IMAGE}/u-boot.bin-tfa"
41rcw ?= ""
42rcw_ls1012afrwy = "_default"
43rcw_ls1012ardb = "_default"
44rcwsec ?= ""
45rcwsec_ls1012afrwy = "_sben"
46rcwsec_ls1012ardb = "_sben"
47do_configure[noexec] = "1"
48
49do_compile() {
50 export LIBPATH="${RECIPE_SYSROOT_NATIVE}"
51 install -d ${S}/include/tools_share/openssl
52 cp -r ${RECIPE_SYSROOT}/usr/include/openssl/* ${S}/include/tools_share/openssl
53 ${RECIPE_SYSROOT_NATIVE}/usr/bin/cst/gen_keys 1024
54 if [ "${BUILD_SECURE}" = "true" ]; then
55 secureopt="TRUSTED_BOARD_BOOT=1 $ddrphyopt CST_DIR=${RECIPE_SYSROOT_NATIVE}/usr/bin/cst"
56 secext="_sec"
57 bl33="${uboot_boot_sec}"
58 rcwsec="${rcwsec}"
59 else
60 bl33="${uboot_boot}"
61 rcwsec="${rcw}"
62 fi
63
64 if [ "${BUILD_OPTEE}" = "true" ]; then
65 bl32="${DEPLOY_DIR_IMAGE}/optee/tee_${MACHINE}.bin"
66 bl32opt="BL32=${bl32}"
67 spdopt="SPD=opteed"
68 fi
69
70 for d in ${BOOTTYPE}; do
71 case $d in
72 nor)
73 rcwimg="${RCWNOR}${rcwsec}.bin"
74 uefiboot="${UEFI_NORBOOT}"
75 ;;
76 nand)
77 rcwimg="${RCWNAND}${rcwsec}.bin"
78 ;;
79 qspi)
80 rcwimg="${RCWQSPI}${rcwsec}.bin"
81 ;;
82 sd)
83 rcwimg="${RCWSD}${rcwsec}.bin"
84 ;;
85 flexspi_nor)
86 rcwimg="${RCWXSPI}${rcwsec}.bin"
87 uefiboot="${UEFI_XSPIBOOT}"
88 ;;
89 esac
90
91 if [ -f "${DEPLOY_DIR_IMAGE}/rcw/${PLATFORM}/${rcwimg}" ]; then
92 if [ ${MACHINE} = ls1012afrwy ]; then
93 oe_runmake V=1 -C ${S} realclean
94 oe_runmake V=1 -C ${S} all fip pbl PLAT=ls1012afrwy_512mb BOOT_MODE=${d} RCW=${DEPLOY_DIR_IMAGE}/rcw/${PLATFORM}/${rcwimg} BL33=${bl33} ${bl32opt} ${spdopt} ${secureopt} ${fuseopt}
95 cp -r ${S}/build/ls1012afrwy_512mb/release/bl2_qspi.pbl ${S}/bl2_${d}_512mb.pbl
96 cp -r ${S}/build/ls1012afrwy_512mb/release/fip.bin ${S}/fip_512mb.bin
97 fi
98 if [ -n "${uefiboot}" ]; then
99 oe_runmake V=1 -C ${S} realclean
100 oe_runmake V=1 -C ${S} all fip pbl PLAT=${PLATFORM} BOOT_MODE=${d} RCW=${DEPLOY_DIR_IMAGE}/rcw/${PLATFORM}/${rcwimg} BL33=${DEPLOY_DIR_IMAGE}/uefi/${PLATFORM}/${uefiboot} ${bl32opt} ${spdopt} ${secureopt} ${fuseopt}
101 cp -r ${S}/build/${PLATFORM}/release/fip.bin ${S}/fip_uefi.bin
102 fi
103 oe_runmake V=1 -C ${S} realclean
104 oe_runmake V=1 -C ${S} all fip pbl PLAT=${PLATFORM} BOOT_MODE=${d} RCW=${DEPLOY_DIR_IMAGE}/rcw/${PLATFORM}/${rcwimg} BL33=${bl33} ${bl32opt} ${spdopt} ${secureopt} ${fuseopt}
105 cp -r ${S}/build/${PLATFORM}/release/bl2_${d}*.pbl ${S}
106 fi
107 rcwimg=""
108 uefiboot=""
109 done
110}
111
112do_install() {
113 install -d ${D}/boot/atf
114 if [ "${BUILD_SECURE}" = "y" ]; then
115 secext="_sec"
116 fi
117 if [ -f "${S}/fip_uefi.bin" ]; then
118 cp -r ${S}/fip_uefi.bin ${D}/boot/atf/fip_uefi.bin
119 fi
120 cp -r ${S}/build/${PLATFORM}/release/fip.bin ${D}/boot/atf/fip.bin
121 for d in ${BOOTTYPE}; do
122 if [ -e ${S}/bl2_${d}${secext}.pbl ]; then
123 cp -r ${S}/bl2_${d}${secext}.pbl ${D}/boot/atf/bl2_${d}${secext}.pbl
124 fi
125 done
126 if [ ${MACHINE} = ls1012afrwy ]; then
127 cp -r ${S}/fip_512mb.bin ${D}/boot/atf/fip_512mb.bin
128 cp -r ${S}/bl2_qspi_512mb.pbl ${D}/boot/atf/fip_512mb.bin
129 fi
130 chown -R root:root ${D}
131}
132
133do_deploy() {
134 install -d ${DEPLOYDIR}/atf
135 if [ "${BUILD_SECURE}" = "y" ]; then
136 secext="_sec"
137 fi
138
139 if [ -e ${D}/boot/atf/fip_uefi.bin ]; then
140 cp -r ${D}/boot/atf/fip_uefi.bin ${DEPLOYDIR}/atf/fip_uefi.bin
141 fi
142 cp -r ${D}/boot/atf/fip.bin ${DEPLOYDIR}/atf/fip_uboot${secext}.bin
143 for d in ${BOOTTYPE}; do
144 if [ -e ${D}/boot/atf/bl2_${d}${secext}.pbl ]; then
145 cp -r ${D}/boot/atf/bl2_${d}${secext}.pbl ${DEPLOYDIR}/atf/bl2_${d}${secext}.pbl
146 fi
147 done
148 if [ ${MACHINE} = ls1012afrwy ]; then
149 cp -r ${S}/bl2_qspi_512mb.pbl ${DEPLOYDIR}/atf/
150 cp -r ${S}/fip_512mb.bin ${DEPLOYDIR}/atf/fip_uboot${secext}_512mb.bin
151 fi
152}
153addtask deploy after do_install
154FILES_${PN} += "/boot"
155BBCLASSEXTEND = "native nativesdk"
156COMPATIBLE_MACHINE = "(qoriq)"