diff options
-rw-r--r-- | conf/machine/include/imx-base.inc | 6 | ||||
-rw-r--r-- | recipes-graphics/mesa/mesa_%.bbappend | 3 | ||||
-rw-r--r-- | recipes-graphics/xorg-xserver/xserver-xf86-config/use-mainline-bsp/xorg.conf | 31 |
3 files changed, 15 insertions, 25 deletions
diff --git a/conf/machine/include/imx-base.inc b/conf/machine/include/imx-base.inc index 16d48da9..a1ab6cc3 100644 --- a/conf/machine/include/imx-base.inc +++ b/conf/machine/include/imx-base.inc | |||
@@ -101,7 +101,11 @@ XSERVER_DRIVER = "xf86-video-fbdev" | |||
101 | XSERVER_DRIVER_imxgpu2d = "xf86-video-imx-vivante" | 101 | XSERVER_DRIVER_imxgpu2d = "xf86-video-imx-vivante" |
102 | XSERVER_DRIVER_vf = "xf86-video-modesetting" | 102 | XSERVER_DRIVER_vf = "xf86-video-modesetting" |
103 | XSERVER_DRIVER_append_mx8 = " xf86-video-modesetting" | 103 | XSERVER_DRIVER_append_mx8 = " xf86-video-modesetting" |
104 | XSERVER_DRIVER_use-mainline-bsp = "xf86-video-armada" | 104 | XSERVER_DRIVER_use-mainline-bsp = " \ |
105 | xf86-video-fbdev \ | ||
106 | xf86-video-modesetting \ | ||
107 | xserver-xorg-extension-glx \ | ||
108 | " | ||
105 | XSERVER = "xserver-xorg \ | 109 | XSERVER = "xserver-xorg \ |
106 | xf86-input-evdev \ | 110 | xf86-input-evdev \ |
107 | ${XSERVER_DRIVER}" | 111 | ${XSERVER_DRIVER}" |
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend index 76f1bc28..738f02c8 100644 --- a/recipes-graphics/mesa/mesa_%.bbappend +++ b/recipes-graphics/mesa/mesa_%.bbappend | |||
@@ -20,6 +20,9 @@ PACKAGECONFIG_append_use-mainline-bsp = " gallium etnaviv kmsro freedreno" | |||
20 | # For NXP BSP, GPU drivers don't support dri | 20 | # For NXP BSP, GPU drivers don't support dri |
21 | PACKAGECONFIG_remove_imxgpu_use-nxp-bsp = "dri" | 21 | PACKAGECONFIG_remove_imxgpu_use-nxp-bsp = "dri" |
22 | 22 | ||
23 | # mainline/etnaviv: | ||
24 | RRECOMMENDS_${PN}-megadriver_append_use-mainline-bsp = " libdrm-etnaviv mesa-etnaviv-env" | ||
25 | |||
23 | BACKEND = \ | 26 | BACKEND = \ |
24 | "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \ | 27 | "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \ |
25 | bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', \ | 28 | bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', \ |
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config/use-mainline-bsp/xorg.conf b/recipes-graphics/xorg-xserver/xserver-xf86-config/use-mainline-bsp/xorg.conf index b6f83469..c58ae207 100644 --- a/recipes-graphics/xorg-xserver/xserver-xf86-config/use-mainline-bsp/xorg.conf +++ b/recipes-graphics/xorg-xserver/xserver-xf86-config/use-mainline-bsp/xorg.conf | |||
@@ -1,28 +1,11 @@ | |||
1 | Section "Device" | 1 | Section "Device" |
2 | Identifier "Driver0" | 2 | Identifier "etnaviv" |
3 | Screen 0 | 3 | Driver "modesetting" |
4 | Driver "armada" | 4 | Option "kmsdev" "/dev/dri/card0" |
5 | 5 | Option "AccelMethod" "glamor" | |
6 | # Support hotplugging displays? | 6 | EndSection |
7 | Option "Hotplug" "TRUE" | ||
8 | |||
9 | # Support hardware cursor if available? | ||
10 | Option "HWCursor" "TRUE" | ||
11 | |||
12 | # Use GPU acceleration? | ||
13 | Option "UseGPU" "TRUE" | ||
14 | |||
15 | # Provide Xv interfaces? | ||
16 | Option "XvAccel" "TRUE" | ||
17 | |||
18 | # Prefer overlay for Xv (TRUE for armada-drm, FALSE for imx-drm) | ||
19 | Option "XvPreferOverlay" "TRUE" | ||
20 | |||
21 | # Which accelerator module to load (automatically found if commented out) | ||
22 | Option "AccelModule" "etnadrm_gpu" | ||
23 | Option "AccelModule" "etnaviv_gpu" | ||
24 | 7 | ||
25 | # Support DRI2 interfaces? | 8 | Section "ServerFlags" |
26 | Option "DRI" "TRUE" | 9 | Option "AutoAddGPU" "false" |
27 | EndSection | 10 | EndSection |
28 | 11 | ||