summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg/0001-hw-xwayland-Makefile.am-fix-build-without-glx.patch44
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend10
2 files changed, 51 insertions, 3 deletions
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg/0001-hw-xwayland-Makefile.am-fix-build-without-glx.patch b/recipes-graphics/xorg-xserver/xserver-xorg/0001-hw-xwayland-Makefile.am-fix-build-without-glx.patch
new file mode 100644
index 00000000..48f271ae
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xorg/0001-hw-xwayland-Makefile.am-fix-build-without-glx.patch
@@ -0,0 +1,44 @@
1From 836f93de99b35050d78d61d3654f7c5655184144 Mon Sep 17 00:00:00 2001
2From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
3Date: Fri, 19 Apr 2019 10:19:50 +0200
4Subject: [PATCH] hw/xwayland/Makefile.am: fix build without glx
5
6Commit d8ec33fe0542141aed1d9016d2ecaf52da944b4b added libglxvnd.la to
7Xwayland_LDFLAGS but GLX can be disabled through --disable-glx.
8In this case, build fails on:
9
10make[3]: *** No rule to make target '../../glx/libglxvnd.la', needed by 'Xwayland'. Stop.
11make[3]: *** Waiting for unfinished jobs....
12
13Fixes:
14 - http://autobuild.buildroot.org/results/397f8098c57fc6c88aa12dc8d35ebb1b933d52ef
15
16Upstream-Status: Backport [836f93de99b35050d78d61d3654f7c5655184144]
17Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
18---
19 hw/xwayland/Makefile.am | 6 +++++-
20 1 file changed, 5 insertions(+), 1 deletion(-)
21
22diff --git a/hw/xwayland/Makefile.am b/hw/xwayland/Makefile.am
23index bc1cb8506..502879e2a 100644
24--- a/hw/xwayland/Makefile.am
25+++ b/hw/xwayland/Makefile.am
26@@ -21,10 +21,14 @@ Xwayland_SOURCES = \
27 $(top_srcdir)/Xi/stubs.c \
28 $(top_srcdir)/mi/miinitext.c
29
30+if GLX
31+GLXVND_LIB = $(top_builddir)/glx/libglxvnd.la
32+endif
33+
34 Xwayland_LDADD = \
35 $(glamor_lib) \
36 $(XWAYLAND_LIBS) \
37- $(top_builddir)/glx/libglxvnd.la \
38+ $(GLXVND_LIB) \
39 $(XWAYLAND_SYS_LIBS) \
40 $(top_builddir)/Xext/libXvidmode.la \
41 $(XSERVER_SYS_LIBS)
42--
432.17.1
44
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend b/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend
index 84b69075..9eb149f0 100644
--- a/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend
+++ b/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend
@@ -1,8 +1,12 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
2SRC_URI_append_imxgpu = " \
3 file://0003-Remove-check-for-useSIGIO-option.patch \
4 file://0001-hw-xwayland-Makefile.am-fix-build-without-glx.patch \
5"
6
1IMX_OPENGL_PKGCONFIGS_REMOVE = "" 7IMX_OPENGL_PKGCONFIGS_REMOVE = ""
2IMX_OPENGL_PKGCONFIGS_REMOVE_imxgpu = "glamor" 8IMX_OPENGL_PKGCONFIGS_REMOVE_imxgpu = "glamor"
3OPENGL_PKGCONFIGS_remove_mx6 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" 9OPENGL_PKGCONFIGS_remove_mx6 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}"
4OPENGL_PKGCONFIGS_remove_mx7 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" 10OPENGL_PKGCONFIGS_remove_mx7 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}"
5OPENGL_PKGCONFIGS_remove_mx8 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" 11OPENGL_PKGCONFIGS_remove_mx8 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}"
6 12OPENGL_PKGCONFIGS_remove_imxdrm = "dri glx"
7FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
8SRC_URI_append_imxgpu2d = " file://0003-Remove-check-for-useSIGIO-option.patch"