diff options
-rw-r--r-- | recipes-extended/secure-obj/secure-obj.inc | 4 | ||||
-rw-r--r-- | recipes-extended/secure-obj/secure-obj_git.bb | 21 |
2 files changed, 15 insertions, 10 deletions
diff --git a/recipes-extended/secure-obj/secure-obj.inc b/recipes-extended/secure-obj/secure-obj.inc index 3fd70eb8..3fc5b89d 100644 --- a/recipes-extended/secure-obj/secure-obj.inc +++ b/recipes-extended/secure-obj/secure-obj.inc | |||
@@ -12,7 +12,7 @@ LDFLAGS += "${TOOLCHAIN_OPTIONS}" | |||
12 | 12 | ||
13 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/secure_obj;nobranch=1 \ | 13 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/secure_obj;nobranch=1 \ |
14 | " | 14 | " |
15 | SRCREV = "74befe01bda41f1c27b197ef2ab66e475e9a81b3" | 15 | SRCREV = "24d31333bd50f212ac692db83a4a2d88d0dadb52" |
16 | 16 | ||
17 | WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" | 17 | WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" |
18 | export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/" | 18 | export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/" |
@@ -24,4 +24,4 @@ ALLOW_EMPTY_${PN} = "1" | |||
24 | INHIBIT_PACKAGE_STRIP = "1" | 24 | INHIBIT_PACKAGE_STRIP = "1" |
25 | PARALLEL_MAKE = "" | 25 | PARALLEL_MAKE = "" |
26 | INSANE_SKIP_${PN} = "ldflags" | 26 | INSANE_SKIP_${PN} = "ldflags" |
27 | COMPATIBLE_MACHINE = "(ls2080ardb|ls2084ardb|ls2088a|ls1043a|ls1046a|ls1088a)" | 27 | COMPATIBLE_MACHINE = "(ls2080ardb|ls2084ardb|ls2088a|ls1043a|ls1046a|ls1088a|ls1012a)" |
diff --git a/recipes-extended/secure-obj/secure-obj_git.bb b/recipes-extended/secure-obj/secure-obj_git.bb index 103c089e..db881b19 100644 --- a/recipes-extended/secure-obj/secure-obj_git.bb +++ b/recipes-extended/secure-obj/secure-obj_git.bb | |||
@@ -9,6 +9,8 @@ export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/" | |||
9 | export OPTEE_CLIENT_EXPORT = "${RECIPE_SYSROOT}/usr" | 9 | export OPTEE_CLIENT_EXPORT = "${RECIPE_SYSROOT}/usr" |
10 | export CROSS_COMPILE_HOST = "${CROSS_COMPILE}" | 10 | export CROSS_COMPILE_HOST = "${CROSS_COMPILE}" |
11 | export CROSS_COMPILE_TA = "${CROSS_COMPILE}" | 11 | export CROSS_COMPILE_TA = "${CROSS_COMPILE}" |
12 | ARCH_qoriq-arm64 = "aarch64" | ||
13 | ARCH_qoriq-arm = "arm" | ||
12 | 14 | ||
13 | do_compile() { | 15 | do_compile() { |
14 | unset LDFLAGS | 16 | unset LDFLAGS |
@@ -23,15 +25,18 @@ do_compile() { | |||
23 | } | 25 | } |
24 | 26 | ||
25 | do_install() { | 27 | do_install() { |
26 | install -d ${D}${bindir}/secure_obj | 28 | install -d ${D}${bindir} |
27 | install -d ${D}${libdir}/secure_obj | ||
28 | install -d ${D}${includedir} | 29 | install -d ${D}${includedir} |
29 | cp ${S}/secure_storage_ta/ta/b05bcf48-9732-4efa-a9e0-141c7c888c34.ta ${D}${bindir}/secure_obj | 30 | install -d ${D}${base_libdir}/optee_armtz |
30 | cp ${S}/securekey_lib/out/export/lib/libsecure_obj.so ${D}${libdir}/secure_obj | 31 | install -d ${D}${libdir}/${ARCH}-linux-gnu/openssl-1.0.0/engines |
31 | cp ${S}/secure_obj-openssl-engine/libeng_secure_obj.so ${D}${libdir}/secure_obj | 32 | cp ${S}/secure_storage_ta/ta/b05bcf48-9732-4efa-a9e0-141c7c888c34.ta ${D}${base_libdir}/optee_armtz |
32 | cp ${S}/securekey_lib/out/export/app/* ${D}${bindir}/secure_obj | 33 | cp ${S}/securekey_lib/out/export/lib/libsecure_obj.so ${D}${libdir} |
34 | cp ${S}/secure_obj-openssl-engine/libeng_secure_obj.so ${D}${libdir}/${ARCH}-linux-gnu/openssl-1.0.0/engines | ||
35 | cp ${S}/securekey_lib/out/export/app/* ${D}${bindir} | ||
36 | cp ${S}/secure_obj-openssl-engine/app/sobj_eng_app ${D}${bindir} | ||
33 | cp ${S}/securekey_lib/out/export/include/* ${D}${includedir} | 37 | cp ${S}/securekey_lib/out/export/include/* ${D}${includedir} |
34 | cp ${S}/secure_obj-openssl-engine/app/sobj_eng_app ${D}${bindir}/secure_obj | ||
35 | } | 38 | } |
36 | 39 | ||
37 | FILES_${PN} += "${libdir}/secure_obj" | 40 | FILES_${PN} += "${base_libdir}/optee_armtz ${libdir}/${ARCH}-linux-gnu/openssl-1.0.0/engines" |
41 | INSANE_SKIP_${PN} = "dev-deps ldflags" | ||
42 | INSANE_SKIP_${PN}-dev = "ldflags dev-elf" | ||