summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.4.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.4.bb b/recipes-bsp/imx-atf/imx-atf_2.4.bb
index 8360bfa8..965e0948 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.4.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.4.bb
@@ -25,13 +25,16 @@ EXTRA_OEMAKE += " \
25 PLAT=${ATF_PLATFORM} \ 25 PLAT=${ATF_PLATFORM} \
26" 26"
27 27
28BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}" 28# Let the Makefile handle setting up the CFLAGS and LDFLAGS as it is a standalone application
29CFLAGS[unexport] = "1"
30LDFLAGS[unexport] = "1"
31AS[unexport] = "1"
32LD[unexport] = "1"
29 33
30CFLAGS:remove:mx8mq = "-O2" 34BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}"
31 35
32do_compile() { 36do_compile() {
33 # Clear LDFLAGS to avoid the option -Wl recognize issue 37 # Clear LDFLAGS to avoid the option -Wl recognize issue
34 unset LDFLAGS
35 oe_runmake bl31 38 oe_runmake bl31
36 if ${BUILD_OPTEE}; then 39 if ${BUILD_OPTEE}; then
37 oe_runmake clean BUILD_BASE=build-optee 40 oe_runmake clean BUILD_BASE=build-optee