diff options
-rw-r--r-- | recipes-security/optee/optee-test-qoriq/0001-fix-build-failure-with-GCC-8.patch | 40 | ||||
-rw-r--r-- | recipes-security/optee/optee-test-qoriq_git.bb | 5 |
2 files changed, 43 insertions, 2 deletions
diff --git a/recipes-security/optee/optee-test-qoriq/0001-fix-build-failure-with-GCC-8.patch b/recipes-security/optee/optee-test-qoriq/0001-fix-build-failure-with-GCC-8.patch new file mode 100644 index 00000000..bad7c5e0 --- /dev/null +++ b/recipes-security/optee/optee-test-qoriq/0001-fix-build-failure-with-GCC-8.patch | |||
@@ -0,0 +1,40 @@ | |||
1 | From d877fddcef79e856193b9b0a3a3089c22151047f Mon Sep 17 00:00:00 2001 | ||
2 | From: Chunrong Guo <chunrong.guo@nxp.com> | ||
3 | Date: Fri, 29 Jun 2018 15:49:34 +0800 | ||
4 | Subject: [PATCH] fix build failure with GCC 8 | ||
5 | |||
6 | Signed-off-by: BJ DevOps Team <bjdevops@NXP1.onmicrosoft.com> | ||
7 | --- | ||
8 | host/xtest/Makefile | 2 ++ | ||
9 | host/xtest/adbg/src/adbg_run.c | 2 +- | ||
10 | 2 files changed, 3 insertions(+), 1 deletion(-) | ||
11 | |||
12 | diff --git a/host/xtest/Makefile b/host/xtest/Makefile | ||
13 | index 832cba2..d95899d 100644 | ||
14 | --- a/host/xtest/Makefile | ||
15 | +++ b/host/xtest/Makefile | ||
16 | @@ -139,6 +139,8 @@ CFLAGS += -Wall -Wcast-align -Werror \ | ||
17 | -Wmissing-prototypes -Wnested-externs -Wpointer-arith \ | ||
18 | -Wshadow -Wstrict-prototypes -Wswitch-default \ | ||
19 | -Wwrite-strings \ | ||
20 | + -Wno-stringop-overflow \ | ||
21 | + -Wno-array-bounds \ | ||
22 | -Wno-missing-field-initializers -Wno-format-zero-length | ||
23 | endif | ||
24 | |||
25 | diff --git a/host/xtest/adbg/src/adbg_run.c b/host/xtest/adbg/src/adbg_run.c | ||
26 | index 406e429..3b57bbb 100644 | ||
27 | --- a/host/xtest/adbg/src/adbg_run.c | ||
28 | +++ b/host/xtest/adbg/src/adbg_run.c | ||
29 | @@ -100,7 +100,7 @@ int Do_ADBG_AppendToSuite( | ||
30 | snprintf(p, size, "%s+%s", Dest_p->SuiteID_p, | ||
31 | Source_p->SuiteID_p); | ||
32 | else | ||
33 | - strncpy(p, Source_p->SuiteID_p, size); | ||
34 | + memcpy(p, Source_p->SuiteID_p, size); | ||
35 | free((void *)Dest_p->SuiteID_p); | ||
36 | Dest_p->SuiteID_p = p; | ||
37 | |||
38 | -- | ||
39 | 1.8.3.1 | ||
40 | |||
diff --git a/recipes-security/optee/optee-test-qoriq_git.bb b/recipes-security/optee/optee-test-qoriq_git.bb index 880bd6f6..06b8f642 100644 --- a/recipes-security/optee/optee-test-qoriq_git.bb +++ b/recipes-security/optee/optee-test-qoriq_git.bb | |||
@@ -9,7 +9,8 @@ DEPENDS = "optee-client-qoriq optee-os-qoriq python-pycrypto-native" | |||
9 | inherit pythonnative | 9 | inherit pythonnative |
10 | 10 | ||
11 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/optee_test;nobranch=1 \ | 11 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/optee_test;nobranch=1 \ |
12 | " | 12 | file://0001-fix-build-failure-with-GCC-8.patch \ |
13 | " | ||
13 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
14 | 15 | ||
15 | SRCREV = "a54952babb83d801148867bd639a24ff6cd36f00" | 16 | SRCREV = "a54952babb83d801148867bd639a24ff6cd36f00" |
@@ -20,7 +21,7 @@ TA_DEV_KIT_DIR = "${STAGING_INCDIR}/optee/export-user_ta" | |||
20 | 21 | ||
21 | EXTRA_OEMAKE = " TA_DEV_KIT_DIR=${TA_DEV_KIT_DIR} \ | 22 | EXTRA_OEMAKE = " TA_DEV_KIT_DIR=${TA_DEV_KIT_DIR} \ |
22 | OPTEE_CLIENT_EXPORT=${OPTEE_CLIENT_EXPORT} \ | 23 | OPTEE_CLIENT_EXPORT=${OPTEE_CLIENT_EXPORT} \ |
23 | TEEC_EXPORT=${TEEC_EXPORT} \ | 24 | CFG_ARM64=y \ |
24 | CROSS_COMPILE_HOST=${TARGET_PREFIX} \ | 25 | CROSS_COMPILE_HOST=${TARGET_PREFIX} \ |
25 | CROSS_COMPILE_TA=${TARGET_PREFIX} \ | 26 | CROSS_COMPILE_TA=${TARGET_PREFIX} \ |
26 | V=1 \ | 27 | V=1 \ |