summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.4.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.4.bb b/recipes-bsp/imx-atf/imx-atf_2.4.bb
index afb31698..eedcdc54 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.4.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.4.bb
@@ -43,9 +43,9 @@ def remove_options_tail (in_string):
43 from itertools import takewhile 43 from itertools import takewhile
44 return ' '.join(takewhile(lambda x: not x.startswith('-'), in_string.split(' '))) 44 return ' '.join(takewhile(lambda x: not x.startswith('-'), in_string.split(' ')))
45 45
46EXTRA_OEMAKE += "LD=${@remove_options_tail(d.getVar('LD'))}" 46EXTRA_OEMAKE += 'LD="${@remove_options_tail(d.getVar('LD'))}"'
47 47
48EXTRA_OEMAKE += "CC=${@remove_options_tail(d.getVar('CC'))}" 48EXTRA_OEMAKE += 'CC="${@remove_options_tail(d.getVar('CC'))}"'
49 49
50do_compile() { 50do_compile() {
51 # Clear LDFLAGS to avoid the option -Wl recognize issue 51 # Clear LDFLAGS to avoid the option -Wl recognize issue