diff options
-rw-r--r-- | recipes-bsp/ls2-phy/ls2-phy_git.bb | 27 |
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-bsp/ls2-phy/ls2-phy_git.bb b/recipes-bsp/ls2-phy/ls2-phy_git.bb new file mode 100644 index 00000000..422a922e --- /dev/null +++ b/recipes-bsp/ls2-phy/ls2-phy_git.bb | |||
@@ -0,0 +1,27 @@ | |||
1 | SUMMARY = "Firmwares and Standalone Applications" | ||
2 | LICENSE = "Freescale-EULA" | ||
3 | LIC_FILES_CHKSUM = "file://EULA;md5=c9ae442cf1f9dd6c13dfad64b0ffe73f" | ||
4 | |||
5 | inherit deploy | ||
6 | |||
7 | SRC_URI = "git://git.freescale.com/ppc/sdk/ls2-phy.git;branch=sdk-v2.0.x" | ||
8 | SRCREV = "554f2648c6a4c6f974827ab326e8c1908dead6f1" | ||
9 | |||
10 | S = "${WORKDIR}/git" | ||
11 | |||
12 | do_install () { | ||
13 | install -d ${D}/boot | ||
14 | cp -fr ${S}/AQR405 ${D}/boot | ||
15 | cp -fr ${S}/CS4340 ${D}/boot | ||
16 | } | ||
17 | |||
18 | do_deploy () { | ||
19 | install -d ${DEPLOYDIR}/ls2-phy | ||
20 | cp -fr ${S}/AQR405 ${DEPLOYDIR}/ls2-phy | ||
21 | cp -fr ${S}/CS4340 ${DEPLOYDIR}/ls2-phy | ||
22 | } | ||
23 | addtask deploy before do_build after do_install | ||
24 | |||
25 | PACKAGES += "${PN}-image" | ||
26 | FILES_${PN}-image += "/boot" | ||
27 | COMPATIBLE_MACHINE = "(ls2080ardb)" | ||