summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/rcw/rcw-bin_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-bsp/rcw/rcw-bin_git.bb b/recipes-bsp/rcw/rcw-bin_git.bb
new file mode 100644
index 00000000..bdb075f3
--- /dev/null
+++ b/recipes-bsp/rcw/rcw-bin_git.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Reset Configuration Word"
2DESCRIPTION = "Reset Configuration Word - hardware boot-time parameters for the QorIQ targets"
3LICENSE = "NXP-Binary-EULA"
4LIC_FILES_CHKSUM = "file://NXP-Binary-EULA;md5=ba5ff3a3faf52a38970d0a536ef42df5"
5
6inherit deploy siteinfo
7
8SRC_URI = "git://github.com/qoriq-open-source/rcw-bin.git;nobranch=1"
9SRCREV = "bf3ae3cb15829876007c553509501cdaa16745e7"
10
11S = "${WORKDIR}/git"
12
13M="${@d.getVar('MACHINE', True).replace('-64b','').replace('-32b','').replace('-${SITEINFO_ENDIANNESS}','')}"
14
15do_install () {
16 install -d ${D}/boot/rcw
17 cp -rf ${S}/${M}* ${D}/boot/rcw/
18 chown -R root:root ${D}
19}
20
21do_deploy () {
22 install -d ${DEPLOYDIR}/rcw
23 cp -rf ${S}/${M}* ${DEPLOYDIR}/rcw/
24}
25addtask deploy before do_build after do_install
26
27PACKAGES += "${PN}-image"
28FILES_${PN}-image += "/boot"
29
30COMPATIBLE_MACHINE = "(qoriq)"
31PACKAGE_ARCH = "${MACHINE_ARCH}"
32COMPATIBLE_MACHINE = "(ls1012a|ls2088a|ls1088a)"