summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/uuu_bootloader_tag.bbclass5
-rw-r--r--conf/layer.conf6
-rw-r--r--conf/machine/include/imx-base.inc2
-rw-r--r--recipes-bsp/imx-mkimage/imx-boot_1.0.bb1
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2023.04.bb15
5 files changed, 20 insertions, 9 deletions
diff --git a/classes/uuu_bootloader_tag.bbclass b/classes/uuu_bootloader_tag.bbclass
index fb6acd72..87745660 100644
--- a/classes/uuu_bootloader_tag.bbclass
+++ b/classes/uuu_bootloader_tag.bbclass
@@ -4,8 +4,9 @@
4do_deploy:append() { 4do_deploy:append() {
5 if [ "${UUU_BOOTLOADER}" != "" ]; then 5 if [ "${UUU_BOOTLOADER}" != "" ]; then
6 cp ${DEPLOYDIR}/${UUU_BOOTLOADER} ${DEPLOYDIR}/${UUU_BOOTLOADER_TAGGED} 6 cp ${DEPLOYDIR}/${UUU_BOOTLOADER} ${DEPLOYDIR}/${UUU_BOOTLOADER_TAGGED}
7 cp ${DEPLOYDIR}/${UUU_BOOTLOADER} ${DEPLOYDIR}/${UUU_BOOTLOADER_UNTAGGED}
7 ln -sf ${UUU_BOOTLOADER_TAGGED} ${DEPLOYDIR}/${UUU_BOOTLOADER} 8 ln -sf ${UUU_BOOTLOADER_TAGGED} ${DEPLOYDIR}/${UUU_BOOTLOADER}
8 stat -L -cUUUBURNXXOEUZX7+A-XY5601QQWWZ%sEND ${DEPLOYDIR}/${UUU_BOOTLOADER} \ 9 stat -L -cUUUBURNXXOEUZX7+A-XY5601QQWWZ%sEND ${DEPLOYDIR}/${UUU_BOOTLOADER_TAGGED} \
9 >> ${DEPLOYDIR}/${UUU_BOOTLOADER} 10 >> ${DEPLOYDIR}/${UUU_BOOTLOADER_TAGGED}
10 fi 11 fi
11} 12}
diff --git a/conf/layer.conf b/conf/layer.conf
index 49a94d61..ef4e3e6e 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -28,6 +28,12 @@ ${IMX_MIRROR} http://download.ossystems.com.br/bsp/freescale/source/ \n \
28# implemented in imx GL driver implementation 28# implemented in imx GL driver implementation
29COMPATIBLE_HOST:pn-xdg-desktop-portal-wlr:imxgpu = "(null)" 29COMPATIBLE_HOST:pn-xdg-desktop-portal-wlr:imxgpu = "(null)"
30 30
31# For compatibility with layers before scarthgap
32PROVIDES:pn-bmap-tools-native = "bmaptool-native"
33RPROVIDES:pn-bmap-tools-native:bmap-tools-native = "bmaptool-native"
34PROVIDES:pn-bmap-tools = "bmaptool"
35RPROVIDES:pn-bmap-tools:bmap-tools = "bmaptool"
36
31BBFILES_DYNAMIC += " \ 37BBFILES_DYNAMIC += " \
32 aglprofilegraphical:${LAYERDIR}/dynamic-layers/aglprofilegraphical/*/*/*.bb \ 38 aglprofilegraphical:${LAYERDIR}/dynamic-layers/aglprofilegraphical/*/*/*.bb \
33 aglprofilegraphical:${LAYERDIR}/dynamic-layers/aglprofilegraphical/*/*/*.bbappend \ 39 aglprofilegraphical:${LAYERDIR}/dynamic-layers/aglprofilegraphical/*/*/*.bbappend \
diff --git a/conf/machine/include/imx-base.inc b/conf/machine/include/imx-base.inc
index f436b59e..7f4ae4d7 100644
--- a/conf/machine/include/imx-base.inc
+++ b/conf/machine/include/imx-base.inc
@@ -637,7 +637,7 @@ WKS_FILE_DEPENDS ?= " \
637 virtual/bootloader \ 637 virtual/bootloader \
638 \ 638 \
639 e2fsprogs-native \ 639 e2fsprogs-native \
640 bmap-tools-native \ 640 bmaptool-native \
641 ${@bb.utils.contains('MACHINE_FEATURES', 'optee', '${OPTEE_WKS_FILE_DEPENDS}', '', d)} \ 641 ${@bb.utils.contains('MACHINE_FEATURES', 'optee', '${OPTEE_WKS_FILE_DEPENDS}', '', d)} \
642" 642"
643 643
diff --git a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
index d5aef3c6..a761870b 100644
--- a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
+++ b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
@@ -25,6 +25,7 @@ inherit deploy uuu_bootloader_tag
25 25
26UUU_BOOTLOADER = "${BOOT_NAME}" 26UUU_BOOTLOADER = "${BOOT_NAME}"
27UUU_BOOTLOADER_TAGGED = "${BOOT_NAME}-tagged" 27UUU_BOOTLOADER_TAGGED = "${BOOT_NAME}-tagged"
28UUU_BOOTLOADER_UNTAGGED = "${BOOT_NAME}-untagged"
28 29
29# Add CFLAGS with native INCDIR & LIBDIR for imx-mkimage build 30# Add CFLAGS with native INCDIR & LIBDIR for imx-mkimage build
30CFLAGS = "-O2 -Wall -std=c99 -I ${STAGING_INCDIR_NATIVE} -L ${STAGING_LIBDIR_NATIVE}" 31CFLAGS = "-O2 -Wall -std=c99 -I ${STAGING_INCDIR_NATIVE} -L ${STAGING_LIBDIR_NATIVE}"
diff --git a/recipes-bsp/u-boot/u-boot-imx_2023.04.bb b/recipes-bsp/u-boot/u-boot-imx_2023.04.bb
index f0ebdc5f..0e7c467b 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2023.04.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2023.04.bb
@@ -9,12 +9,15 @@ PROVIDES += "u-boot u-boot-mfgtool"
9 9
10inherit uuu_bootloader_tag 10inherit uuu_bootloader_tag
11 11
12UUU_BOOTLOADER = "" 12UUU_BOOTLOADER = ""
13UUU_BOOTLOADER:mx6-generic-bsp = "${UBOOT_BINARY}" 13UUU_BOOTLOADER:mx6-generic-bsp = "${UBOOT_BINARY}"
14UUU_BOOTLOADER:mx7-generic-bsp = "${UBOOT_BINARY}" 14UUU_BOOTLOADER:mx7-generic-bsp = "${UBOOT_BINARY}"
15UUU_BOOTLOADER_TAGGED = "" 15UUU_BOOTLOADER_TAGGED = ""
16UUU_BOOTLOADER_TAGGED:mx6-generic-bsp = "u-boot-tagged.${UBOOT_SUFFIX}" 16UUU_BOOTLOADER_TAGGED:mx6-generic-bsp = "u-boot-tagged.${UBOOT_SUFFIX}"
17UUU_BOOTLOADER_TAGGED:mx7-generic-bsp = "u-boot-tagged.${UBOOT_SUFFIX}" 17UUU_BOOTLOADER_TAGGED:mx7-generic-bsp = "u-boot-tagged.${UBOOT_SUFFIX}"
18UUU_BOOTLOADER_UNTAGGED = ""
19UUU_BOOTLOADER_UNTAGGED:mx6-generic-bsp = "u-boot-untagged.${UBOOT_SUFFIX}"
20UUU_BOOTLOADER_UNTAGGED:mx7-generic-bsp = "u-boot-untagged.${UBOOT_SUFFIX}"
18 21
19do_deploy:append:mx8m-generic-bsp() { 22do_deploy:append:mx8m-generic-bsp() {
20 # Deploy u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary 23 # Deploy u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary