diff options
-rw-r--r-- | conf/machine/imx8mm-ddr4-evk.conf | 6 | ||||
-rw-r--r-- | conf/machine/imx8mm-lpddr4-evk.conf | 5 | ||||
-rw-r--r-- | conf/machine/include/imx8mm-evk.inc | 3 | ||||
-rw-r--r-- | recipes-bsp/imx-atf/imx-atf_2.6.bb (renamed from recipes-bsp/imx-atf/imx-atf_2.4.bb) | 4 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc-common_2022.07.inc (renamed from recipes-bsp/u-boot/u-boot-fslc-common_2022.04.inc) | 10 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc-mfgtool_2022.07.bb (renamed from recipes-bsp/u-boot/u-boot-fslc-mfgtool_2022.04.bb) | 0 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc-mxsboot_2022.07.bb (renamed from recipes-bsp/u-boot/u-boot-fslc-mxsboot_2022.04.bb) | 0 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc_2022.07.bb (renamed from recipes-bsp/u-boot/u-boot-fslc_2022.04.bb) | 0 |
8 files changed, 9 insertions, 19 deletions
diff --git a/conf/machine/imx8mm-ddr4-evk.conf b/conf/machine/imx8mm-ddr4-evk.conf index 431485e7..bbfef2c2 100644 --- a/conf/machine/imx8mm-ddr4-evk.conf +++ b/conf/machine/imx8mm-ddr4-evk.conf | |||
@@ -24,7 +24,5 @@ DDR_FIRMWARE_NAME = " \ | |||
24 | 24 | ||
25 | IMXBOOT_TARGETS_BASENAME = "flash_ddr4_evk" | 25 | IMXBOOT_TARGETS_BASENAME = "flash_ddr4_evk" |
26 | 26 | ||
27 | # Mainline BSP doesn't support DDR4 so it must be set to nxp. | 27 | # Mainline U-Boot doesn't support DDR4 so it must be set to u-boot-imx. |
28 | # Also this machine isn't supported by u-boot-fslc but imx8mm-evk.inc already | 28 | IMX_DEFAULT_BOOTLOADER = "u-boot-imx" |
29 | # set the bootloader to u-boot-imx instead when NXP BSP is used. | ||
30 | IMX_DEFAULT_BSP = "nxp" | ||
diff --git a/conf/machine/imx8mm-lpddr4-evk.conf b/conf/machine/imx8mm-lpddr4-evk.conf index 0c886cb1..0a85ed20 100644 --- a/conf/machine/imx8mm-lpddr4-evk.conf +++ b/conf/machine/imx8mm-lpddr4-evk.conf | |||
@@ -34,8 +34,3 @@ DDR_FIRMWARE_NAME = " \ | |||
34 | " | 34 | " |
35 | 35 | ||
36 | IMXBOOT_TARGETS_BASENAME = "flash_evk" | 36 | IMXBOOT_TARGETS_BASENAME = "flash_evk" |
37 | |||
38 | # Mainline BSP doesn't support LPDDR4 so it must be set to nxp. | ||
39 | # Also this machine isn't supported by u-boot-fslc but imx8mn-evk.inc already | ||
40 | # set the bootloader to u-boot-imx instead when NXP BSP is used. | ||
41 | IMX_DEFAULT_BSP = "nxp" | ||
diff --git a/conf/machine/include/imx8mm-evk.inc b/conf/machine/include/imx8mm-evk.inc index eba4ac9f..41f7bad4 100644 --- a/conf/machine/include/imx8mm-evk.inc +++ b/conf/machine/include/imx8mm-evk.inc | |||
@@ -27,9 +27,6 @@ KERNEL_DEVICETREE:append:use-nxp-bsp = " \ | |||
27 | " | 27 | " |
28 | UBOOT_DTB_NAME = "${KERNEL_DEVICETREE_BASENAME}.dtb" | 28 | UBOOT_DTB_NAME = "${KERNEL_DEVICETREE_BASENAME}.dtb" |
29 | 29 | ||
30 | IMX_DEFAULT_BOOTLOADER:use-nxp-bsp = "u-boot-imx" | ||
31 | IMX_DEFAULT_BOOTLOADER:use-mainline-bsp = "u-boot-fslc" | ||
32 | |||
33 | UBOOT_SUFFIX = "bin" | 30 | UBOOT_SUFFIX = "bin" |
34 | 31 | ||
35 | UBOOT_CONFIG ??= "sd" | 32 | UBOOT_CONFIG ??= "sd" |
diff --git a/recipes-bsp/imx-atf/imx-atf_2.4.bb b/recipes-bsp/imx-atf/imx-atf_2.6.bb index a8068eb0..b0cd4d3d 100644 --- a/recipes-bsp/imx-atf/imx-atf_2.4.bb +++ b/recipes-bsp/imx-atf/imx-atf_2.6.bb | |||
@@ -9,10 +9,10 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" | |||
9 | 9 | ||
10 | PV .= "+git${SRCPV}" | 10 | PV .= "+git${SRCPV}" |
11 | 11 | ||
12 | SRCBRANCH = "lf_v2.4" | 12 | SRCBRANCH = "lf_v2.6" |
13 | SRC_URI = "git://source.codeaurora.org/external/imx/imx-atf.git;protocol=https;branch=${SRCBRANCH} \ | 13 | SRC_URI = "git://source.codeaurora.org/external/imx/imx-atf.git;protocol=https;branch=${SRCBRANCH} \ |
14 | file://0001-Makefile-Suppress-array-bounds-error.patch" | 14 | file://0001-Makefile-Suppress-array-bounds-error.patch" |
15 | SRCREV = "05f788b9bbb13d002997e35008a4b945f7e2957b" | 15 | SRCREV = "c6a19b1a351308cc73443283f6aa56b2eff791b8" |
16 | 16 | ||
17 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
18 | 18 | ||
diff --git a/recipes-bsp/u-boot/u-boot-fslc-common_2022.04.inc b/recipes-bsp/u-boot/u-boot-fslc-common_2022.07.inc index 0fad0367..2d1cb54d 100644 --- a/recipes-bsp/u-boot/u-boot-fslc-common_2022.04.inc +++ b/recipes-bsp/u-boot/u-boot-fslc-common_2022.07.inc | |||
@@ -1,19 +1,19 @@ | |||
1 | # Copyright (C) 2012-2019 O.S. Systems Software LTDA. | 1 | # Copyright (C) 2012-2022 O.S. Systems Software LTDA. |
2 | # Released under the MIT license (see COPYING.MIT for the terms) | 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
3 | 3 | ||
4 | inherit fsl-u-boot-localversion | 4 | inherit fsl-u-boot-localversion |
5 | 5 | ||
6 | LICENSE = "GPL-2.0-or-later" | 6 | LICENSE = "GPL-2.0-or-later" |
7 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=5a7450c57ffe5ae63fd732446b988025" | 7 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=2ca5f2c35c8cc335f0a19756634782f1" |
8 | 8 | ||
9 | DEPENDS += "flex-native bison-native" | 9 | DEPENDS += "flex-native bison-native" |
10 | 10 | ||
11 | SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH};protocol=https" | 11 | SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH};protocol=https" |
12 | 12 | ||
13 | SRCREV = "f88519827335b548fcd276acda32107f5120276f" | 13 | SRCREV = "a21d7668eb36d2930d8fa0b933121f7b0f2c0ad5" |
14 | SRCBRANCH = "2022.04+fslc" | 14 | SRCBRANCH = "2022.07+fslc" |
15 | 15 | ||
16 | PV = "v2022.04+git${SRCPV}" | 16 | PV = "2022.07+git${SRCPV}" |
17 | 17 | ||
18 | S = "${WORKDIR}/git" | 18 | S = "${WORKDIR}/git" |
19 | B = "${WORKDIR}/build" | 19 | B = "${WORKDIR}/build" |
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mfgtool_2022.04.bb b/recipes-bsp/u-boot/u-boot-fslc-mfgtool_2022.07.bb index 2e79166b..2e79166b 100644 --- a/recipes-bsp/u-boot/u-boot-fslc-mfgtool_2022.04.bb +++ b/recipes-bsp/u-boot/u-boot-fslc-mfgtool_2022.07.bb | |||
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2022.04.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2022.07.bb index 2660df9e..2660df9e 100644 --- a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2022.04.bb +++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2022.07.bb | |||
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2022.04.bb b/recipes-bsp/u-boot/u-boot-fslc_2022.07.bb index de6d22d0..de6d22d0 100644 --- a/recipes-bsp/u-boot/u-boot-fslc_2022.04.bb +++ b/recipes-bsp/u-boot/u-boot-fslc_2022.07.bb | |||