summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-dpaa2/aiopsl/aiopsl_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-dpaa2/aiopsl/aiopsl_git.bb b/recipes-dpaa2/aiopsl/aiopsl_git.bb
new file mode 100644
index 00000000..23a5e9dc
--- /dev/null
+++ b/recipes-dpaa2/aiopsl/aiopsl_git.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "DPAA2 Accelerated I/O Processing service layer"
2SECTION = "dpaa2"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=faf479bdc4702d8033049f97e153f876"
5
6BASEDEPENDS = ""
7
8S = "${WORKDIR}/git"
9
10SRC_URI = "git://git.freescale.com/ppc/sdk/aiopsl.git;nobranch=1"
11SRCREV = "80f3d450896d17a3d8e10f3c6d1c224e78d32757"
12
13do_configure[noexec] = "1"
14do_compile[noexec] = "1"
15
16do_install () {
17 install -d ${D}/usr/aiop/bin
18 install -d ${D}/usr/aiop/scripts
19 install -d ${D}/usr/aiop/traffic_files
20 install -m 755 ${S}/demos/images/LS2088A/*.elf ${D}/usr/aiop/bin
21 install -m 755 ${S}/misc/setup/scripts/dynamic_aiop_*.sh ${D}/usr/aiop/scripts
22 install -m 644 ${S}/misc/setup/traffic_files/classifier.pcap ${D}/usr/aiop/traffic_files
23}
24
25FILES_${PN} += "/usr/aiop/*"
26INSANE_SKIP_${PN} += "arch"
27INHIBIT_PACKAGE_STRIP = "1"
28INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
29COMPATIBLE_MACHINE = "(ls2088a)"