summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb b/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb
new file mode 100644
index 00000000..f3004194
--- /dev/null
+++ b/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb
@@ -0,0 +1,23 @@
1SUMMARY = "PPFE Linux firmware"
2LICENSE = "Freescale-Binary-EULA"
3LIC_FILES_CHKSUM = "file://Freescale-Binary-EULA;md5=f1c407c0fccab5cd0bf9b92565f6f19b"
4
5INHIBIT_DEFAULT_DEPS = "1"
6
7SRC_URI = "git://git.freescale.com/ppc/sdk/engine-pfe-bin.git;nobranch=1"
8SRCREV = "5d984557d9b542bdd8bd469537126c05dd167dcc"
9
10S = "${WORKDIR}/git"
11
12do_install () {
13 install -d ${D}/lib/firmware
14 install -m 644 ${S}/Freescale-Binary-EULA ${D}/lib/firmware
15 install -m 755 ${S}/ls1012a/slow_path/*.elf ${D}/lib/firmware
16}
17
18FILES_${PN} += "/lib/firmware"
19INSANE_SKIP_${PN} += "arch already-stripped"
20INHIBIT_PACKAGE_STRIP = "1"
21INHIBIT_SYSROOT_STRIP = "1"
22
23COMPATIBLE_MACHINE = "(ls1012a)"