summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-dpaa2/gpp-aioptool/gpp-aioptool_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-dpaa2/gpp-aioptool/gpp-aioptool_git.bb b/recipes-dpaa2/gpp-aioptool/gpp-aioptool_git.bb
new file mode 100644
index 00000000..a24604df
--- /dev/null
+++ b/recipes-dpaa2/gpp-aioptool/gpp-aioptool_git.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "AIOP Tool is a userspace application for performing operations \
2on an AIOP Tile using MC interfaces. This application enables the user to \
3fetch status of tile, load a valid ELF file and run it on a tile and get and set \
4time of day."
5SECTION = "dpaa2"
6LICENSE = "Freescale-EULA"
7LIC_FILES_CHKSUM = "file://Freescale-EULA;md5=395c11b7d81446eaa8f997521afe0ebb"
8
9SRC_URI = "git://git.freescale.com/ppc/sdk/gpp-aioptool.git;nobranch=1 \
10"
11SRCREV = "d2b674e0a084429c89994dc8b39827592917a7a6"
12
13S = "${WORKDIR}/git"
14
15TARGET_CC_ARCH += "${LDFLAGS}"
16
17EXTRA_OEMAKE = 'KERNEL_PATH="${STAGING_KERNEL_DIR}"'
18
19do_configure[depends] += "virtual/kernel:do_shared_workdir"
20
21do_install () {
22 oe_runmake install DESTDIR=${D}
23}
24
25COMPATIBLE_MACHINE = "(ls2088a)"