summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend19
1 files changed, 7 insertions, 12 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 8f5aa751..3005fd73 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -1,15 +1,12 @@
1PACKAGECONFIG_remove_mx6 = "egl gles" 1PACKAGECONFIG_remove_imxgpu2d = "egl gles"
2 2
3PROVIDES_remove_mx6 = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl" 3PROVIDES_remove_imxgpu2d = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl"
4PROVIDES_remove_imxgpu3d = "virtual/libgl" 4PROVIDES_remove_imxgpu3d = "virtual/libgl"
5 5
6USE_VIV_LIBGL = "yes"
7USE_VIV_LIBGL_mx6sl = "no"
8
9# FIXME: mesa should support 'x11-no-tls' option 6# FIXME: mesa should support 'x11-no-tls' option
10python () { 7python () {
11 overrides = d.getVar("OVERRIDES", True).split(":") 8 overrides = d.getVar("OVERRIDES", True).split(":")
12 if "mx6" not in overrides: 9 if "imxgpu2d" not in overrides:
13 return 10 return
14 11
15 extra_oeconf = d.getVar("EXTRA_OECONF", True) 12 extra_oeconf = d.getVar("EXTRA_OECONF", True)
@@ -18,10 +15,8 @@ python () {
18} 15}
19 16
20# FIXME: Dirty hack to allow use of Vivante GPU libGL binary 17# FIXME: Dirty hack to allow use of Vivante GPU libGL binary
21do_install_append_mx6 () { 18do_install_append_imxgpu3d () {
22 if [ "${USE_VIV_LIBGL}" = "yes" ]; then 19 rm -f ${D}${libdir}/libGL.* \
23 rm -f ${D}${libdir}/libGL.* \ 20 ${D}${includedir}/GL/gl.h \
24 ${D}${includedir}/GL/gl.h \ 21 ${D}${includedir}/GL/glext.h
25 ${D}${includedir}/GL/glext.h
26 fi
27} 22}