summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-multimedia/imx-codec/imx-codec.inc (renamed from recipes-multimedia/libfslcodec/libfslcodec.inc)27
-rw-r--r--recipes-multimedia/imx-codec/imx-codec_4.0.9.bb9
-rw-r--r--recipes-multimedia/libfslcodec/libfslcodec_4.0.8.bb9
3 files changed, 28 insertions, 17 deletions
diff --git a/recipes-multimedia/libfslcodec/libfslcodec.inc b/recipes-multimedia/imx-codec/imx-codec.inc
index 2f0bc445..e6fd9c6f 100644
--- a/recipes-multimedia/libfslcodec/libfslcodec.inc
+++ b/recipes-multimedia/imx-codec/imx-codec.inc
@@ -1,9 +1,9 @@
1# Copyright (C) 2012-2014 Freescale Semiconductor 1# Copyright (C) 2012-2016 Freescale Semiconductor
2# Released under the MIT license (see COPYING.MIT for the terms) 2# Released under the MIT license (see COPYING.MIT for the terms)
3DESCRIPTION = "Freescale Multimedia codec libs" 3DESCRIPTION = "Freescale Multimedia codec libs"
4LICENSE = "Proprietary" 4LICENSE = "Proprietary"
5SECTION = "multimedia" 5SECTION = "multimedia"
6LIC_FILES_CHKSUM = "file://COPYING;md5=3880bb9c943b135a30fad5e8aabd3ee9" 6LIC_FILES_CHKSUM = "file://COPYING;md5=8cf95184c220e247b9917e7244124c5a"
7 7
8inherit fsl-eula-unpack autotools pkgconfig 8inherit fsl-eula-unpack autotools pkgconfig
9 9
@@ -19,8 +19,8 @@ PACKAGECONFIG_mx6dl = "vpu"
19PACKAGECONFIG[vpu] = "--enable-vpu,--disable-vpu,imx-vpu" 19PACKAGECONFIG[vpu] = "--enable-vpu,--disable-vpu,imx-vpu"
20 20
21do_install_append() { 21do_install_append() {
22 # FIXME: This link points to nowhere 22 # FIXME: This link points to nowhere
23 rm ${D}${libdir}/imx-mm/audio-codec/lib_src_ppp_arm11_elinux.so 23 rm ${D}${libdir}/imx-mm/audio-codec/lib_src_ppp_arm11_elinux.so
24 24
25 # LTIB move the files around or gst-fsl-plugin won't find them 25 # LTIB move the files around or gst-fsl-plugin won't find them
26 for p in $(find ${D}${libdir}/imx-mm -mindepth 2 -maxdepth 2 -not -type d); do 26 for p in $(find ${D}${libdir}/imx-mm -mindepth 2 -maxdepth 2 -not -type d); do
@@ -41,7 +41,7 @@ python __set_insane_skip() {
41 41
42 # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have 42 # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have
43 # the source we cannot fix it. Disable the insane check for now. 43 # the source we cannot fix it. Disable the insane check for now.
44 if p == 'libfslcodec-test-bin': 44 if p == 'imx-codec-test-bin':
45 # FIXME: includes the DUT .so files so we need to deploy those 45 # FIXME: includes the DUT .so files so we need to deploy those
46 d.setVar("INSANE_SKIP_%s" % p, "ldflags textrel libdir") 46 d.setVar("INSANE_SKIP_%s" % p, "ldflags textrel libdir")
47 else: 47 else:
@@ -54,18 +54,29 @@ python __split_libfslcodec_plugins() {
54 codecdir = bb.data.expand('${libdir}', d) 54 codecdir = bb.data.expand('${libdir}', d)
55 do_split_packages(d, codecdir, '^lib_([^_]*).*_arm.*_elinux\.so\..*', 55 do_split_packages(d, codecdir, '^lib_([^_]*).*_arm.*_elinux\.so\..*',
56 aux_files_pattern='${libdir}/imx-mm/audio-codec/wrap/lib_%sd_wrap_arm*_elinux.so.*', 56 aux_files_pattern='${libdir}/imx-mm/audio-codec/wrap/lib_%sd_wrap_arm*_elinux.so.*',
57 output_pattern='libfslcodec-%s', 57 output_pattern='imx-codec-%s',
58 description='Freescale i.MX Codec (%s)', 58 description='Freescale i.MX Codec (%s)',
59 extra_depends='') 59 extra_depends='')
60 pkgs = d.getVar('PACKAGES', True).split()
61 for pkg in pkgs:
62 meta = pkg[10:]
63 if meta != '':
64 d.setVar('RREPLACES_%s' % pkg, ' libfslcodec-%s' % meta)
65 d.setVar('RPROVIDES_%s' % pkg, ' libfslcodec-%s' % meta)
66 d.setVar('RCONFLICTS_%s' % pkg, ' libfslcodec-%s' % meta)
67 else :
68 d.setVar('RREPLACES_%s' % pkg, ' libfslcodec')
69 d.setVar('RPROVIDES_%s' % pkg, ' libfslcodec')
70 d.setVar('RCONFLICTS_%s' % pkg, ' libfslcodec')
60} 71}
61 72
62python __set_metapkg_rdepends() { 73python __set_metapkg_rdepends() {
63 # Allow addition of all codecs in a image; useful specially for 74 # Allow addition of all codecs in a image; useful specially for
64 # debugging. 75 # debugging.
65 codec_pkgs = oe.utils.packages_filter_out_system(d) 76 codec_pkgs = oe.utils.packages_filter_out_system(d)
66 codec_pkgs = filter(lambda x: x not in ['libfslcodec-test-bin', 'libfslcodec-test-source'], 77 codec_pkgs = filter(lambda x: x not in ['imx-codec-test-bin', 'imx-codec-test-source'],
67 codec_pkgs) 78 codec_pkgs)
68 d.appendVar('RDEPENDS_libfslcodec-meta', ' ' + ' '.join(codec_pkgs)) 79 d.appendVar('RDEPENDS_imx-codec-meta', ' ' + ' '.join(codec_pkgs))
69} 80}
70 81
71PACKAGESPLITFUNCS =+ "__split_libfslcodec_plugins __set_metapkg_rdepends" 82PACKAGESPLITFUNCS =+ "__split_libfslcodec_plugins __set_metapkg_rdepends"
diff --git a/recipes-multimedia/imx-codec/imx-codec_4.0.9.bb b/recipes-multimedia/imx-codec/imx-codec_4.0.9.bb
new file mode 100644
index 00000000..3fb9802d
--- /dev/null
+++ b/recipes-multimedia/imx-codec/imx-codec_4.0.9.bb
@@ -0,0 +1,9 @@
1# Copyright (C) 2013-2016 Freescale Semiconductor
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4require imx-codec.inc
5
6SRC_URI[md5sum] = "bcf54698af6f52958b36e34dcbd9fcd1"
7SRC_URI[sha256sum] = "62bda182143cde9743cba0eb2a1c315a53cb434294605742f9fc364219958888"
8
9COMPATIBLE_MACHINE = "(mx6|mx6ul|mx7)"
diff --git a/recipes-multimedia/libfslcodec/libfslcodec_4.0.8.bb b/recipes-multimedia/libfslcodec/libfslcodec_4.0.8.bb
deleted file mode 100644
index 1b32f907..00000000
--- a/recipes-multimedia/libfslcodec/libfslcodec_4.0.8.bb
+++ /dev/null
@@ -1,9 +0,0 @@
1# Copyright (C) 2013-2015 Freescale Semiconductor
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4require libfslcodec.inc
5
6SRC_URI[md5sum] = "462fb27b20cd7df56a49b9e7d6b7c8b4"
7SRC_URI[sha256sum] = "544ffc5989bce18ca50c7a826cc03370b1cf8455335e4291ef0c0779b4c33de0"
8
9COMPATIBLE_MACHINE = "(mx6|mx6ul|mx7)"