summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/imx-kobs/imx-kobs/fix-compile.patch17
-rw-r--r--recipes-bsp/imx-kobs/imx-kobs_git.bb7
2 files changed, 3 insertions, 21 deletions
diff --git a/recipes-bsp/imx-kobs/imx-kobs/fix-compile.patch b/recipes-bsp/imx-kobs/imx-kobs/fix-compile.patch
deleted file mode 100644
index 2ac73aef..00000000
--- a/recipes-bsp/imx-kobs/imx-kobs/fix-compile.patch
+++ /dev/null
@@ -1,17 +0,0 @@
1This patch fixes a build error with kernel includes (>= 4.4) <stdint.h> must
2be explicitly included to get uintX_t types.
3
4Upstream-Status: Pending
5
6Index: imx-kobs-5.4/src/BootControlBlocks.h
7===================================================================
8--- imx-kobs-5.4.orig/src/BootControlBlocks.h
9+++ imx-kobs-5.4/src/BootControlBlocks.h
10@@ -54,6 +54,7 @@
11 //! This structure holds the timing for the NAND. This data is used by
12 //! rom_nand_hal_GpmiSetNandTiming to setup the GPMI hardware registers.
13
14+#include <stdint.h>
15 typedef struct _NAND_Timing {
16 uint8_t m_u8DataSetup;
17 uint8_t m_u8DataHold;
diff --git a/recipes-bsp/imx-kobs/imx-kobs_git.bb b/recipes-bsp/imx-kobs/imx-kobs_git.bb
index b228ab51..aab10f9c 100644
--- a/recipes-bsp/imx-kobs/imx-kobs_git.bb
+++ b/recipes-bsp/imx-kobs/imx-kobs_git.bb
@@ -1,4 +1,5 @@
1# Copyright (C) 2013-2016 Freescale Semiconductor 1# Copyright (C) 2013-2016 Freescale Semiconductor
2# Copyright 2017 NXP
2 3
3SUMMARY = "Nand boot write source" 4SUMMARY = "Nand boot write source"
4SECTION = "base" 5SECTION = "base"
@@ -6,11 +7,9 @@ LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833" 7LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
7 8
8PV = "5.5+git${SRCPV}" 9PV = "5.5+git${SRCPV}"
9SRCREV = "b402243a04e5a6760a860445e5ff6a931d86f794" 10SRCREV = "a2734b93759b4222f9dfa3f8c7645be9d39ea601"
10 11
11SRC_URI = "git://github.com/NXPmicro/imx-kobs.git;protocal=https \ 12SRC_URI = "git://github.com/NXPmicro/imx-kobs.git;protocal=https"
12 file://fix-compile.patch \
13"
14 13
15S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
16 15