diff options
3 files changed, 3 insertions, 51 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv/0001-MGS-515-ccc-Opencv-app-can-t-run-on-imx6sx-with-cam.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv/0001-MGS-515-ccc-Opencv-app-can-t-run-on-imx6sx-with-cam.patch deleted file mode 100644 index 274fbe74..00000000 --- a/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv/0001-MGS-515-ccc-Opencv-app-can-t-run-on-imx6sx-with-cam.patch +++ /dev/null | |||
@@ -1,46 +0,0 @@ | |||
1 | From 90f869763026e8ff18aeecde217d778f00e4f294 Mon Sep 17 00:00:00 2001 | ||
2 | From: Shawn Xiao <b49994@freescale.com> | ||
3 | Date: Tue, 10 Feb 2015 16:11:59 +0800 | ||
4 | Subject: [PATCH] MGS-515 [#ccc] Opencv app can't run on imx6sx with cam | ||
5 | |||
6 | This issue is caused by the no support of VIDIOC_QUERYCTRL ioctl | ||
7 | item in latest cam driver. | ||
8 | |||
9 | Modified the errno in check logic to compatible with new driver. | ||
10 | |||
11 | Feb 10, 2015 | ||
12 | |||
13 | Upstream-Status: Pending | ||
14 | |||
15 | Signed-off-by: Shawn Xiao <b49994@freescale.com> | ||
16 | --- | ||
17 | modules/highgui/src/cap_v4l.cpp | 6 ++++-- | ||
18 | 1 file changed, 4 insertions(+), 2 deletions(-) | ||
19 | |||
20 | diff --git a/modules/highgui/src/cap_v4l.cpp b/modules/highgui/src/cap_v4l.cpp | ||
21 | index c9fca05..8c46b6c 100644 | ||
22 | --- a/modules/highgui/src/cap_v4l.cpp | ||
23 | +++ b/modules/highgui/src/cap_v4l.cpp | ||
24 | @@ -707,7 +707,8 @@ static void v4l2_scan_controls(CvCaptureCAM_V4L* capture) | ||
25 | |||
26 | } else { | ||
27 | |||
28 | - if (errno == EINVAL) | ||
29 | + if (errno == ENOTTY || | ||
30 | + errno == EINVAL) | ||
31 | continue; | ||
32 | |||
33 | perror ("VIDIOC_QUERYCTRL"); | ||
34 | @@ -774,7 +775,8 @@ static void v4l2_scan_controls(CvCaptureCAM_V4L* capture) | ||
35 | |||
36 | } else { | ||
37 | |||
38 | - if (errno == EINVAL) | ||
39 | + if (errno == ENOTTY || | ||
40 | + errno == EINVAL) | ||
41 | break; | ||
42 | |||
43 | perror ("VIDIOC_QUERYCTRL"); | ||
44 | -- | ||
45 | 2.3.0 | ||
46 | |||
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv_3.4.%.bbappend b/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv_3.4.%.bbappend deleted file mode 100644 index 3c4c7f5e..00000000 --- a/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv_3.4.%.bbappend +++ /dev/null | |||
@@ -1,5 +0,0 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
2 | |||
3 | SRC_URI_append_mx6sx = " file://0001-MGS-515-ccc-Opencv-app-can-t-run-on-imx6sx-with-cam.patch" | ||
4 | |||
5 | PACKAGECONFIG_remove_imxgpu2d = "v4l" | ||
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv_4.%.bbappend b/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv_4.%.bbappend new file mode 100644 index 00000000..2bae6470 --- /dev/null +++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv_4.%.bbappend | |||
@@ -0,0 +1,3 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
2 | |||
3 | PACKAGECONFIG_remove_imxgpu2d = "v4l" | ||