summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.1.4.bb15
1 files changed, 10 insertions, 5 deletions
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.1.4.bb b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.1.4.bb
index 5b22f466..c34c65b2 100644
--- a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.1.4.bb
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.1.4.bb
@@ -12,7 +12,7 @@ DEPENDS_append_mx6dl = " imx-lib imx-vpu imx-vpuwrap"
12DEPENDS_append_mx6sl = " imx-lib" 12DEPENDS_append_mx6sl = " imx-lib"
13DEPENDS_append_mx6sx = " imx-lib" 13DEPENDS_append_mx6sx = " imx-lib"
14DEPENDS_append_mx6ul = " imx-lib" 14DEPENDS_append_mx6ul = " imx-lib"
15DEPENDS_append_mx7 = " imx-lib" 15DEPENDS_append_mx7d = " imx-lib"
16 16
17# For backwards compatibility 17# For backwards compatibility
18RREPLACES_${PN} = "gst1.0-fsl-plugin" 18RREPLACES_${PN} = "gst1.0-fsl-plugin"
@@ -37,11 +37,13 @@ inherit autotools pkgconfig
37# Make sure kernel sources are available 37# Make sure kernel sources are available
38do_configure[depends] += "virtual/kernel:do_shared_workdir" 38do_configure[depends] += "virtual/kernel:do_shared_workdir"
39 39
40PLATFORM_mx6 = "MX6" 40PLATFORM_mx6dl = "MX6DL"
41PLATFORM_mx6q = "MX6Q"
41PLATFORM_mx6sl = "MX6SL" 42PLATFORM_mx6sl = "MX6SL"
42PLATFORM_mx6sx = "MX6SX" 43PLATFORM_mx6sx = "MX6SX"
43PLATFORM_mx6ul = "MX6UL" 44PLATFORM_mx6ul = "MX6UL"
44PLATFORM_mx7= "MX7D" 45PLATFORM_mx6ull = "MX6ULL"
46PLATFORM_mx7d = "MX7D"
45 47
46# Todo add a mechanism to map possible build targets 48# Todo add a mechanism to map possible build targets
47EXTRA_OECONF = "PLATFORM=${PLATFORM} \ 49EXTRA_OECONF = "PLATFORM=${PLATFORM} \
@@ -56,7 +58,10 @@ BEEP_RDEPENDS = "imx-codec-aac imx-codec-mp3 imx-codec-oggvorbis"
56RDEPENDS_${PN} += "imx-parser ${BEEP_RDEPENDS} gstreamer1.0-plugins-good-id3demux " 58RDEPENDS_${PN} += "imx-parser ${BEEP_RDEPENDS} gstreamer1.0-plugins-good-id3demux "
57 59
58PACKAGECONFIG ?= "" 60PACKAGECONFIG ?= ""
59PACKAGECONFIG_mx6 = "overlaysink" 61PACKAGECONFIG_mx6dl = "overlaysink"
62PACKAGECONFIG_mx6q = "overlaysink"
63PACKAGECONFIG_mx6sl = "overlaysink"
64PACKAGECONFIG_mx6sx = "overlaysink"
60 65
61 66
62# FIXME: Add all features 67# FIXME: Add all features
@@ -82,4 +87,4 @@ FILES_${PN}-grecorder = "${bindir}/grecorder-1.0"
82FILES_${PN}-librecorder-engine = "${libdir}/librecorder_engine-1.0${SOLIBS}" 87FILES_${PN}-librecorder-engine = "${libdir}/librecorder_engine-1.0${SOLIBS}"
83FILES_${PN}-libplayengine = "${libdir}/libplayengine-1.0${SOLIBS}" 88FILES_${PN}-libplayengine = "${libdir}/libplayengine-1.0${SOLIBS}"
84 89
85COMPATIBLE_MACHINE = "(mx6|mx6ul|mx7)" 90COMPATIBLE_MACHINE = "(mx6dl|mx6q|mx6sl|mx6sx|mx6ul|mx6ull|mx7d)"