diff options
-rw-r--r-- | recipes-bsp/qe-ucode/qe-ucode_git.bb | 15 |
1 files changed, 3 insertions, 12 deletions
diff --git a/recipes-bsp/qe-ucode/qe-ucode_git.bb b/recipes-bsp/qe-ucode/qe-ucode_git.bb index 9bac32d9..58dffa3b 100644 --- a/recipes-bsp/qe-ucode/qe-ucode_git.bb +++ b/recipes-bsp/qe-ucode/qe-ucode_git.bb | |||
@@ -10,29 +10,20 @@ SRCREV= "57401f6dff6507055558eaa6838116baa8a2fd46" | |||
10 | 10 | ||
11 | S = "${WORKDIR}/git" | 11 | S = "${WORKDIR}/git" |
12 | 12 | ||
13 | python () { | ||
14 | if not d.getVar("QE_UCODE"): | ||
15 | PN = d.getVar("PN") | ||
16 | FILE = os.path.basename(d.getVar("FILE")) | ||
17 | bb.debug(1, "To build %s, see %s for instructions on \ | ||
18 | setting up your qe-ucode" % (PN, FILE)) | ||
19 | raise bb.parse.SkipRecipe("because QE_UCODE is not set") | ||
20 | } | ||
21 | |||
22 | do_install () { | 13 | do_install () { |
23 | install -d ${D}/boot | 14 | install -d ${D}/boot |
24 | install -m 644 ${B}/${QE_UCODE} ${D}/boot | 15 | install -m 644 ${B}/*.bin ${D}/boot |
25 | } | 16 | } |
26 | 17 | ||
27 | do_deploy () { | 18 | do_deploy () { |
28 | install -d ${DEPLOYDIR}/boot | 19 | install -d ${DEPLOYDIR}/boot |
29 | install -m 644 ${B}/${QE_UCODE} ${DEPLOYDIR}/boot | 20 | install -m 644 ${B}/*.bin ${DEPLOYDIR}/boot |
30 | } | 21 | } |
31 | addtask deploy before do_build after do_install | 22 | addtask deploy before do_build after do_install |
32 | 23 | ||
33 | PACKAGES += "${PN}-image" | 24 | PACKAGES += "${PN}-image" |
34 | FILES_${PN}-image += "/boot/*" | 25 | FILES_${PN}-image += "/boot/*" |
35 | 26 | ||
36 | COMPATIBLE_MACHINE = "(ls1021a|ls1043a|t1042|t1024)" | 27 | COMPATIBLE_MACHINE = "(qoriq)" |
37 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" | 28 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" |
38 | 29 | ||