diff options
10 files changed, 158 insertions, 70 deletions
diff --git a/dynamic-layers/aglprofilegraphical/recipes-graphics/wayland/weston-init.bbappend b/dynamic-layers/aglprofilegraphical/recipes-graphics/wayland/weston-init.bbappend new file mode 100644 index 00000000..10b66c0e --- /dev/null +++ b/dynamic-layers/aglprofilegraphical/recipes-graphics/wayland/weston-init.bbappend | |||
@@ -0,0 +1,3 @@ | |||
1 | do_install_append() { | ||
2 | rm -f ${D}${sysconfdir}/xdg/weston/weston.ini | ||
3 | } | ||
diff --git a/dynamic-layers/aglprofilegraphical/recipes-graphics/wayland/weston_5.0.0.imx.bbappend b/dynamic-layers/aglprofilegraphical/recipes-graphics/wayland/weston_5.0.0.imx.bbappend deleted file mode 100644 index 1a896a20..00000000 --- a/dynamic-layers/aglprofilegraphical/recipes-graphics/wayland/weston_5.0.0.imx.bbappend +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | # don't install default weston.ini | ||
2 | WESTON_INI_INSTALL_FILE = "" | ||
diff --git a/dynamic-layers/ivi/recipes-graphics/wayland/weston-init.bbappend b/dynamic-layers/ivi/recipes-graphics/wayland/weston-init.bbappend new file mode 100644 index 00000000..72d991c7 --- /dev/null +++ b/dynamic-layers/ivi/recipes-graphics/wayland/weston-init.bbappend | |||
@@ -0,0 +1 @@ | |||
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | |||
diff --git a/dynamic-layers/ivi/recipes-graphics/wayland/weston-init/weston.ini b/dynamic-layers/ivi/recipes-graphics/wayland/weston-init/weston.ini new file mode 100644 index 00000000..6e8e0140 --- /dev/null +++ b/dynamic-layers/ivi/recipes-graphics/wayland/weston-init/weston.ini | |||
@@ -0,0 +1,104 @@ | |||
1 | [core] | ||
2 | shell=ivi-shell.so | ||
3 | modules=hmi-controller.so | ||
4 | #gbm-format=argb8888 | ||
5 | #use-g2d=1 | ||
6 | #xwayland=true | ||
7 | |||
8 | #[shell] | ||
9 | #size=1920x1080 | ||
10 | |||
11 | [ivi-shell] | ||
12 | ivi-shell-user-interface=weston-ivi-shell-user-interface | ||
13 | |||
14 | #developermode=true | ||
15 | |||
16 | cursor-theme=default | ||
17 | cursor-size=32 | ||
18 | |||
19 | base-layer-id=1000 | ||
20 | base-layer-id-offset=10000 | ||
21 | |||
22 | workspace-background-layer-id=2000 | ||
23 | workspace-layer-id=3000 | ||
24 | application-layer-id=4000 | ||
25 | |||
26 | transition-duration=300 | ||
27 | |||
28 | background-image=/usr/share/weston/background.png | ||
29 | background-id=1001 | ||
30 | panel-image=/usr/share/weston/panel.png | ||
31 | panel-id=1002 | ||
32 | surface-id-offset=10 | ||
33 | tiling-image=/usr/share/weston/tiling.png | ||
34 | tiling-id=1003 | ||
35 | sidebyside-image=/usr/share/weston/sidebyside.png | ||
36 | sidebyside-id=1004 | ||
37 | fullscreen-image=/usr/share/weston/fullscreen.png | ||
38 | fullscreen-id=1005 | ||
39 | random-image=/usr/share/weston/random.png | ||
40 | random-id=1006 | ||
41 | home-image=/usr/share/weston/home.png | ||
42 | home-id=1007 | ||
43 | workspace-background-color=0x99000000 | ||
44 | workspace-background-id=2001 | ||
45 | |||
46 | [ivi-launcher] | ||
47 | workspace-id=0 | ||
48 | icon-id=4001 | ||
49 | icon=/usr/share/weston/icon_ivi_flower.png | ||
50 | path=/usr/bin/weston-flower | ||
51 | |||
52 | [ivi-launcher] | ||
53 | workspace-id=0 | ||
54 | icon-id=4002 | ||
55 | icon=/usr/share/weston/icon_ivi_clickdot.png | ||
56 | path=/usr/bin/weston-clickdot | ||
57 | |||
58 | [ivi-launcher] | ||
59 | workspace-id=1 | ||
60 | icon-id=4003 | ||
61 | icon=/usr/share/weston/icon_ivi_simple-egl.png | ||
62 | path=/usr/bin/weston-simple-egl | ||
63 | |||
64 | [ivi-launcher] | ||
65 | workspace-id=1 | ||
66 | icon-id=4004 | ||
67 | icon=/usr/share/weston/icon_ivi_simple-shm.png | ||
68 | path=/usr/bin/weston-simple-shm | ||
69 | |||
70 | [ivi-launcher] | ||
71 | workspace-id=2 | ||
72 | icon-id=4005 | ||
73 | icon=/usr/share/weston/icon_ivi_smoke.png | ||
74 | path=/usr/bin/weston-smoke | ||
75 | |||
76 | [ivi-launcher] | ||
77 | workspace-id=3 | ||
78 | icon-id=4006 | ||
79 | icon=/usr/share/weston/icon_ivi_flower.png | ||
80 | path=/usr/bin/weston-flower | ||
81 | |||
82 | [ivi-launcher] | ||
83 | workspace-id=3 | ||
84 | icon-id=4007 | ||
85 | icon=/usr/share/weston/icon_ivi_clickdot.png | ||
86 | path=/usr/bin/weston-clickdot | ||
87 | |||
88 | [ivi-launcher] | ||
89 | workspace-id=3 | ||
90 | icon-id=4008 | ||
91 | icon=/usr/share/weston/icon_ivi_simple-egl.png | ||
92 | path=/usr/bin/weston-simple-egl | ||
93 | |||
94 | [ivi-launcher] | ||
95 | workspace-id=3 | ||
96 | icon-id=4009 | ||
97 | icon=/usr/share/weston/icon_ivi_simple-shm.png | ||
98 | path=/usr/bin/weston-simple-shm | ||
99 | |||
100 | [ivi-launcher] | ||
101 | workspace-id=3 | ||
102 | icon-id=4010 | ||
103 | icon=/usr/share/weston/icon_ivi_smoke.png | ||
104 | path=/usr/bin/weston-smoke | ||
diff --git a/dynamic-layers/ivi/recipes-graphics/wayland/weston_5.0.0.imx.bbappend b/dynamic-layers/ivi/recipes-graphics/wayland/weston_5.0.0.imx.bbappend deleted file mode 100644 index d36fbd4d..00000000 --- a/dynamic-layers/ivi/recipes-graphics/wayland/weston_5.0.0.imx.bbappend +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | # install default weston.ini for IVI | ||
2 | WESTON_INI_INSTALL_FILE = "${B}/ivi-shell/weston.ini" | ||
diff --git a/recipes-graphics/wayland/weston-init/mx8mq/weston.ini b/recipes-graphics/wayland/weston-init/mx8mq/weston.ini new file mode 100644 index 00000000..eceb6456 --- /dev/null +++ b/recipes-graphics/wayland/weston-init/mx8mq/weston.ini | |||
@@ -0,0 +1,25 @@ | |||
1 | [core] | ||
2 | gbm-format=argb8888 | ||
3 | idle-time=0 | ||
4 | #use-g2d=1 | ||
5 | #xwayland=true | ||
6 | |||
7 | [shell] | ||
8 | size=1920x1080 | ||
9 | |||
10 | #[output] | ||
11 | #name=HDMI-A-1 | ||
12 | #mode=1920x1080@60 | ||
13 | #transform=90 | ||
14 | |||
15 | #[output] | ||
16 | #name=HDMI-A-2 | ||
17 | #mode=off | ||
18 | # WIDTHxHEIGHT Resolution size width and height in pixels | ||
19 | # off Disables the output | ||
20 | # preferred Uses the preferred mode | ||
21 | # current Uses the current crt controller mode | ||
22 | #transform=90 | ||
23 | |||
24 | [screen-share] | ||
25 | command=@bindir@/weston --backend=rdp-backend.so --shell=fullscreen-shell.so --no-clients-resize | ||
diff --git a/recipes-graphics/wayland/weston-init/weston.ini b/recipes-graphics/wayland/weston-init/weston.ini new file mode 100644 index 00000000..d9094b1f --- /dev/null +++ b/recipes-graphics/wayland/weston-init/weston.ini | |||
@@ -0,0 +1,25 @@ | |||
1 | [core] | ||
2 | #gbm-format=argb8888 | ||
3 | idle-time=0 | ||
4 | #use-g2d=1 | ||
5 | #xwayland=true | ||
6 | |||
7 | #[shell] | ||
8 | #size=1920x1080 | ||
9 | |||
10 | #[output] | ||
11 | #name=HDMI-A-1 | ||
12 | #mode=1920x1080@60 | ||
13 | #transform=90 | ||
14 | |||
15 | #[output] | ||
16 | #name=HDMI-A-2 | ||
17 | #mode=off | ||
18 | # WIDTHxHEIGHT Resolution size width and height in pixels | ||
19 | # off Disables the output | ||
20 | # preferred Uses the preferred mode | ||
21 | # current Uses the current crt controller mode | ||
22 | #transform=90 | ||
23 | |||
24 | [screen-share] | ||
25 | command=@bindir@/weston --backend=rdp-backend.so --shell=fullscreen-shell.so --no-clients-resize | ||
diff --git a/recipes-graphics/wayland/weston/0001-weston.ini-using-argb8888-as-gbm-default-on-mscale-8.patch b/recipes-graphics/wayland/weston/0001-weston.ini-using-argb8888-as-gbm-default-on-mscale-8.patch deleted file mode 100644 index 75589d3b..00000000 --- a/recipes-graphics/wayland/weston/0001-weston.ini-using-argb8888-as-gbm-default-on-mscale-8.patch +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | From 186ec0c80410b2120b8f31c211cb44a836c84522 Mon Sep 17 00:00:00 2001 | ||
2 | From: Haihua Hu <jared.hu@nxp.com> | ||
3 | Date: Wed, 4 Jul 2018 16:05:20 +0800 | ||
4 | Subject: [PATCH] weston.ini: using argb8888 as gbm default on mscale 850D | ||
5 | |||
6 | mscale 850D video playback need using pixel alpha for graphic layer | ||
7 | |||
8 | upstream status: imx specific | ||
9 | Signed-off-by: Haihua Hu <jared.hu@nxp.com> | ||
10 | |||
11 | --- | ||
12 | weston.ini.in | 1 + | ||
13 | 1 file changed, 1 insertion(+) | ||
14 | |||
15 | Index: git/weston.ini.in | ||
16 | =================================================================== | ||
17 | --- git.orig/weston.ini.in | ||
18 | +++ git/weston.ini.in | ||
19 | @@ -2,6 +2,7 @@ | ||
20 | # i.MX: Disable idle timeout | ||
21 | idle-time=0 | ||
22 | #use-g2d=1 | ||
23 | +gbm-format=argb8888 | ||
24 | |||
25 | [libinput] | ||
26 | touchscreen_calibrator=true | ||
diff --git a/recipes-graphics/wayland/weston/0002-weston.ini-configure-desktop-shell-size-in-weston-co.patch b/recipes-graphics/wayland/weston/0002-weston.ini-configure-desktop-shell-size-in-weston-co.patch deleted file mode 100644 index 4aa32569..00000000 --- a/recipes-graphics/wayland/weston/0002-weston.ini-configure-desktop-shell-size-in-weston-co.patch +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | From 3012798d7e9c9e624024fc962d749a960289ad8b Mon Sep 17 00:00:00 2001 | ||
2 | From: Haihua Hu <jared.hu@nxp.com> | ||
3 | Date: Wed, 11 Jul 2018 17:47:47 +0800 | ||
4 | Subject: [PATCH] weston.ini: configure desktop shell size in weston configure | ||
5 | file | ||
6 | |||
7 | mscale 850D need set desktop shell to 1080p | ||
8 | |||
9 | upstream status: imx specific | ||
10 | Signed-off-by: Haihua Hu <jared.hu@nxp.com> | ||
11 | |||
12 | --- | ||
13 | weston.ini.in | 2 ++ | ||
14 | 1 file changed, 2 insertions(+) | ||
15 | |||
16 | diff --git a/weston.ini.in b/weston.ini.in | ||
17 | index bd8abe4..077155b 100644 | ||
18 | --- a/weston.ini.in | ||
19 | +++ b/weston.ini.in | ||
20 | @@ -8,6 +8,8 @@ gbm-format=argb8888 | ||
21 | #mode=1920x1080@60 | ||
22 | #transform=90 | ||
23 | |||
24 | +[shell] | ||
25 | +size=1920x1080 | ||
26 | |||
27 | #[output] | ||
28 | #name=HDMI-A-2 | ||
diff --git a/recipes-graphics/wayland/weston_5.0.0.imx.bb b/recipes-graphics/wayland/weston_5.0.0.imx.bb index e9f354f0..270aa2ad 100644 --- a/recipes-graphics/wayland/weston_5.0.0.imx.bb +++ b/recipes-graphics/wayland/weston_5.0.0.imx.bb | |||
@@ -16,10 +16,6 @@ SRC_URI = "git://source.codeaurora.org/external/imx/weston-imx.git;protocol=http | |||
16 | file://0001-weston-launch-Provide-a-default-version-that-doesn-t.patch \ | 16 | file://0001-weston-launch-Provide-a-default-version-that-doesn-t.patch \ |
17 | file://0003-weston-touch-calibrator-Advertise-the-touchscreen-ca.patch \ | 17 | file://0003-weston-touch-calibrator-Advertise-the-touchscreen-ca.patch \ |
18 | " | 18 | " |
19 | # Use argb8888 as gbm-format for i.MX8MQ only | ||
20 | SRC_URI_append_mx8mq = " file://0001-weston.ini-using-argb8888-as-gbm-default-on-mscale-8.patch \ | ||
21 | file://0002-weston.ini-configure-desktop-shell-size-in-weston-co.patch \ | ||
22 | " | ||
23 | SRCREV = "fb563901657b296c7c7c86d26602a622429e334f" | 19 | SRCREV = "fb563901657b296c7c7c86d26602a622429e334f" |
24 | S = "${WORKDIR}/git" | 20 | S = "${WORKDIR}/git" |
25 | 21 | ||
@@ -102,9 +98,6 @@ PACKAGECONFIG[imxg2d] = "--enable-imxg2d,--disable-imxg2d,virtual/libg2d" | |||
102 | # Weston with OpenGL support | 98 | # Weston with OpenGL support |
103 | PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl" | 99 | PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl" |
104 | 100 | ||
105 | # Set to install a default weston.ini file | ||
106 | WESTON_INI_INSTALL_FILE = "${B}/weston.ini" | ||
107 | |||
108 | do_install_append() { | 101 | do_install_append() { |
109 | # Weston doesn't need the .la files to load modules, so wipe them | 102 | # Weston doesn't need the .la files to load modules, so wipe them |
110 | rm -f ${D}/${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.la | 103 | rm -f ${D}/${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.la |
@@ -121,11 +114,6 @@ do_install_append() { | |||
121 | if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "yes" ]; then | 114 | if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "yes" ]; then |
122 | install -Dm 644 ${WORKDIR}/xwayland.weston-start ${D}${datadir}/weston-start/xwayland | 115 | install -Dm 644 ${WORKDIR}/xwayland.weston-start ${D}${datadir}/weston-start/xwayland |
123 | fi | 116 | fi |
124 | |||
125 | # install default weston.ini | ||
126 | if [ "${WESTON_INI_INSTALL_FILE}" != "" ]; then | ||
127 | install -D -m 0644 ${WESTON_INI_INSTALL_FILE} ${D}${sysconfdir}/xdg/weston/weston.ini | ||
128 | fi | ||
129 | } | 117 | } |
130 | 118 | ||
131 | PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', '${PN}-xwayland', '', d)} \ | 119 | PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', '${PN}-xwayland', '', d)} \ |