diff options
-rw-r--r-- | classes/use-imx-security-controller-firmware.bbclass | 10 | ||||
-rw-r--r-- | conf/machine/imx8dx-mek.conf | 2 | ||||
-rw-r--r-- | conf/machine/include/imx-base.inc | 6 | ||||
-rw-r--r-- | recipes-bsp/imx-mkimage/imx-boot_1.0.bb | 1 | ||||
-rw-r--r-- | recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc | 3 | ||||
-rw-r--r-- | recipes-graphics/wayland/weston-init.bbappend | 5 | ||||
-rw-r--r-- | recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb | 5 | ||||
-rw-r--r-- | recipes-multimedia/imx-dsp/imx-dsp-codec-ext_1.2.0.bb | 2 | ||||
-rw-r--r-- | recipes-multimedia/imx-dsp/imx-dsp_1.2.0.bb | 2 | ||||
-rw-r--r-- | recipes-security/optee-imx/optee-os_3.15.0.imx.bb | 16 |
10 files changed, 31 insertions, 21 deletions
diff --git a/classes/use-imx-security-controller-firmware.bbclass b/classes/use-imx-security-controller-firmware.bbclass index bdbf3684..dfd708e4 100644 --- a/classes/use-imx-security-controller-firmware.bbclass +++ b/classes/use-imx-security-controller-firmware.bbclass | |||
@@ -16,13 +16,13 @@ | |||
16 | # This behavior ensures that derivatives which requires SECO Firmware to be | 16 | # This behavior ensures that derivatives which requires SECO Firmware to be |
17 | # present in the image file have it properly defined. | 17 | # present in the image file have it properly defined. |
18 | 18 | ||
19 | SECO_FIRMWARE_NAME ?= "" | 19 | SECO_FIRMWARE_NAME ?= "" |
20 | 20 | SECO_FIRMWARE_NAME:mx8qm-nxp-bsp = "mx8qmb0-ahab-container.img" | |
21 | SECO_FIRMWARE_NAME:mx8qm-nxp-bsp = "mx8qmb0-ahab-container.img" | 21 | SECO_FIRMWARE_NAME:mx8qxp-nxp-bsp = \ |
22 | SECO_FIRMWARE_NAME:mx8qxp-nxp-bsp = \ | ||
23 | "${@bb.utils.contains('MACHINE_FEATURES', 'soc-revb0', 'mx8qxb0-ahab-container.img', \ | 22 | "${@bb.utils.contains('MACHINE_FEATURES', 'soc-revb0', 'mx8qxb0-ahab-container.img', \ |
24 | 'mx8qxc0-ahab-container.img', d)}" | 23 | 'mx8qxc0-ahab-container.img', d)}" |
25 | SECO_FIRMWARE_NAME:mx8dxl-nxp-bsp = "mx8dxla1-ahab-container.img" | 24 | SECO_FIRMWARE_NAME:mx8dx-nxp-bsp = "mx8qxc0-ahab-container.img" |
25 | SECO_FIRMWARE_NAME:mx8dxl-nxp-bsp = "mx8dxla1-ahab-container.img" | ||
26 | 26 | ||
27 | python () { | 27 | python () { |
28 | if "mx8m-nxp-bsp" in d.getVar('MACHINEOVERRIDES').split(":"): | 28 | if "mx8m-nxp-bsp" in d.getVar('MACHINEOVERRIDES').split(":"): |
diff --git a/conf/machine/imx8dx-mek.conf b/conf/machine/imx8dx-mek.conf index d1aaa8ee..8e8bdee0 100644 --- a/conf/machine/imx8dx-mek.conf +++ b/conf/machine/imx8dx-mek.conf | |||
@@ -3,7 +3,7 @@ | |||
3 | #@DESCRIPTION: i.MX 8DualXPlus Multisensory Enablement Kit board | 3 | #@DESCRIPTION: i.MX 8DualXPlus Multisensory Enablement Kit board |
4 | #@MAINTAINER: Lauren Post <lauren.post@nxp.com> | 4 | #@MAINTAINER: Lauren Post <lauren.post@nxp.com> |
5 | 5 | ||
6 | MACHINEOVERRIDES =. "mx8qxp:mx8dx:" | 6 | MACHINEOVERRIDES =. "mx8dx:" |
7 | 7 | ||
8 | require include/imx8x-mek.inc | 8 | require include/imx8x-mek.inc |
9 | 9 | ||
diff --git a/conf/machine/include/imx-base.inc b/conf/machine/include/imx-base.inc index dc997443..cba47a0a 100644 --- a/conf/machine/include/imx-base.inc +++ b/conf/machine/include/imx-base.inc | |||
@@ -159,6 +159,7 @@ MACHINEOVERRIDES_EXTENDER:mx8mp:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxd | |||
159 | MACHINEOVERRIDES_EXTENDER:mx8mq:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxdrm:imxvpu:imxgpu:imxgpu3d:mx8-generic-bsp:mx8-nxp-bsp:mx8m-generic-bsp:mx8m-nxp-bsp:mx8mq-generic-bsp:mx8mq-nxp-bsp" | 159 | MACHINEOVERRIDES_EXTENDER:mx8mq:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxdrm:imxvpu:imxgpu:imxgpu3d:mx8-generic-bsp:mx8-nxp-bsp:mx8m-generic-bsp:mx8m-nxp-bsp:mx8mq-generic-bsp:mx8mq-nxp-bsp" |
160 | 160 | ||
161 | MACHINEOVERRIDES_EXTENDER:mx8qxp:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxdrm:imxdpu:imxgpu:imxgpu2d:imxgpu3d:mx8-generic-bsp:mx8-nxp-bsp:mx8x-generic-bsp:mx8x-nxp-bsp:mx8qxp-generic-bsp:mx8qxp-nxp-bsp" | 161 | MACHINEOVERRIDES_EXTENDER:mx8qxp:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxdrm:imxdpu:imxgpu:imxgpu2d:imxgpu3d:mx8-generic-bsp:mx8-nxp-bsp:mx8x-generic-bsp:mx8x-nxp-bsp:mx8qxp-generic-bsp:mx8qxp-nxp-bsp" |
162 | MACHINEOVERRIDES_EXTENDER:mx8dx:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxdrm:imxdpu:imxgpu:imxgpu2d:imxgpu3d:mx8-generic-bsp:mx8-nxp-bsp:mx8x-generic-bsp:mx8x-nxp-bsp:mx8dx-generic-bsp:mx8dx-nxp-bsp" | ||
162 | MACHINEOVERRIDES_EXTENDER:mx8dxl:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxfbdev:mx8dxl-generic-bsp:mx8-generic-bsp:mx8-nxp-bsp:mx8x-generic-bsp:mx8x-nxp-bsp:mx8dxl-nxp-bsp" | 163 | MACHINEOVERRIDES_EXTENDER:mx8dxl:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxfbdev:mx8dxl-generic-bsp:mx8-generic-bsp:mx8-nxp-bsp:mx8x-generic-bsp:mx8x-nxp-bsp:mx8dxl-nxp-bsp" |
163 | 164 | ||
164 | ####### | 165 | ####### |
@@ -196,6 +197,7 @@ MACHINEOVERRIDES_EXTENDER:mx8mp:use-mainline-bsp = "imx-generic-bsp:imx-mainlin | |||
196 | MACHINEOVERRIDES_EXTENDER:mx8mq:use-mainline-bsp = "imx-generic-bsp:imx-mainline-bsp:mx8-generic-bsp:mx8-mainline-bsp:mx8m-generic-bsp:mx8m-mainline-bsp:mx8mq-generic-bsp:mx8mq-mainline-bsp" | 197 | MACHINEOVERRIDES_EXTENDER:mx8mq:use-mainline-bsp = "imx-generic-bsp:imx-mainline-bsp:mx8-generic-bsp:mx8-mainline-bsp:mx8m-generic-bsp:mx8m-mainline-bsp:mx8mq-generic-bsp:mx8mq-mainline-bsp" |
197 | 198 | ||
198 | MACHINEOVERRIDES_EXTENDER:mx8qxp:use-mainline-bsp = "imx-generic-bsp:imx-mainline-bsp:mx8-generic-bsp:mx8-mainline-bsp:mx8x-generic-bsp:mx8x-mainline-bsp:mx8qxp-generic-bsp:mx8qxp-mainline-bsp" | 199 | MACHINEOVERRIDES_EXTENDER:mx8qxp:use-mainline-bsp = "imx-generic-bsp:imx-mainline-bsp:mx8-generic-bsp:mx8-mainline-bsp:mx8x-generic-bsp:mx8x-mainline-bsp:mx8qxp-generic-bsp:mx8qxp-mainline-bsp" |
200 | MACHINEOVERRIDES_EXTENDER:mx8dx:use-mainline-bsp = "imx-generic-bsp:imx-mainline-bsp:mx8-generic-bsp:mx8-mainline-bsp:mx8x-generic-bsp:mx8x-mainline-bsp:mx8dx-generic-bsp:mx8dx-mainline-bsp" | ||
199 | MACHINEOVERRIDES_EXTENDER:mx8dxl:use-mainline-bsp = "imx-generic-bsp:imx-mainline-bsp:mx8-generic-bsp:mx8-mainline-bsp:mx8x-generic-bsp:mx8x-mainline-bsp:mx8dxl-generic-bsp:mx8dxl-mainline-bsp" | 201 | MACHINEOVERRIDES_EXTENDER:mx8dxl:use-mainline-bsp = "imx-generic-bsp:imx-mainline-bsp:mx8-generic-bsp:mx8-mainline-bsp:mx8x-generic-bsp:mx8x-mainline-bsp:mx8dxl-generic-bsp:mx8dxl-mainline-bsp" |
200 | 202 | ||
201 | MACHINEOVERRIDES_EXTENDER_FILTER_OUT = " \ | 203 | MACHINEOVERRIDES_EXTENDER_FILTER_OUT = " \ |
@@ -221,6 +223,7 @@ MACHINEOVERRIDES_EXTENDER_FILTER_OUT = " \ | |||
221 | mx8mp \ | 223 | mx8mp \ |
222 | mx8mq \ | 224 | mx8mq \ |
223 | mx8qxp \ | 225 | mx8qxp \ |
226 | mx8dx \ | ||
224 | mx8dxl \ | 227 | mx8dxl \ |
225 | " | 228 | " |
226 | 229 | ||
@@ -246,6 +249,7 @@ MACHINE_SOCARCH_SUFFIX:mx8mn-nxp-bsp = "-mx8mn" | |||
246 | MACHINE_SOCARCH_SUFFIX:mx8mp-nxp-bsp = "-mx8mp" | 249 | MACHINE_SOCARCH_SUFFIX:mx8mp-nxp-bsp = "-mx8mp" |
247 | MACHINE_SOCARCH_SUFFIX:mx8mq-nxp-bsp = "-mx8m" | 250 | MACHINE_SOCARCH_SUFFIX:mx8mq-nxp-bsp = "-mx8m" |
248 | MACHINE_SOCARCH_SUFFIX:mx8qxp-nxp-bsp = "-mx8" | 251 | MACHINE_SOCARCH_SUFFIX:mx8qxp-nxp-bsp = "-mx8" |
252 | MACHINE_SOCARCH_SUFFIX:mx8dx-nxp-bsp = "-mx8" | ||
249 | MACHINE_SOCARCH_SUFFIX:mx8dxl-nxp-bsp = "-mx8dxl" | 253 | MACHINE_SOCARCH_SUFFIX:mx8dxl-nxp-bsp = "-mx8dxl" |
250 | 254 | ||
251 | # For Mainline we use a single SoC suffix as we don't have different build options | 255 | # For Mainline we use a single SoC suffix as we don't have different build options |
@@ -335,6 +339,7 @@ MACHINE_FIRMWARE:append:mx8mp-generic-bsp = " linux-firmware-imx-sdma-imx7d fir | |||
335 | MACHINE_FIRMWARE:append:mx8mq-generic-bsp = " linux-firmware-imx-sdma-imx7d" | 339 | MACHINE_FIRMWARE:append:mx8mq-generic-bsp = " linux-firmware-imx-sdma-imx7d" |
336 | MACHINE_FIRMWARE:append:mx8qm-generic-bsp = " firmware-imx-vpu-imx8" | 340 | MACHINE_FIRMWARE:append:mx8qm-generic-bsp = " firmware-imx-vpu-imx8" |
337 | MACHINE_FIRMWARE:append:mx8qxp-generic-bsp = " firmware-imx-vpu-imx8" | 341 | MACHINE_FIRMWARE:append:mx8qxp-generic-bsp = " firmware-imx-vpu-imx8" |
342 | MACHINE_FIRMWARE:append:mx8dx-generic-bsp = " firmware-imx-vpu-imx8" | ||
338 | MACHINE_FIRMWARE:append:imx-mainline-bsp = " linux-firmware-imx-sdma-imx6q linux-firmware-imx-sdma-imx7d firmware-imx-vpu-imx6q firmware-imx-vpu-imx6d" | 343 | MACHINE_FIRMWARE:append:imx-mainline-bsp = " linux-firmware-imx-sdma-imx6q linux-firmware-imx-sdma-imx7d firmware-imx-vpu-imx6q firmware-imx-vpu-imx6d" |
339 | 344 | ||
340 | MACHINE_EXTRA_RRECOMMENDS += "${MACHINE_FIRMWARE}" | 345 | MACHINE_EXTRA_RRECOMMENDS += "${MACHINE_FIRMWARE}" |
@@ -383,6 +388,7 @@ MACHINE_GSTREAMER_1_0_PLUGIN:mx8mp-nxp-bsp ?= "imx-gst1.0-plugin" | |||
383 | MACHINE_GSTREAMER_1_0_PLUGIN:mx8mq-nxp-bsp ?= "imx-gst1.0-plugin" | 388 | MACHINE_GSTREAMER_1_0_PLUGIN:mx8mq-nxp-bsp ?= "imx-gst1.0-plugin" |
384 | MACHINE_GSTREAMER_1_0_PLUGIN:mx8qm-nxp-bsp ?= "imx-gst1.0-plugin" | 389 | MACHINE_GSTREAMER_1_0_PLUGIN:mx8qm-nxp-bsp ?= "imx-gst1.0-plugin" |
385 | MACHINE_GSTREAMER_1_0_PLUGIN:mx8qxp-nxp-bsp ?= "imx-gst1.0-plugin" | 390 | MACHINE_GSTREAMER_1_0_PLUGIN:mx8qxp-nxp-bsp ?= "imx-gst1.0-plugin" |
391 | MACHINE_GSTREAMER_1_0_PLUGIN:mx8dx-nxp-bsp ?= "imx-gst1.0-plugin" | ||
386 | 392 | ||
387 | PREFERRED_VERSION_gstreamer1.0:mx8-nxp-bsp ?= "1.18.0.imx" | 393 | PREFERRED_VERSION_gstreamer1.0:mx8-nxp-bsp ?= "1.18.0.imx" |
388 | PREFERRED_VERSION_gstreamer1.0-plugins-base:mx8-nxp-bsp ?= "1.18.0.imx" | 394 | PREFERRED_VERSION_gstreamer1.0-plugins-base:mx8-nxp-bsp ?= "1.18.0.imx" |
diff --git a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb index d5330897..88689ead 100644 --- a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb +++ b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb | |||
@@ -73,6 +73,7 @@ REV_OPTION ?= "" | |||
73 | REV_OPTION:mx8qxp-nxp-bsp = \ | 73 | REV_OPTION:mx8qxp-nxp-bsp = \ |
74 | "${@bb.utils.contains('MACHINE_FEATURES', 'soc-revb0', '', \ | 74 | "${@bb.utils.contains('MACHINE_FEATURES', 'soc-revb0', '', \ |
75 | 'REV=C0', d)}" | 75 | 'REV=C0', d)}" |
76 | REV_OPTION:mx8dx-nxp-bsp = "REV=C0" | ||
76 | 77 | ||
77 | compile_mx8m() { | 78 | compile_mx8m() { |
78 | bbnote 8MQ/8MM/8MN/8MP boot binary build | 79 | bbnote 8MQ/8MM/8MN/8MP boot binary build |
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc index 3dd2f55c..7816ec40 100644 --- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc +++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc | |||
@@ -147,9 +147,10 @@ HAS_GBM:mx8-nxp-bsp = "true" | |||
147 | 147 | ||
148 | IMX_SOC = "IMX_SOC_NOT_SET" | 148 | IMX_SOC = "IMX_SOC_NOT_SET" |
149 | IMX_SOC:mx8qm-nxp-bsp = "mx8qm" | 149 | IMX_SOC:mx8qm-nxp-bsp = "mx8qm" |
150 | IMX_SOC:mx8qxp-nxp-bsp = "mx8qxp" | ||
151 | IMX_SOC:mx8dx-nxp-bsp = "mx8qxp" | ||
150 | IMX_SOC:mx8mp-nxp-bsp = "mx8mp" | 152 | IMX_SOC:mx8mp-nxp-bsp = "mx8mp" |
151 | IMX_SOC:mx8mq-nxp-bsp = "mx8mq" | 153 | IMX_SOC:mx8mq-nxp-bsp = "mx8mq" |
152 | IMX_SOC:mx8qxp-nxp-bsp = "mx8qxp" | ||
153 | IMX_SOC:mx8mn-nxp-bsp = "mx8mn" | 154 | IMX_SOC:mx8mn-nxp-bsp = "mx8mn" |
154 | IMX_SOC:mx8ulp-nxp-bsp = "mx8ulp" | 155 | IMX_SOC:mx8ulp-nxp-bsp = "mx8ulp" |
155 | 156 | ||
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend index 7aceb6b1..4ba6cba7 100644 --- a/recipes-graphics/wayland/weston-init.bbappend +++ b/recipes-graphics/wayland/weston-init.bbappend | |||
@@ -27,9 +27,10 @@ INI_UNCOMMENT_ASSIGNMENTS:append:mx8mq-nxp-bsp = " \ | |||
27 | # FIXME: The 8QM and 8QXP SoCs have better performance without G2D so don't enable it | 27 | # FIXME: The 8QM and 8QXP SoCs have better performance without G2D so don't enable it |
28 | # Ideally, this should be seamless and Vivante ought to handle it internally and take the fastest | 28 | # Ideally, this should be seamless and Vivante ought to handle it internally and take the fastest |
29 | # rendering code. | 29 | # rendering code. |
30 | INI_UNCOMMENT_USE_G2D:imxgpu2d ?= "use-g2d=1" | 30 | INI_UNCOMMENT_USE_G2D:imxgpu2d ?= "use-g2d=1" |
31 | INI_UNCOMMENT_USE_G2D:mx8qm-nxp-bsp = "" | 31 | INI_UNCOMMENT_USE_G2D:mx8qm-nxp-bsp = "" |
32 | INI_UNCOMMENT_USE_G2D:mx8qxp-nxp-bsp = "" | 32 | INI_UNCOMMENT_USE_G2D:mx8qxp-nxp-bsp = "" |
33 | INI_UNCOMMENT_USE_G2D:mx8dx-nxp-bsp = "" | ||
33 | INI_UNCOMMENT_ASSIGNMENTS:append:imxgpu2d = " \ | 34 | INI_UNCOMMENT_ASSIGNMENTS:append:imxgpu2d = " \ |
34 | ${INI_UNCOMMENT_USE_G2D} \ | 35 | ${INI_UNCOMMENT_USE_G2D} \ |
35 | " | 36 | " |
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb index f53de1fa..160a9ea5 100644 --- a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb +++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb | |||
@@ -49,9 +49,10 @@ PACKAGES =+ "${PN}-gplay ${PN}-libgplaycore ${PN}-libgstfsl ${PN}-grecorder ${PN | |||
49 | # Add codec list that the beep plugin run-time depended | 49 | # Add codec list that the beep plugin run-time depended |
50 | BEEP_RDEPENDS = "imx-codec-aac imx-codec-mp3 imx-codec-oggvorbis" | 50 | BEEP_RDEPENDS = "imx-codec-aac imx-codec-mp3 imx-codec-oggvorbis" |
51 | RDEPENDS:${PN} += "imx-parser ${BEEP_RDEPENDS} gstreamer1.0-plugins-good-id3demux " | 51 | RDEPENDS:${PN} += "imx-parser ${BEEP_RDEPENDS} gstreamer1.0-plugins-good-id3demux " |
52 | RDEPENDS:${PN}:append:mx8qm-nxp-bsp = " imx-dsp" | 52 | RDEPENDS:${PN}:append:mx8qm-nxp-bsp = " imx-dsp" |
53 | RDEPENDS:${PN}:append:mx8qxp-nxp-bsp = " imx-dsp" | 53 | RDEPENDS:${PN}:append:mx8qxp-nxp-bsp = " imx-dsp" |
54 | RDEPENDS:${PN}:append:mx8mp-nxp-bsp = " imx-dsp" | 54 | RDEPENDS:${PN}:append:mx8dx-nxp-bsp = " imx-dsp" |
55 | RDEPENDS:${PN}:append:mx8mp-nxp-bsp = " imx-dsp" | ||
55 | RDEPENDS:${PN}:append:mx8ulp-nxp-bsp = " imx-dsp" | 56 | RDEPENDS:${PN}:append:mx8ulp-nxp-bsp = " imx-dsp" |
56 | 57 | ||
57 | # overlaysink rely on G2D, | 58 | # overlaysink rely on G2D, |
diff --git a/recipes-multimedia/imx-dsp/imx-dsp-codec-ext_1.2.0.bb b/recipes-multimedia/imx-dsp/imx-dsp-codec-ext_1.2.0.bb index f34c466c..470fb7fa 100644 --- a/recipes-multimedia/imx-dsp/imx-dsp-codec-ext_1.2.0.bb +++ b/recipes-multimedia/imx-dsp/imx-dsp-codec-ext_1.2.0.bb | |||
@@ -18,4 +18,4 @@ INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | |||
18 | INSANE_SKIP:${PN} = "arch dev-so" | 18 | INSANE_SKIP:${PN} = "arch dev-so" |
19 | 19 | ||
20 | FILES:${PN} += "${libdir}/imx-mm/audio-codec ${datadir}/imx-mm" | 20 | FILES:${PN} += "${libdir}/imx-mm/audio-codec ${datadir}/imx-mm" |
21 | COMPATIBLE_MACHINE = "(mx8qm-nxp-bsp|mx8qxp-nxp-bsp|mx8mp-nxp-bsp|mx8ulp-nxp-bsp)" | 21 | COMPATIBLE_MACHINE = "(mx8qm-nxp-bsp|mx8qxp-nxp-bsp|mx8dx-nxp-bsp|mx8mp-nxp-bsp|mx8ulp-nxp-bsp)" |
diff --git a/recipes-multimedia/imx-dsp/imx-dsp_1.2.0.bb b/recipes-multimedia/imx-dsp/imx-dsp_1.2.0.bb index eb90f17f..bfa279a0 100644 --- a/recipes-multimedia/imx-dsp/imx-dsp_1.2.0.bb +++ b/recipes-multimedia/imx-dsp/imx-dsp_1.2.0.bb | |||
@@ -42,4 +42,4 @@ INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | |||
42 | INHIBIT_SYSROOT_STRIP = "1" | 42 | INHIBIT_SYSROOT_STRIP = "1" |
43 | 43 | ||
44 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 44 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
45 | COMPATIBLE_MACHINE = "(mx8qm-nxp-bsp|mx8qxp-nxp-bsp|mx8mp-nxp-bsp|mx8ulp-nxp-bsp)" | 45 | COMPATIBLE_MACHINE = "(mx8qm-nxp-bsp|mx8qxp-nxp-bsp|mx8dx-nxp-bsp|mx8mp-nxp-bsp|mx8ulp-nxp-bsp)" |
diff --git a/recipes-security/optee-imx/optee-os_3.15.0.imx.bb b/recipes-security/optee-imx/optee-os_3.15.0.imx.bb index e3eea2b4..3fca3dbf 100644 --- a/recipes-security/optee-imx/optee-os_3.15.0.imx.bb +++ b/recipes-security/optee-imx/optee-os_3.15.0.imx.bb | |||
@@ -31,14 +31,14 @@ PLATFORM_FLAVOR:imx6ul = "mx6ulevk" | |||
31 | PLATFORM_FLAVOR:imx6ull = "mx6ullevk" | 31 | PLATFORM_FLAVOR:imx6ull = "mx6ullevk" |
32 | PLATFORM_FLAVOR:imx6ull = "mx6ullevk" | 32 | PLATFORM_FLAVOR:imx6ull = "mx6ullevk" |
33 | PLATFORM_FLAVOR:imx6ulz = "mx6ulzevk" | 33 | PLATFORM_FLAVOR:imx6ulz = "mx6ulzevk" |
34 | PLATFORM_FLAVOR:mx8mq-nxp-bsp = "mx8mqevk" | 34 | PLATFORM_FLAVOR:mx8mq-nxp-bsp = "mx8mqevk" |
35 | PLATFORM_FLAVOR:mx8mm-nxp-bsp = "mx8mmevk" | 35 | PLATFORM_FLAVOR:mx8mm-nxp-bsp = "mx8mmevk" |
36 | PLATFORM_FLAVOR:mx8mn-nxp-bsp = "mx8mnevk" | 36 | PLATFORM_FLAVOR:mx8mn-nxp-bsp = "mx8mnevk" |
37 | PLATFORM_FLAVOR:mx8mp-nxp-bsp = "mx8mpevk" | 37 | PLATFORM_FLAVOR:mx8mp-nxp-bsp = "mx8mpevk" |
38 | PLATFORM_FLAVOR:mx8qm-nxp-bsp = "mx8qmmek" | 38 | PLATFORM_FLAVOR:mx8qm-nxp-bsp = "mx8qmmek" |
39 | PLATFORM_FLAVOR:mx8qxp-nxp-bsp = "mx8qxpmek" | 39 | PLATFORM_FLAVOR:mx8qxp-nxp-bsp = "mx8qxpmek" |
40 | PLATFORM_FLAVOR:mx8dx-nxp-bsp = "mx8dxmek" | 40 | PLATFORM_FLAVOR:mx8dx-nxp-bsp = "mx8dxmek" |
41 | PLATFORM_FLAVOR:mx8dxl-nxp-bsp = "mx8dxlevk" | 41 | PLATFORM_FLAVOR:mx8dxl-nxp-bsp = "mx8dxlevk" |
42 | 42 | ||
43 | OPTEE_ARCH ?= "arm32" | 43 | OPTEE_ARCH ?= "arm32" |
44 | OPTEE_ARCH:armv7a = "arm32" | 44 | OPTEE_ARCH:armv7a = "arm32" |