diff options
-rw-r--r-- | recipes-dpaa2/management-complex/management-complex_10.14.1.bb | 41 | ||||
-rw-r--r-- | recipes-dpaa2/management-complex/management-complex_10.20.4.bb | 41 | ||||
-rw-r--r-- | recipes-dpaa2/management-complex/management-complex_10.24.0.bb | 41 | ||||
-rw-r--r-- | recipes-dpaa2/management-complex/management-complex_10.29.0.bb | 41 | ||||
-rw-r--r-- | recipes-dpaa2/management-complex/management-complex_10.37.0.bb (renamed from recipes-dpaa2/management-complex/management-complex_10.35.0.bb) | 4 |
5 files changed, 2 insertions, 166 deletions
diff --git a/recipes-dpaa2/management-complex/management-complex_10.14.1.bb b/recipes-dpaa2/management-complex/management-complex_10.14.1.bb deleted file mode 100644 index 4d4f1dcd..00000000 --- a/recipes-dpaa2/management-complex/management-complex_10.14.1.bb +++ /dev/null | |||
@@ -1,41 +0,0 @@ | |||
1 | SUMMARY = "DPAA2 Management Complex Firmware" | ||
2 | LICENSE = "NXP-Binary-EULA" | ||
3 | LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=afcb1213054384820390d410ab62105f" | ||
4 | |||
5 | inherit deploy | ||
6 | |||
7 | INHIBIT_DEFAULT_DEPS = "1" | ||
8 | |||
9 | SRC_URI = "git://github.com/nxp/qoriq-mc-binary;nobranch=1;protocol=https" | ||
10 | SRCREV = "408110ee632f6291545b0b156cd74e7e3b4612cc" | ||
11 | |||
12 | S = "${WORKDIR}/git" | ||
13 | |||
14 | REGLEX:ls2088a = "ls2088a" | ||
15 | REGLEX:ls2080a = "ls2080a" | ||
16 | REGLEX:ls1088a = "ls1088a" | ||
17 | REGLEX:lx2160a = "lx2160a" | ||
18 | |||
19 | do_install () { | ||
20 | install -d ${D}/boot | ||
21 | install -m 755 ${S}/${REGLEX}/*.itb ${D}/boot | ||
22 | } | ||
23 | |||
24 | do_deploy () { | ||
25 | install -d ${DEPLOYDIR}/mc_app | ||
26 | install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app | ||
27 | # make a symlink to the latest binary | ||
28 | for mc_binary in `find ${DEPLOYDIR}/mc_app -type f -printf "%f\n" |sort`;do | ||
29 | ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb | ||
30 | done | ||
31 | } | ||
32 | addtask deploy before do_build after do_install | ||
33 | |||
34 | PACKAGES += "${PN}-image" | ||
35 | FILES:${PN}-image += "/boot" | ||
36 | |||
37 | INHIBIT_PACKAGE_STRIP = "1" | ||
38 | |||
39 | COMPATIBLE_MACHINE = "(qoriq-arm64)" | ||
40 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
41 | |||
diff --git a/recipes-dpaa2/management-complex/management-complex_10.20.4.bb b/recipes-dpaa2/management-complex/management-complex_10.20.4.bb deleted file mode 100644 index 07f26b29..00000000 --- a/recipes-dpaa2/management-complex/management-complex_10.20.4.bb +++ /dev/null | |||
@@ -1,41 +0,0 @@ | |||
1 | SUMMARY = "DPAA2 Management Complex Firmware" | ||
2 | LICENSE = "NXP-Binary-EULA" | ||
3 | LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=73d4b970c18882e229e4bf1ada5bb8d6" | ||
4 | |||
5 | inherit deploy | ||
6 | |||
7 | INHIBIT_DEFAULT_DEPS = "1" | ||
8 | |||
9 | SRC_URI = "git://github.com/nxp/qoriq-mc-binary;nobranch=1;protocol=https" | ||
10 | SRCREV = "f73683596a7b72124d67b62e64f3dc2bb36b9321" | ||
11 | |||
12 | S = "${WORKDIR}/git" | ||
13 | |||
14 | REGLEX:ls2088a = "ls2088a" | ||
15 | REGLEX:ls2080a = "ls2080a" | ||
16 | REGLEX:ls1088a = "ls1088a" | ||
17 | REGLEX:lx2160a = "lx2160a" | ||
18 | |||
19 | do_install () { | ||
20 | install -d ${D}/boot | ||
21 | install -m 755 ${S}/${REGLEX}/*.itb ${D}/boot | ||
22 | } | ||
23 | |||
24 | do_deploy () { | ||
25 | install -d ${DEPLOYDIR}/mc_app | ||
26 | install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app | ||
27 | # make a symlink to the latest binary | ||
28 | for mc_binary in `find ${DEPLOYDIR}/mc_app -type f -printf "%f\n" |sort`;do | ||
29 | ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb | ||
30 | done | ||
31 | } | ||
32 | addtask deploy before do_build after do_install | ||
33 | |||
34 | PACKAGES += "${PN}-image" | ||
35 | FILES:${PN}-image += "/boot" | ||
36 | |||
37 | INHIBIT_PACKAGE_STRIP = "1" | ||
38 | |||
39 | COMPATIBLE_MACHINE = "(qoriq-arm64)" | ||
40 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
41 | |||
diff --git a/recipes-dpaa2/management-complex/management-complex_10.24.0.bb b/recipes-dpaa2/management-complex/management-complex_10.24.0.bb deleted file mode 100644 index 3408fba0..00000000 --- a/recipes-dpaa2/management-complex/management-complex_10.24.0.bb +++ /dev/null | |||
@@ -1,41 +0,0 @@ | |||
1 | SUMMARY = "DPAA2 Management Complex Firmware" | ||
2 | LICENSE = "NXP-Binary-EULA" | ||
3 | LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=481d6288552113961a835bbabceb0c33" | ||
4 | |||
5 | inherit deploy | ||
6 | |||
7 | INHIBIT_DEFAULT_DEPS = "1" | ||
8 | |||
9 | SRC_URI = "git://github.com/nxp/qoriq-mc-binary;nobranch=1;protocol=https" | ||
10 | SRCREV = "324817697a4c89a9a940fb7dba1b18909913ee20" | ||
11 | |||
12 | S = "${WORKDIR}/git" | ||
13 | |||
14 | REGLEX:ls2088a = "ls2088a" | ||
15 | REGLEX:ls2080a = "ls2080a" | ||
16 | REGLEX:ls1088a = "ls1088a" | ||
17 | REGLEX:lx2160a = "lx216xa" | ||
18 | REGLEX:lx2162a = "lx216xa" | ||
19 | |||
20 | do_install () { | ||
21 | install -d ${D}/boot | ||
22 | install -m 755 ${S}/${REGLEX}/*.itb ${D}/boot | ||
23 | } | ||
24 | |||
25 | do_deploy () { | ||
26 | install -d ${DEPLOYDIR}/mc_app | ||
27 | install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app | ||
28 | # make a symlink to the latest binary | ||
29 | for mc_binary in `find ${DEPLOYDIR}/mc_app -type f -printf "%f\n" |sort`;do | ||
30 | ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb | ||
31 | done | ||
32 | } | ||
33 | addtask deploy before do_build after do_install | ||
34 | |||
35 | PACKAGES += "${PN}-image" | ||
36 | FILES:${PN}-image += "/boot" | ||
37 | |||
38 | INHIBIT_PACKAGE_STRIP = "1" | ||
39 | |||
40 | COMPATIBLE_MACHINE = "(qoriq-arm64)" | ||
41 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
diff --git a/recipes-dpaa2/management-complex/management-complex_10.29.0.bb b/recipes-dpaa2/management-complex/management-complex_10.29.0.bb deleted file mode 100644 index 08991f09..00000000 --- a/recipes-dpaa2/management-complex/management-complex_10.29.0.bb +++ /dev/null | |||
@@ -1,41 +0,0 @@ | |||
1 | SUMMARY = "DPAA2 Management Complex Firmware" | ||
2 | LICENSE = "NXP-Binary-EULA" | ||
3 | LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=2cb2fee5d3558ee2a81331ed121647ad" | ||
4 | |||
5 | inherit deploy | ||
6 | |||
7 | INHIBIT_DEFAULT_DEPS = "1" | ||
8 | |||
9 | SRC_URI = "git://github.com/nxp/qoriq-mc-binary;nobranch=1;protocol=https" | ||
10 | SRCREV = "d21bc22000a14b0b6eeafc017fb93bc70499f74a" | ||
11 | |||
12 | S = "${WORKDIR}/git" | ||
13 | |||
14 | REGLEX:ls2088a = "ls2088a" | ||
15 | REGLEX:ls2080a = "ls2080a" | ||
16 | REGLEX:ls1088a = "ls1088a" | ||
17 | REGLEX:lx2160a = "lx216xa" | ||
18 | REGLEX:lx2162a = "lx216xa" | ||
19 | |||
20 | do_install () { | ||
21 | install -d ${D}/boot | ||
22 | install -m 755 ${S}/${REGLEX}/*.itb ${D}/boot | ||
23 | } | ||
24 | |||
25 | do_deploy () { | ||
26 | install -d ${DEPLOYDIR}/mc_app | ||
27 | install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app | ||
28 | # make a symlink to the latest binary | ||
29 | for mc_binary in `find ${DEPLOYDIR}/mc_app -type f -printf "%f\n" |sort`;do | ||
30 | ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb | ||
31 | done | ||
32 | } | ||
33 | addtask deploy before do_build after do_install | ||
34 | |||
35 | PACKAGES += "${PN}-image" | ||
36 | FILES:${PN}-image += "/boot" | ||
37 | |||
38 | INHIBIT_PACKAGE_STRIP = "1" | ||
39 | |||
40 | COMPATIBLE_MACHINE = "(qoriq-arm64)" | ||
41 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
diff --git a/recipes-dpaa2/management-complex/management-complex_10.35.0.bb b/recipes-dpaa2/management-complex/management-complex_10.37.0.bb index d114a92e..c683654f 100644 --- a/recipes-dpaa2/management-complex/management-complex_10.35.0.bb +++ b/recipes-dpaa2/management-complex/management-complex_10.37.0.bb | |||
@@ -1,13 +1,13 @@ | |||
1 | SUMMARY = "DPAA2 Management Complex Firmware" | 1 | SUMMARY = "DPAA2 Management Complex Firmware" |
2 | LICENSE = "NXP-Binary-EULA" | 2 | LICENSE = "NXP-Binary-EULA" |
3 | LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=1db1363924ceccb1edea921b6495bdc2" | 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=481d6288552113961a835bbabceb0c33" |
4 | 4 | ||
5 | inherit deploy | 5 | inherit deploy |
6 | 6 | ||
7 | INHIBIT_DEFAULT_DEPS = "1" | 7 | INHIBIT_DEFAULT_DEPS = "1" |
8 | 8 | ||
9 | SRC_URI = "git://github.com/nxp/qoriq-mc-binary;protocol=https;nobranch=1" | 9 | SRC_URI = "git://github.com/nxp/qoriq-mc-binary;protocol=https;nobranch=1" |
10 | SRCREV = "836d7bf606b51c18b5e3726d68dcf3b3ac4de74a" | 10 | SRCREV = "bb19f586b87b97878b4bd0d3e57da2ca40c5c69f" |
11 | 11 | ||
12 | S = "${WORKDIR}/git" | 12 | S = "${WORKDIR}/git" |
13 | 13 | ||