diff options
-rw-r--r-- | recipes-dpaa2/restool/files/disable-manpage-generation.patch | 25 | ||||
-rw-r--r-- | recipes-dpaa2/restool/restool_git.bb | 15 |
2 files changed, 35 insertions, 5 deletions
diff --git a/recipes-dpaa2/restool/files/disable-manpage-generation.patch b/recipes-dpaa2/restool/files/disable-manpage-generation.patch new file mode 100644 index 00000000..ec512830 --- /dev/null +++ b/recipes-dpaa2/restool/files/disable-manpage-generation.patch | |||
@@ -0,0 +1,25 @@ | |||
1 | From 5392152e704ff001c41de03445d668227237a87e Mon Sep 17 00:00:00 2001 | ||
2 | From: Ting Liu <ting.liu@nxp.com> | ||
3 | Date: Fri, 15 Oct 2021 09:36:04 +0530 | ||
4 | Subject: [PATCH] disable manpage generation | ||
5 | |||
6 | Signed-off-by: Ting Liu <ting.liu@nxp.com> | ||
7 | --- | ||
8 | Makefile | 1 - | ||
9 | 1 file changed, 1 deletion(-) | ||
10 | |||
11 | diff --git a/Makefile b/Makefile | ||
12 | index ee669ae..ab6e499 100644 | ||
13 | --- a/Makefile | ||
14 | +++ b/Makefile | ||
15 | @@ -60,7 +60,6 @@ install: restool scripts/ls-main scripts/ls-append-dpl scripts/ls-debug scripts/ | ||
16 | install -D -m 755 scripts/ls-debug $(DESTDIR)$(bindir)/ls-debug | ||
17 | $(foreach symlink, $(RESTOOL_SCRIPT_SYMLINKS), sh -c "cd $(DESTDIR)$(bindir) && ln -sf ls-main $(symlink)" ;) | ||
18 | install -D -m 755 scripts/restool_completion.sh $(DESTDIR)$(bindir_completion)/restool | ||
19 | - install -m 0644 -D $(MANPAGE) $(call get_manpage_destination,$(MANPAGE)) | ||
20 | |||
21 | clean: | ||
22 | rm -f $(OBJ) $(MANPAGE) \ | ||
23 | -- | ||
24 | 2.25.1 | ||
25 | |||
diff --git a/recipes-dpaa2/restool/restool_git.bb b/recipes-dpaa2/restool/restool_git.bb index 7f4a93f7..3ff5afd8 100644 --- a/recipes-dpaa2/restool/restool_git.bb +++ b/recipes-dpaa2/restool/restool_git.bb | |||
@@ -2,14 +2,16 @@ SUMMARY = "DPAA2 Resource Manager Tool" | |||
2 | LICENSE = "BSD" | 2 | LICENSE = "BSD" |
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=ec8d84e9cd4de287e290275d09db27f0" | 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=ec8d84e9cd4de287e290275d09db27f0" |
4 | 4 | ||
5 | RDEPENDS:${PN} += "bash dtc" | 5 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/restool;nobranch=1 \ |
6 | 6 | file://disable-manpage-generation.patch \ | |
7 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/restool;nobranch=1" | 7 | " |
8 | SRCREV = "8ddbe4c9559ffad5d7e5dd3cd5f00ceeff7f05d4" | 8 | SRCREV = "d29522aef9f92ff2557978d5d3979b771a9576fe" |
9 | 9 | ||
10 | S = "${WORKDIR}/git" | 10 | S = "${WORKDIR}/git" |
11 | 11 | ||
12 | EXTRA_OEMAKE = 'CC="${CC}" EXTRA_CFLAGS="-O2 -Wno-missing-field-initializers -Wno-missing-braces -Wno-maybe-uninitialized -Wno-date-time"' | 12 | inherit bash-completion |
13 | |||
14 | EXTRA_OEMAKE = 'CC="${CC}" MANPAGE= EXTRA_CFLAGS="-O2 -Wno-missing-field-initializers -Wno-missing-braces -Wno-maybe-uninitialized -Wno-date-time"' | ||
13 | 15 | ||
14 | do_install () { | 16 | do_install () { |
15 | oe_runmake install DESTDIR=${D} | 17 | oe_runmake install DESTDIR=${D} |
@@ -18,3 +20,6 @@ do_install () { | |||
18 | COMPATIBLE_MACHINE = "(qoriq-arm64)" | 20 | COMPATIBLE_MACHINE = "(qoriq-arm64)" |
19 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 21 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
20 | 22 | ||
23 | RDEPENDS:${PN} += "bash dtc" | ||
24 | RDEPENDS:${PN}-bash-completion += "bash" | ||
25 | |||