summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/layer.conf6
-rw-r--r--dynamic-layers/aglprofilegraphical/recipes-graphics/wayland/weston_5.0.0.imx.bbappend2
-rw-r--r--dynamic-layers/ivi/recipes-graphics/wayland/weston_5.0.0.imx.bbappend2
-rw-r--r--recipes-graphics/wayland/weston_5.0.0.imx.bb12
4 files changed, 15 insertions, 7 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 1b71bead..93e5f97f 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -27,12 +27,18 @@ ${QORIQ_MIRROR} http://download.ossystems.com.br/bsp/freescale/source/ \n \
27" 27"
28 28
29BBFILES_DYNAMIC += " \ 29BBFILES_DYNAMIC += " \
30 aglprofilegraphical:${LAYERDIR}/dynamic-layers/aglprofilegraphical/*/*/*.bb \
31 aglprofilegraphical:${LAYERDIR}/dynamic-layers/aglprofilegraphical/*/*/*.bbappend \
32 \
30 browser-layer:${LAYERDIR}/dynamic-layers/browser-layer/*/*/*.bb \ 33 browser-layer:${LAYERDIR}/dynamic-layers/browser-layer/*/*/*.bb \
31 browser-layer:${LAYERDIR}/dynamic-layers/browser-layer/*/*/*.bbappend \ 34 browser-layer:${LAYERDIR}/dynamic-layers/browser-layer/*/*/*.bbappend \
32 \ 35 \
33 filesystem-layer:${LAYERDIR}/dynamic-layers/filesystem-layer/*/*/*.bb \ 36 filesystem-layer:${LAYERDIR}/dynamic-layers/filesystem-layer/*/*/*.bb \
34 filesystem-layer:${LAYERDIR}/dynamic-layers/filesystem-layer/*/*/*.bbappend \ 37 filesystem-layer:${LAYERDIR}/dynamic-layers/filesystem-layer/*/*/*.bbappend \
35 \ 38 \
39 ivi:${LAYERDIR}/dynamic-layers/ivi/*/*/*.bb \
40 ivi:${LAYERDIR}/dynamic-layers/ivi/*/*/*.bbappend \
41 \
36 networking-layer:${LAYERDIR}/dynamic-layers/networking-layer/*/*/*.bb \ 42 networking-layer:${LAYERDIR}/dynamic-layers/networking-layer/*/*/*.bb \
37 networking-layer:${LAYERDIR}/dynamic-layers/networking-layer/*/*/*.bbappend \ 43 networking-layer:${LAYERDIR}/dynamic-layers/networking-layer/*/*/*.bbappend \
38 \ 44 \
diff --git a/dynamic-layers/aglprofilegraphical/recipes-graphics/wayland/weston_5.0.0.imx.bbappend b/dynamic-layers/aglprofilegraphical/recipes-graphics/wayland/weston_5.0.0.imx.bbappend
new file mode 100644
index 00000000..1a896a20
--- /dev/null
+++ b/dynamic-layers/aglprofilegraphical/recipes-graphics/wayland/weston_5.0.0.imx.bbappend
@@ -0,0 +1,2 @@
1# don't install default weston.ini
2WESTON_INI_INSTALL_FILE = ""
diff --git a/dynamic-layers/ivi/recipes-graphics/wayland/weston_5.0.0.imx.bbappend b/dynamic-layers/ivi/recipes-graphics/wayland/weston_5.0.0.imx.bbappend
new file mode 100644
index 00000000..d36fbd4d
--- /dev/null
+++ b/dynamic-layers/ivi/recipes-graphics/wayland/weston_5.0.0.imx.bbappend
@@ -0,0 +1,2 @@
1# install default weston.ini for IVI
2WESTON_INI_INSTALL_FILE = "${B}/ivi-shell/weston.ini"
diff --git a/recipes-graphics/wayland/weston_5.0.0.imx.bb b/recipes-graphics/wayland/weston_5.0.0.imx.bb
index 9f32d94a..e9f354f0 100644
--- a/recipes-graphics/wayland/weston_5.0.0.imx.bb
+++ b/recipes-graphics/wayland/weston_5.0.0.imx.bb
@@ -102,6 +102,9 @@ PACKAGECONFIG[imxg2d] = "--enable-imxg2d,--disable-imxg2d,virtual/libg2d"
102# Weston with OpenGL support 102# Weston with OpenGL support
103PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl" 103PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl"
104 104
105# Set to install a default weston.ini file
106WESTON_INI_INSTALL_FILE = "${B}/weston.ini"
107
105do_install_append() { 108do_install_append() {
106 # Weston doesn't need the .la files to load modules, so wipe them 109 # Weston doesn't need the .la files to load modules, so wipe them
107 rm -f ${D}/${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.la 110 rm -f ${D}/${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.la
@@ -120,13 +123,8 @@ do_install_append() {
120 fi 123 fi
121 124
122 # install default weston.ini 125 # install default weston.ini
123 if [ -n "${@bb.utils.filter('BBFILE_COLLECTIONS', 'aglprofilegraphical', d)}" ]; then 126 if [ "${WESTON_INI_INSTALL_FILE}" != "" ]; then
124 if [ "${@bb.utils.filter('BBFILE_COLLECTIONS', 'ivi', d)}" ]; then 127 install -D -m 0644 ${WESTON_INI_INSTALL_FILE} ${D}${sysconfdir}/xdg/weston/weston.ini
125 WESTON_INI_SRCDIR=${B}/ivi-shell
126 else
127 WESTON_INI_SRCDIR=${B}
128 fi
129 install -D -m 0644 ${WESTON_INI_SRCDIR}/weston.ini ${D}${sysconfdir}/xdg/weston/weston.ini
130 fi 128 fi
131} 129}
132 130