diff options
-rw-r--r-- | recipes-bsp/firmware-qca/firmware-qca6174_2.0.bb | 27 |
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-bsp/firmware-qca/firmware-qca6174_2.0.bb b/recipes-bsp/firmware-qca/firmware-qca6174_2.0.bb new file mode 100644 index 00000000..462bf2e8 --- /dev/null +++ b/recipes-bsp/firmware-qca/firmware-qca6174_2.0.bb | |||
@@ -0,0 +1,27 @@ | |||
1 | # Copyright 2018 NXP | ||
2 | |||
3 | require firmware-qca.inc | ||
4 | |||
5 | SUMMARY = "Qualcomm Wi-Fi and Bluetooth firmware" | ||
6 | DESCRIPTION = "Qualcomm Wi-Fi and Bluetooth firmware for modules such as QCA6174A" | ||
7 | SECTION = "base" | ||
8 | LICENSE = "Proprietary" | ||
9 | |||
10 | inherit allarch | ||
11 | |||
12 | do_install () { | ||
13 | # Install firmware.conf for QCA modules | ||
14 | install -d ${D}${sysconfdir}/bluetooth | ||
15 | install -m 644 ${S}/1CQ_QCA6174A_LEA_2.0/etc/bluetooth/firmware.conf ${D}${sysconfdir}/bluetooth | ||
16 | |||
17 | # Install firmware files | ||
18 | install -d ${D}${base_libdir} | ||
19 | cp -r ${S}/1CQ_QCA6174A_LEA_2.0/lib/firmware ${D}${base_libdir} | ||
20 | } | ||
21 | |||
22 | FILES_${PN} = " \ | ||
23 | ${sysconfdir}/bluetooth/firmware.conf \ | ||
24 | ${base_libdir}/firmware/qca6174 \ | ||
25 | ${base_libdir}/firmware/wlan \ | ||
26 | ${base_libdir}/firmware/* \ | ||
27 | " | ||