summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/mc-utils/mc-utils_git.bb26
1 files changed, 10 insertions, 16 deletions
diff --git a/recipes-bsp/mc-utils/mc-utils_git.bb b/recipes-bsp/mc-utils/mc-utils_git.bb
index b725af7f..97bbd7e7 100644
--- a/recipes-bsp/mc-utils/mc-utils_git.bb
+++ b/recipes-bsp/mc-utils/mc-utils_git.bb
@@ -1,16 +1,14 @@
1DESCRIPTION = "The Management Complex (MC) is a key component of DPAA" 1DESCRIPTION = "The Management Complex (MC) is a key component of DPAA"
2SECTION = "mc-utils" 2SECTION = "mc-utils"
3LICENSE = "BSD" 3LICENSE = "BSD"
4 4LIC_FILES_CHKSUM = "file://LICENSE;md5=386a6287daa6504b7e7e5014ddfb3987"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=386a6287daa6504b7e7e5014ddfb3987 \
6"
7 5
8DEPENDS += "dtc-native" 6DEPENDS += "dtc-native"
9 7
10inherit deploy 8inherit deploy
11 9
12SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/mc-utils;nobranch=1" 10SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/mc-utils;nobranch=1"
13SRCREV = "8e0b863693fc2ccbc62a62c79b4e3db6da88c16e" 11SRCREV = "12ffee82d210cb6b5c8fa30fbc6f5d29e4be2e6f"
14 12
15S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
16 14
@@ -18,10 +16,10 @@ MC_CFG ?= ""
18MC_CFG:ls1088a = "ls1088a" 16MC_CFG:ls1088a = "ls1088a"
19MC_CFG:ls2088a = "ls2088a" 17MC_CFG:ls2088a = "ls2088a"
20MC_CFG:lx2160a = "lx2160a" 18MC_CFG:lx2160a = "lx2160a"
21MC_CFG:lx2162aqds = "lx2162aqds" 19MC_CFG:lx2162a = "lx2162a"
22 20
23MC_FLAVOUR ?= "RDB" 21MC_FLAVOUR ?= "${@oe.utils.ifelse(d.getVar('MACHINE').endswith('qds'), 'QDS', 'RDB')}"
24MC_FLAVOUR:lx2162a = "" 22MC_FOLDER ?= "${@d.getVar('MC_CFG').upper() + '-' + d.getVar('MC_FLAVOUR')}"
25 23
26do_compile () { 24do_compile () {
27 oe_runmake -C config 25 oe_runmake -C config
@@ -29,23 +27,19 @@ do_compile () {
29 27
30do_install () { 28do_install () {
31 install -d ${D}/boot/mc-utils 29 install -d ${D}/boot/mc-utils
32 cp -r ${S}/config/${MC_CFG}/${MC_FLAVOUR}/*.dtb ${D}/boot/mc-utils 30 if [ -e ${S}/config/${MC_CFG}/${MC_FOLDER} ]; then
33 if [ -d ${S}/config/${MC_CFG}/${MC_FLAVOUR}/custom/ ]; then 31 cp -r ${S}/config/${MC_CFG}/${MC_FOLDER}/* ${D}/boot/mc-utils/
34 install -d ${D}/boot/mc-utils/custom
35 cp -r ${S}/config/${MC_CFG}/${MC_FLAVOUR}/custom/*.dtb ${D}/boot/mc-utils/custom
36 fi 32 fi
33 find ${D}/boot/mc-utils/ ! -name "*.dtb" ! -type d -exec rm {} \;
37} 34}
38 35
39do_deploy () { 36do_deploy () {
40 install -d ${DEPLOYDIR}/mc-utils 37 install -d ${DEPLOYDIR}/mc-utils
41 cp -r ${S}/config/${MC_CFG}/${MC_FLAVOUR}/*.dtb ${DEPLOYDIR}/mc-utils 38 cp -r ${D}/boot/mc-utils/* ${DEPLOYDIR}/mc-utils/
42 if [ -d ${S}/config/${MC_CFG}/${MC_FLAVOUR}/custom/ ]; then
43 install -d ${DEPLOYDIR}/mc-utils/custom
44 cp -r ${S}/config/${MC_CFG}/${MC_FLAVOUR}/custom/*.dtb ${DEPLOYDIR}/mc-utils/custom
45 fi
46} 39}
47addtask deploy after do_install 40addtask deploy after do_install
48 41
49PACKAGES += "${PN}-image" 42PACKAGES += "${PN}-image"
50FILES:${PN}-image += "/boot" 43FILES:${PN}-image += "/boot"
44PACKAGE_ARCH = "${MACHINE_ARCH}"
51COMPATIBLE_MACHINE = "(qoriq-arm64)" 45COMPATIBLE_MACHINE = "(qoriq-arm64)"