summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/rcw/rcw_git.bb13
1 files changed, 8 insertions, 5 deletions
diff --git a/recipes-bsp/rcw/rcw_git.bb b/recipes-bsp/rcw/rcw_git.bb
index 81178617..e00c0a6e 100644
--- a/recipes-bsp/rcw/rcw_git.bb
+++ b/recipes-bsp/rcw/rcw_git.bb
@@ -8,17 +8,21 @@ DEPENDS += "change-file-endianess-native tcl-native"
8inherit deploy 8inherit deploy
9 9
10SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git;branch=sdk-v2.0.x" 10SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git;branch=sdk-v2.0.x"
11SRCREV = "6ae9086528019ab55968da05c25bd319737c8e62" 11SRCREV = "3252b8cce8e5a214c8e652121ef9b9460663c65a"
12 12
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14 14
15EXTRA_OEMAKE = "BOARDS=${@d.getVar('MACHINE', True).replace('-64b','')} DESTDIR=${D}/boot/rcw/" 15EXTRA_OEMAKE = "BOARDS=${@d.getVar('MACHINE', True).replace('-64b','').replace('-32b','')} DESTDIR=${D}/boot/rcw/"
16 16
17do_install () { 17do_install () {
18 oe_runmake install 18 oe_runmake install
19 for f in `find ${D}/boot/rcw/ -name "*qspiboot*"`;do 19 for f in `find ${D}/boot/rcw/ -name "*qspiboot*"`;do
20 if echo $f |grep -q "qspiboot_sben"; then
21 continue
22 fi
20 f_swap=`echo $f |sed -e 's/qspiboot/qspiboot_swap/'` 23 f_swap=`echo $f |sed -e 's/qspiboot/qspiboot_swap/'`
21 tclsh ${STAGING_BINDIR_NATIVE}/byte_swap.tcl $f $f_swap 8 24 tclsh ${STAGING_BINDIR_NATIVE}/byte_swap.tcl $f $f_swap 8
25 mv -f $f_swap $f
22 done 26 done
23} 27}
24 28
@@ -31,6 +35,5 @@ addtask deploy after do_install
31PACKAGES += "${PN}-image" 35PACKAGES += "${PN}-image"
32FILES_${PN}-image += "/boot" 36FILES_${PN}-image += "/boot"
33 37
34COMPATIBLE_MACHINE = "(qoriq-ppc|ls1021a|ls1043a)" 38COMPATIBLE_MACHINE = "(qoriq)"
35PACKAGE_ARCH = "${MACHINE_SOCARCH}" 39PACKAGE_ARCH = "${MACHINE_ARCH}"
36