summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/cairo/cairo_%.bbappend2
-rw-r--r--recipes-graphics/xwayland/xwayland_%.bbappend7
2 files changed, 8 insertions, 1 deletions
diff --git a/recipes-graphics/cairo/cairo_%.bbappend b/recipes-graphics/cairo/cairo_%.bbappend
index 245adb59..c61e9a58 100644
--- a/recipes-graphics/cairo/cairo_%.bbappend
+++ b/recipes-graphics/cairo/cairo_%.bbappend
@@ -3,6 +3,6 @@ PACKAGECONFIG:remove:imxgpu3d = "opengl"
3 3
4# links with imx-gpu libs which are pre-built for glibc 4# links with imx-gpu libs which are pre-built for glibc
5# gcompat will address it during runtime 5# gcompat will address it during runtime
6LDFLAGS:append:imxgpu3d:libc-musl = " -Wl,--allow-shlib-undefined"
7LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined" 6LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined"
8 7
8RDEPENDS:${PN}:append:imxgpu:libc-musl = " gcompat"
diff --git a/recipes-graphics/xwayland/xwayland_%.bbappend b/recipes-graphics/xwayland/xwayland_%.bbappend
index 69063121..f2141f4f 100644
--- a/recipes-graphics/xwayland/xwayland_%.bbappend
+++ b/recipes-graphics/xwayland/xwayland_%.bbappend
@@ -10,3 +10,10 @@ OPENGL_PKGCONFIGS_REMOVE_IMXGPU = ""
10OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx6-nxp-bsp = "glamor glx" 10OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx6-nxp-bsp = "glamor glx"
11OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx7-nxp-bsp = "glamor glx" 11OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx7-nxp-bsp = "glamor glx"
12OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx8-nxp-bsp = "glx" 12OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx8-nxp-bsp = "glx"
13
14
15# links with imx-gpu libs which are pre-built for glibc
16# gcompat will address it during runtime
17LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined"
18
19RDEPENDS:${PN}:append:imxgpu:libc-musl = " gcompat"