diff options
-rw-r--r-- | recipes-bsp/u-boot/u-boot-imx_2017.03.bb | 2 | ||||
-rw-r--r-- | recipes-kernel/dtc/dtc-145_git.bb | 12 | ||||
-rw-r--r-- | recipes-kernel/dtc/files/make_install.patch | 17 |
3 files changed, 30 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot-imx_2017.03.bb b/recipes-bsp/u-boot/u-boot-imx_2017.03.bb index 72205676..52ebee99 100644 --- a/recipes-bsp/u-boot/u-boot-imx_2017.03.bb +++ b/recipes-bsp/u-boot/u-boot-imx_2017.03.bb | |||
@@ -6,7 +6,7 @@ DESCRIPTION = "i.MX U-Boot suppporting i.MX reference boards." | |||
6 | require recipes-bsp/u-boot/u-boot.inc | 6 | require recipes-bsp/u-boot/u-boot.inc |
7 | 7 | ||
8 | PROVIDES += "u-boot" | 8 | PROVIDES += "u-boot" |
9 | DEPENDS_append = "dtc-native" | 9 | DEPENDS_append = "dtc-145-native" |
10 | 10 | ||
11 | LICENSE = "GPLv2+" | 11 | LICENSE = "GPLv2+" |
12 | LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263" | 12 | LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
diff --git a/recipes-kernel/dtc/dtc-145_git.bb b/recipes-kernel/dtc/dtc-145_git.bb new file mode 100644 index 00000000..afed62fd --- /dev/null +++ b/recipes-kernel/dtc/dtc-145_git.bb | |||
@@ -0,0 +1,12 @@ | |||
1 | require recipes-kernel/dtc/dtc.inc | ||
2 | |||
3 | LIC_FILES_CHKSUM = " \ | ||
4 | file://GPL;md5=94d55d512a9ba36caa9b7df079bae19f \ | ||
5 | file://libfdt/libfdt.h;beginline=3;endline=52;md5=fb360963151f8ec2d6c06b055bcbb68c \ | ||
6 | " | ||
7 | |||
8 | SRCREV = "22a65c5331c22979d416738eb756b9541672e00d" | ||
9 | |||
10 | S = "${WORKDIR}/git" | ||
11 | |||
12 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/recipes-kernel/dtc/files/make_install.patch b/recipes-kernel/dtc/files/make_install.patch new file mode 100644 index 00000000..ccf17b38 --- /dev/null +++ b/recipes-kernel/dtc/files/make_install.patch | |||
@@ -0,0 +1,17 @@ | |||
1 | Upstream-Status: Inappropriate [configuration] | ||
2 | |||
3 | Index: git/Makefile | ||
4 | =================================================================== | ||
5 | --- git.orig/Makefile | ||
6 | +++ git/Makefile | ||
7 | @@ -168,8 +168,8 @@ install-bin: all $(SCRIPTS) | ||
8 | install-lib: all | ||
9 | @$(VECHO) INSTALL-LIB | ||
10 | $(INSTALL) -d $(DESTDIR)$(LIBDIR) | ||
11 | - $(INSTALL) $(LIBFDT_lib) $(DESTDIR)$(LIBDIR) | ||
12 | - ln -sf $(notdir $(LIBFDT_lib)) $(DESTDIR)$(LIBDIR)/$(LIBFDT_soname) | ||
13 | + $(INSTALL) $(LIBFDT_lib) $(DESTDIR)$(LIBDIR)/$(LIBFDT_soname) | ||
14 | + ln -sf $(LIBFDT_soname) $(DESTDIR)$(LIBDIR)/$(notdir $(LIBFDT_lib)) | ||
15 | ln -sf $(LIBFDT_soname) $(DESTDIR)$(LIBDIR)/libfdt.$(SHAREDLIB_EXT) | ||
16 | $(INSTALL) -m 644 $(LIBFDT_archive) $(DESTDIR)$(LIBDIR) | ||
17 | |||