summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.6.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.6.bb b/recipes-bsp/imx-atf/imx-atf_2.6.bb
index 1df61cab..b0426f0b 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.6.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.6.bb
@@ -29,9 +29,7 @@ EXTRA_OEMAKE += " \
29 29
30# Let the Makefile handle setting up the CFLAGS and LDFLAGS as it is a standalone application 30# Let the Makefile handle setting up the CFLAGS and LDFLAGS as it is a standalone application
31CFLAGS[unexport] = "1" 31CFLAGS[unexport] = "1"
32# Needed for binutils >= 2.39 to prevent build failure. 32LDFLAGS[unexport] = "1"
33# imx-atf links with ld, thus no '-Wl,' prefix
34LDFLAGS = "--no-warn-rwx-segments"
35AS[unexport] = "1" 33AS[unexport] = "1"
36LD[unexport] = "1" 34LD[unexport] = "1"
37 35
@@ -58,6 +56,7 @@ EXTRA_OEMAKE += 'IMX_BOOT_UART_BASE=${ATF_BOOT_UART_BASE}'
58do_configure[noexec] = "1" 56do_configure[noexec] = "1"
59 57
60do_compile() { 58do_compile() {
59 # Clear LDFLAGS to avoid the option -Wl recognize issue
61 oe_runmake bl31 60 oe_runmake bl31
62 if ${BUILD_OPTEE}; then 61 if ${BUILD_OPTEE}; then
63 oe_runmake clean BUILD_BASE=build-optee 62 oe_runmake clean BUILD_BASE=build-optee