summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.6.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.6.bb b/recipes-bsp/imx-atf/imx-atf_2.6.bb
index b0426f0b..1df61cab 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.6.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.6.bb
@@ -29,7 +29,9 @@ EXTRA_OEMAKE += " \
29 29
30# Let the Makefile handle setting up the CFLAGS and LDFLAGS as it is a standalone application 30# Let the Makefile handle setting up the CFLAGS and LDFLAGS as it is a standalone application
31CFLAGS[unexport] = "1" 31CFLAGS[unexport] = "1"
32LDFLAGS[unexport] = "1" 32# Needed for binutils >= 2.39 to prevent build failure.
33# imx-atf links with ld, thus no '-Wl,' prefix
34LDFLAGS = "--no-warn-rwx-segments"
33AS[unexport] = "1" 35AS[unexport] = "1"
34LD[unexport] = "1" 36LD[unexport] = "1"
35 37
@@ -56,7 +58,6 @@ EXTRA_OEMAKE += 'IMX_BOOT_UART_BASE=${ATF_BOOT_UART_BASE}'
56do_configure[noexec] = "1" 58do_configure[noexec] = "1"
57 59
58do_compile() { 60do_compile() {
59 # Clear LDFLAGS to avoid the option -Wl recognize issue
60 oe_runmake bl31 61 oe_runmake bl31
61 if ${BUILD_OPTEE}; then 62 if ${BUILD_OPTEE}; then
62 oe_runmake clean BUILD_BASE=build-optee 63 oe_runmake clean BUILD_BASE=build-optee